Can't boot usb in UEFI mode

Hi everyone!

My problem is that when I try to boot the installation USB in UEFI Mode my screen flashes black and returns to the boot device selection screen. I have no problems in booting other distros (Ubuntu, Fedora…) but with OpenSUSE its being impossible. I’ve tried both, secure boot enabled and disabled. However, I am able to boot and install in legacy mode, but I’d prefer using UEFI so I can keep my windows partition as it is.

Thank you.

Hi
What is the system hardware, dual graphics cards?

At the grub menu, highlight the install part and press e to edit, in the linux line down the page with quiet etc in it, add the option nomodeset at the end and press F10 to boot, does this help?

I can neither get de grub menu. If I try to run de USB it inly flashes black and returns to the bios boot device selection screen.

My laptop is a Lenovo Thinkpad X1 Yoga 2nd gen (only intel integrated graphics, kaby lake i7 processor)

Hi
Hmmm, maybe 32bit UEFI only…? Could also be the USB port, are they all 3.0, or have a 2.0 or legacy bios option for USB?

The bios is 64 bit, as I said, other distros work without problem so I don’t know. But if it’s because of the ports, yes, they are all usb 3.0

Hi
In the BIOS, is there a legacy USB option? Or try a different port on the device…

No, no legacy USB option and already tried all ports

Hi
How did you lay down the image to the usb device, dd, imagewriter etc? Do you have a different USB device you can try, or try a live/rescue Tumbleweed…

OH, you did check the sha256sum of the download?

I’ve tried three last snapshots, and yes checked the sum. I’ve also tried many different methods for writing the imagge(dd from linux, image writers, rufus on wondows…)

Hi
Can you try a Tumbleweed live version and just use dd to copy the image, also try a different USB device if you have one… 4GB will be fine for a live system.

As far as I know, it should work if secure-boot is disabled. Maybe try that again.

I have a Lenovo ThinkServer, which had a similar problem. But it was okay with secure-boot disabled.

The specific problem is that the opensuse efi bootcode is digitally signed by both Microsoft and by opensuse. Some Lenovo machines come with firmware that doesn’t understand multiple signatures.

Ubuntu and Fedora both use only the Microsoft signature. And if my conjecture is right, that’s why they work but opensuse doesn’t work.

So give it another try. Disable secure-boot. In your firmware (BIOS), set it to prefer UEFI. Perhaps even disable CSM. Then see if it will boot opensuse.

I should add that, on my Lenovo, a later BIOS update fixed the problem and now it can hand two signatures.

An added comment. This might not apply to your system.

Apparently there’s a bug in Ubuntu 17.10, which corrupts the BIOS. One symptom, is that you can no longer boot a USB. Some Lenovo laptops, and a few others, are known to be vulnerable.

If you check the Ubuntu download page, you will see that they pulled the download for 17.10, with a link explaining the issue.

Hi
Just been asked about in the openSUSE Kernel ML…

ML Ref: [opensuse-kernel] Intel-SPI vs. Lenovo - openSUSE Kernel - openSUSE Mailing Lists
Ub* Bug Ref: Bug #1734147 “corrupted BIOS due to Intel SPI bug in kernel” : Bugs : linux package : Ubuntu

Thanks. And interesting.

I’ve also been wondering. I have recently seen reports of USB problems in the opensuse bugzilla, and perhaps on the factory mailing list (not sure about that one).

I just booted up Ubuntu 17.10, in a virtual machine where I have it installed. And it silently updated the kernel. The new kernel was compiled on Monday Dec 18th, and the intel-spi driver is missing. I’m a bit surprised that they did this silently, without any warning to reboot. But perhaps they have not had enough time to get their act together.

On Wed 20 Dec 2017 08:16:01 PM CST, nrickert wrote:

malcolmlewis;2848733 Wrote:
> Hi
> Just been asked about in the openSUSE Kernel ML…

Thanks. And interesting.

I’ve also been wondering. I have recently seen reports of USB problems
in the opensuse bugzilla, and perhaps on the factory mailing list (not
sure about that one).

I just booted up Ubuntu 17.10, in a virtual machine where I have it
installed. And it silently updated the kernel. The new kernel was
compiled on Monday Dec 18th, and the intel-spi driver is missing. I’m a
bit surprised that they did this silently, without any warning to
reboot. But perhaps they have not had enough time to get their act
together.

Hi
It’s still present in Tumbleweed… but the writeable parm is set to
disable by default. I wonder what the fix will be…don’t think
replacing the BIOS chip or motherboard will be an option…


Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE Leap 42.2|GNOME 3.20.2|4.4.92-18.36-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

From the available information it is not related; damage happens not during write, but during initialization (actually, it probably leaves flash read-only).

The wiki says that UEFI CANNOT be installed by USB, only by DVD.

I’m not sure where you saw that. I couldn’t find it. However, I did find:
“Secure Boot support in openSUSE 12.3 is still considered experimental.”

Maybe that Wiki entry is just a little out of date.

All of my UEFI installs have been via a USB. I started with 12.3. Before that time, the instructions for installing with a USB were complex. You had to use two USB flash drives. One was for the installer, and the other was to have an EFI partition on a USB for booting into the installer. There was an image for that USB on the DVD. Fedora had similar instructions at that time. I guess that changed when “syslinux” came out with a version of “isohybrid” that supported a small EFI partition as part of the hybrid structure.

Hi
All of my installs are via USB device, the only issue I’ve had is with USB 3.0 ports. I installed Leap 42.3 on this machine last night (HP 255 G4) USB 3.0 was a no go connected to the USB 2.0 port and all was good…