can't boot to x

At the time, the connection to the repo was down. It’s ok now. I will continue with your instructions.

According to zypper dup, I am to upgrade 16 packages and downgrade 222 (!) packages - so I should go ahead?

Did you change the repo as I instructed?

Assuming you answer yes, then YES, go ahead

Well the zypper dup worked like a charm. No problems so far. Now I add repos 17 and 21 and then packman the way you mentioned? Do I need to run zypper dup again after this?

And “yes” I made the repo change you suggested.

Yes add those then do the package switcher on Packman:

In kde it looks like this

In gnome like this

If you get a error, use the expert button, save it to file and post the content here

I’m using LXDE. Do I run zypper dup again after all this?

Apply the switch and you are done.

You will probably have a number of packages we call orphaned (they are from the repos you deleted and where no match exists in your current repos)
I would just leave them. If they are actual applications, it’s likely they will still work anyway.

I am not finding an option to switch packages to Packman - really searched hard…as I said I’m using LXDE. Any other options? If I increased the priority number beyond 99 for Packman and then ran zypper dup again, would that help?

Please post a screen shot of Yast software management

and your repo list with

zypper lr -d

I’ve taken a screen shot but I’m not sure how to show it to you. There are no attachment options that I can see nor do I know how to give and url. sorry

1 | | NVIDIA Repository | Yes | Yes | 99 | rpm-md | |
2 | non-oss | non-oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.4/repo/non-oss |
3 | openSUSE-11.4-Oss | openSUSE-11.4-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.4/repo/oss |
4 | | libdvdcss repository | Yes | Yes | 99 | rpm-md | |
5 | | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /suse/openSUSE_11.4/ |
6 | repo-update | openSUSE-11.4-Update | Yes | Yes | 99 | rpm-md | Index of /update/11.4

do the following

screens can be posted via
SUSE Paste

zypper dup -r 5

Thanks! You are always there at the computer. I hope you sleep too :slight_smile:

SUSE Paste

Look again. That is the gnome UI
You need to select repo view and then select packman

Or just try the dup command I gave above

It’s AM here
So no sleep for at least 14 hrs now

I’ll be away for about 1hr - starting now

Ok. I have done it all without any errors. But I still have the same issue of not being able to boot into X. Here is my /var/log/boot.msg SUSE Paste


Please post result of

/sbin/lspci -nnk

SUSE Paste

Have you ever been able to boot to X?

My system has ran perfectly for the past year under opensuse. No problems at all. Screen resolution and responsiveness are good. I’m fairly sure my nvidia driver is being used (and not a generic one -vesa) as I use Stellarium (planetarium software) which lags terribly with the wrong driver.

The only change I can remember doing between boots when this happend is I wiped out an entry in “after.local”. It was “mlnet” which when loaded at boot, halted the boot process. I’ve noticed that now during boot, “after.local” is being checked. Is that normal?

X works fine with “failsafe” but obviously not nvidia