Can't boot to GUI after update

Hello everybody,

today, I updated my OpenSuse 11.1 to 11.3. Since then, I can no longer enter GNOME, just the shell. Something like “gdmdisplay lasted x seconds” is diplayed several times. I have read on the web that there is a problem with NVIDIA cards (I have a Geforce 6200 LE). So far, I tried the following:

  1. typing “nomodeset” to the boot options

  2. adding device=“fbdev” to /etc/X11/xorg.conf.d/50-device.conf, then blacklisting nouveau

  3. installing the proprietary nvidia driver:

zypper ar -f nvidia
zypper install x11-video-nvidiaG02

When I do this, the system tries to retrieve metadata for the nvidia repository for a long time, then times out. And yes, I have internet, ping works.

  1. downloading the nvidia driver and installing it manually - this aborts with the message that “kernel-source” can’t be found.

Nothing of the above worked, so I am here, desperately asking you. Please help me. I’m writing this from Windows. that’s so humilating.

You say ‘Update’ from 11.1 > 11.3
Or I hope you mean ‘New Install’

nVidia Driver via Repo in 11.3 - Guide

openSUSE Graphic Card Practical Theory Guide for Users

Well, I used the DVD, which offered me to update my old Version. So, I didn’t update it via network, if that is what you mean. And thank you for the links, but I had already read them, and, as I wrote, the steps recommended there did not work.

Please try running this as su -
from the CLI

**zypper ref

zypper up**

By the way, how can I install the dependencies for the nvidia driver (gcc, make and
kernel-sources) manually? I tried “zypper install kernel-source”, but then again, after trying to retrieve metadata for the nvidia repository for a long time, zypper times out.

You can get to yast like this
Boot to Level 3, then Yast and More…

Both zypper ref and zypper up result in zypper looking for the metadata for the nvidia repository.

Go to yast the way I showed
Check your packages and install what you may need

Maybe I have ruined the system completely, but installing software with yast does not work, just as it does not work with zypper. When I go to Yast’s “Software managment” section, it simply tries to load the repositories for a long time, but doesn’t finish it. I tried to disable the Nvidia repository via yast, but yast software managment still doesn’t finish loading, and when I try to install something via zypper, it doesn’t do anything, not even showing a message. It’s hopeless.

Looks like a New install is in order

But if 11.3 does not work with my graphical device now - why should it do that next time? A new install would just bring me back to the start of my journey. Or maybe I should go back to 11.1?

A clean install (keep /home if you must) should work out of the box.
Every install I have done of 11.3 with nvidia graphics has work just fine without installing the nvidia driver.
I did one yesterday on a GeForce8 11.3 Gnome, all done in under an hour with all the updates and full multi-media

Though in that case I didn’t add the nvidia driver, in most I have after it’s running.
No messing, just as described here:
nVidia Driver via Repo in 11.3 - Guide

I see no reason why it should not work

I couldn’t believe it, but you’re right. A new install worked. I didn’t even have to apply the steps from your guide. Thank you for your support!

No problem.
Happy to help