Can't boot SUSE

I am just new to Linux and installed SUSE 10.0 (I was out of internet for three weeks and it is the only version I had here) at my secondary machine. I had to clicked away some error messages via “ignore” during the installation (once I clicked at “abort” but it did cancel the whole installation =/), but I have installed many bonus programms, so it doesn’t have to be a serious issue for sure.
How ever, when I want to boot the OS, I first have to hit F1 to continue in BIOS, then after I select my Linux boot version I get the following error message:

 VFS: Cannot open root device "hda3" or unknown-block(0,0)
Please append a correct "root=" boot option
 Kernel Panic - not syncing: VFS: Unable to mountroot fs on unknown-block (0,0)

So, any ideas?

You can reed all about SUSE here: Lampdocs: Documenting the Open Source

So are you saying that you did successfully install 10.0 but now the machine will not boot? Did the machine boot before, or is this the first time you’ve tried to boot after installation?

From the error message, it appears that the grub boot command may be in error. But it could be something else, more serious (especially given you did a number of "ignore"s at installation).

What is the 10.0 media that you have? Do you have a LiveCD?

The first time I tried to boot after installation.
I don’t have a LiveCD.

If you do not have a live CD you will want to use the rescue mode option on the openSUSE install disk to check your grub configuration.

In the Grub configuration stanza root=/dev/hda3 specifies the partition that the top level directory, root directory, has been installed on. The syntax root(hd0,1) specifies the location of the grub boot loader files.

Since this is your first boot and you are receiving a GRUB screen that means that the configuration was successfully created during the install and the pointer was added to your master boot record.

It is possible that your hard drive may have bad sectors of blocks so I would also run FSCK on that partition as well as run bad blocks to check your hard drive for problems. FSCK, as well as other checks, can be performed through rescue mode on the install disk as well.

If you did have errors during the install and chose to ignore and skip them you may be missing some dependencies. If the options above do not help than you may want to perform a repair.

Since this is an entirely new install, the fastest & easiest would be to just try installing again fresh. The error message suggests a problem in the grub boot control file (/boot/grub/menu.lst), but that is by no means for sure. When you reinstall, pay close attention to the partition setup (write it down). Also, when you get to the boot loader step, go into the dialog and check the boot stanza - the parameters are displayed on the Section Management screen; if you highlight the section line and click Edit, the next screen will show you the root device used. Or, you can click on Other (bottom right), then on Edit Configuration Files, and you’ll be taken to a screen where you can see the actual contents of menu.lst. Verify that the line which begins with “kernel” has a phrase in it like “root=” followed by an identifier of the partition (the error message suggested this was wrong).

Eh…the installation took 6-7 hours or something like that :X (With many extra programms installed)

Sorry for D-P, but which login I must enter in the rescue system? Can’t recall that I created any account or something like that.

6+ hours??? I presume you were installing from a CD or DVD, rather than from the internet - in which case, that is way too long and therefore a bit suspicous.

In any event - and assuming this was true with 10.0; that was quite a long while ago - when you boot into the Rescue System you have loaded a barebones installation into the machine’s memory. The logon is simply “root”; there will be no password required as you are not logging into your installed system. To get to your installed system and the grub configuration file (I presume this is what you’re trying to do, per Tim’s post), you need to first mount your root partition, thus:

mount -t <filesystem type> /dev/<partition> /mnt

IIRC, back at 10.0 the default filesystem was reiserfs; for some time now it has been ext3. So in the above command you need to supply whichever filesystem type you actually used. The <partition> will be something like hda1; you can look at the partition table with the “fdisk -l” command (w/o quotes).

Once mounted, the file is at /mnt/boot/grub/menu.lst. Look for the line in the stanza beginning with “kernel”, for the phrase “root=”. It should be “root=/dev/<partition>” with <partition> being the same one you just mounted. If it is not, you can change that at boot time on-the-fly from the grub menu, and then once booted in, correct the file. If the phrase is correct, then the problem is elsewhere.

The <partition> will be something like hda1; you can look at the partition table with the “fdisk -l” command (w/o quotes).

I guess it is the one with “system”:“linux”? Or is it the linux swap/solaris partition?

> I am just new to Linux and installed SUSE 10.0

i can think of NO valid reason to help someone install an operating
system which is NOT supported with security updates…

that is just ASKING for trouble…

Basinator, i’d recommend you install openSUSE 10.3 or later…


As I wrote before, it was the only version I had when I was out of internet, and I believe that such version upgrades are even possible after the installing of the OS, so I can do them later with out redownloading the whole OS again.

@Basinator -

Yes, in the fdisk report the root will show as type “linux” in the system column. But please note that if you set up /home on its own partition, you will have at least 2 partitions identified as “linux”; you’ll need to choose whichever one is the root. To verify you mounted the correct one, just do:

ls /mnt

If you mounted the root, you’ll see over a dozen files/directories listed. If you mounted home, you’ll see only a couple.

By the way, if your intention is to later upgrade 10.0, I must strongly advise that the only safe way to do so will be to do a “clean” (or “fresh”) install, which will reformat the root partition (as opposed to an “in place” upgrade which updates the existing files). That will be a very major upgrade - something akin to upgrading from Windows XP to Windows 7. Virtually every file in the system must be replaced. A very significant amount of the configuration is fundamentally restructured. Methods have changed dramatically since 10.0. The kernel now does a whole lot entirely differently from then. I understand that at the moment 10.0 is your only option. Please just know that when it comes time for you to upgrade, you will need to use the clean install method from the DVD. Note that if you have used a separate /home partition, you can do a clean install reformatting the root but still leaving /home intact, thereby preserving your user data.

Eh…atm I am with internet access, but I will have to redownload a mass of data then. However, any option that I can install the new SUSE but with the old programms at my 10.0 DVD? So I won’t have had to download them as well?
Or do I have to download all progs again? Which download I should take then (the download with the most bonus programms ^^)? I choose DVD³ for now…

The programs you know from 10.0 have grown with the rest of linux. I lately helped someone upgrade from 9.3 by a clean 11.1 install and she was supprised. All things she had gotten used to were there, but they had evolved to things she wouldn’t have dreamt of. So your programs will be there in 11.1, but in a newer state and more polished.

Can you give a list of programs you heavily use ?

If you want to keep your download to the minimum, while the DVD is over 4GB the LiveCD is under 1GB. Any additional software you want that comes with the DVD, can be downloaded from the repositories. In other words, with the DVD you get almost everything (except of course for programs from Packman; you will definitely want some of those), while with the CD you get a basic install and then selectively download whatever other packages you want.

The only downside to using the LiveCD is that it does not provide the same level of control during installation as does the DVD - on some machines, only the DVD will work. So there is a possibility that once having downloaded the LiveCD, a user may have to still download the DVD. This does not happen very often, but it does happen.

Nope sry, I just installed tons of progs with SUSE - As stated in my first post, it was my first linux installation so I don’t really know the programms - but I simple dont want to re-download them all…argh we shall see if I do or not.
Which is the DL version with all those extra programms? DVD³?

As I posted just above, the DVD contains most (not quite all) of the programs included with the offical release. All the programs in the release are in the software download repository (I assume you know what the repositories are). In addition to what is included with the official release, there are unofficial software repositories with quite a lot of additional software. The most popular of these repo’s are described here Additional YaST Package Repositories.

OK, I did download the installation DVD, burned the image on a DVD, then inserted it…nothing happened. I didn’t got any message, couldn’t access the DVD (double-layer, but the 10.0 install-dvd is a d-l, too). I checked the files at it, they are there. Haven’t tried it till yet with my primary machine. Any ideas?
(I can’t access to the DVD in the BIOS at my 2nd PC)

It is much better to actually boot from the DVD; is that not an option?

If you are trying to start the installer from within Windows, Windows does not always recognize the file on the media (this is not uncommon). So what you can do is to open the DVD in Windows Explorer and double-click on the file openSUSE11_1_LOCAL.exe, that will start the installer.

Please note that some Vista users have reported problems installing from within Windows. Most Vista machines do not come with recovery media (except to completely restore the machine to its factory state). If you have Vista, it is highly recommended to have a copy of the Vista Recovery Disc. You can get that here Windows Vista Recovery Disc.

Also please note that before installing any additional operating system, it is strongly recommended that the user have a verified backup. If you already installed 10.0 and so you have already re-partitioned the disk, that reduces the risk significantly. But still a good practice to have that backup, regardless.

Good luck.