Can't boot OpenSUSE Leap 42.3 from Live USB: "error: no such device: /efi/boot/fallback.efi"

I’m currently dual-booting Windows 10 Pro and Linux Mint 18.3 Cinnamon. I’ve created a Live USB drive (I’ve tried with both Etcher and Rufus, they produce the same results), but when I try to boot from it by selecting “Boot from Hard Disk” in the options menu that appears, I get an error message saying “error: no such device: /efi/boot/fallback.efi”. I’ve tried disabling secure boot and fast boot and also setting my UEFI to run in legacy mode. Before creating a Live USB, I verified the checksum to check that the iso had downloaded correctly.

I read on another forum post that I could make a copy of bootx64.efi (in /EFI/BOOT on the Live USB)and rename it fallback.efi, but in creating the Live USB, the EFI partition has been made a certain size, and there isn’t enough space to duplicate bootx64.efi.

In the options menu that appears when I try to boot from the USB, I’ve also tried selecting “Installation”. When I do so, I get a long series of quickly scrolling messages on my screen, ending with a message about starting udev, and then my screen goes black and my monitor doesn’t detect a signal. The same also happens when I try “Rescue System” or “Check Installation Media”. I’ve tried waiting for something to happen and also pressing pretty much every key on my keyboard. The only thing I can do from there is manually switching off my PC on from the power button.

If anybody thinks they can help with this problem, it would be hugely appreciated. Thanks!

Which Live image? The “Boot from hard disk” option is the first option on the install DVD, meant to start an already installed system on internal hard disk. With a Live image booting from USB should have “Start KDE Live” or “Start GNOME Live” or something like that.
Re. the other issue mentioned: how long did you wait? Did you try booting in Safe mode?

There’s actually an open bug report on this: Bug 1089624 “Boot from Hard Disk” on DVD install fails

Okay, you used a USB, but it’s the same problem (only worse).

The honest answer, is that this boot menu option attempts to do the impossible. And sometimes it actually works. But sometimes it fails. There isn’t a perfect solution.

My take is that this boot option has a limited purpose – you have just installed openSUSE, and now you want to boot into the just installed system. The most reliable way to do this is:

  • reboot
  • when you get to the boot menu, unplug the USB or unload the CD/DVD
  • hit CTRL-ALT-DEL and try again

And yes, even this does not work with some systems.

As you have Mint, do not bother with the MS Windows stuff – it is unnecessarily complicated.
E.g. assuming that your USB drive is found at /dev/sdb

>  wget -Nc

> sha256 -c openSUSE_Argon.x86_64-5.10.90-Build3.281.iso.sha256
openSUSE_Argon.x86_64-5.10.90-Build3.281.iso: OK
sha256sum: WARNING: 14 lines are improperly formatted

> sudo dd bs=4K if=openSUSE_Argon.x86_64-5.10.90-Build3.281.iso.sha256  of=/dev/sdb

Should result in a bootable Live KDE USB stick based on Leap-42.3.

It appears that I had misread the question.
As all my present machines require active intervention to boot from a USB stick rather than a fixed drive I had never seen this bug until I experimented a few minutes ago.