can't boot on opensue after windows 10 update

Hi to everyone, this is m first post!
I have a problem in my dual boot laptop on startup: after windows 10 update I have no more grub, but the laptop boot directly on windows. I have gpt partition on uefi system and secureboot enabled. With win8.1 i did not have ever any problems. Can anyone help me? I can’t reinstall opensuse
Thanks in advance

At the boot machine splash window select the EFI boot menu. The keys may be different on different computers maybe F10 or F12. See if you can select openSUSE there. I suspect Win 10 put itself first as default boot.

You should not have to but why do you say you can not install openSUSE???

If per chance Win10 wiped the EFI boot partition then you will have to at least boot from a live openSUSE DVD/USB to repair But I suspect Windows just mad itself first boot

Hi golgathorp!
I’ve selected booting opensuse from uefi boot menu, but my laptop returns an error. It says that can’t load file \EFI\opensuse\shim.efi because is missing or contains errors, so it invites me to repair from dvd of windows installation. I’ve tried that, but I can’t resolve

Because I haven’t /home partition in my installation and I can’t lose my data

Windows can not fix that do not even try. While trying to fix things maybe best to turn secure boot off. It a placebo anyway because if a program can modify the boot stack you are pawned anyway.

So Win 10 blasted the openSUSE entry. Probably simply erased all of the efi boot partition and started it over. To hell with anything else you may have installed. Thanks MS for a inferior product.

Get live openSUSE iso put on DVD or USB boot from that run Yast-boot loader Look at all options be sure that it is pointed to the correct drive (there is a button on the first tab for that) be sure that grub-efi is the boot loader be sure that scan for foreign OS is checked. accept then it should reinstall grub.

If you are unsure of anything ask before trying blindly

You can reinstall without touching home just tell the installer NOT to format it and mount it as /home and all is good. If using the full install DVD then just do an upgrade it will not touch home by default. Yes upgrade same version LOL. The main reason there is a separate home partition is to avoid touching your data when updating or installing new OS systems,

Instructions here on putting iso on USB

Note don’t know about compatibility with Win 10 and those instruction

If Imagewriter does not work in 10 then try

If you can boot your install media in UEFI mode, then you can repair the problem. Or, perhaps better, boot the opensuse live rescue CD in UEFI mode.

If you succeed in booting that, give us the output from:

# parted -l

We can followup up with detailed instructions on repairing your installation.

If I do that my configuration and my repository will be overwrited? I did not remember, I have a separate /home partition

I can boot from install media, an usb stick. I copy the output by hand. For the future can I save the output in another USB stick or in windows data?

Model: ATA TOSHIBA THNSNJ25 (scsi)
Disk /dev/sda: 256 GB
sda: sda1 sda2 sda3 sda4 sda5 sda6 sda7 sda8 sda9
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number    Start    End    Size    File system        Flags
1    1049kB    1075MB    ntfs    Basic data partition    hidden, diag
2    1075MB    1180MB    105MB    fat32    Basic data partition    boot
3    1180MB    1314MB    134MB    ntfs    Basic data Partition    msftres
4    1314MB    123GB    121GB    ntfs    Basic data partition
5    123GB    124GB    827MB    ntfs                hidden, diag
6    124GB    128GB    4300MB    linux-swap(v1)    primary
7    128GB    150GB    22.2GB    ext4    primary
8    150GB    243GB    93.4GB    ext4    primary
9    243GB    256GB    12.6GB    ntfs    Basic data partition    hidden, diag

P.S. I havean ssd


I copy the output by hand. For the future can I save the output in another USB stick or in windows data?

Yes, mount the USB or the Windows file system. Then cd to there. Then run your command with

command > filename

That will write the output of the command to file “filename”. It’s usually a good idea to first run the command without the redirection to see what you get. Then rerun with redirection to the file on the mounted file system.

I don’t think you have mentioned which linux version. If this is 13.2, then file systems are mounted by UUID. For 13.1 or older, they were mounted by device-id.

That can make a difference. Windows install might renumber the partitions, which changes device ids, but does not change UUIDs.

Booting from the install media, can you mount “/dev/sda2”? That should be the EFI partition. After mounting (say, at “/mnt”, check if there is a directory “EFI/opensuse” (that’s relative to the mount point). If there is, can you list its content.

If I do that my configuration and my repository will be overwrited? I did not remember, I have a separate /home partition

The default is to have a home if you did not change that then the home is separate and looks to be your partitions number 8

All your personal settings are in your home. System settings are on the root partition.

You can only do a upgrade from the full version the Live versions you can only do a new install but you can tell the installer not to format the home partition but to simply mount it as /home. In the case of an upgrade install your repos should be preserved but for the new install root is formatted and all system wide settings are erased

nrickert has a point about Windows maybe changing the partitioning and thus changing the number on the Linux partition.

I try this, but I have encountered a problem:

tty1:Rescue:~ # mkdir /media/mountingpoint
tty1:Rescue:~ # mount /dev/sda2 /media/mountingpoint
 1162.969412] FAT-fs (sda2): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.

I’ve tried to run fsck /dev/sda2 but it ask me things that I don’t know

I prefere to not format my root partition. I have some many programs and I take very long time to reinstall everythings. I’d rather consider formatting the root partition as a last alternative

Boot into Windows.

Start the disk manager in Windows. I think it is part of system management tools.

In the disk manager, assign a drive letter to the EFI partition. Maybe call it X: or something.

Then, in Windows, run:


(of course, change that “X:” to the appropriate drive letter).

That should fix the corruption problems. Possibly, it will even fix your boot problem. In any case, that’s where to start.

You can later tell windows to unassign the drive letter to that partition. However, it probably does that automatically on the next boot anyway.

Can’t resolve.CHKDSK return me an error:
the file system is type RAW. CHKDSK is not available for RAW drives

Odd, though that is consistent with linux seeing it as corrupt.

Perhaps you will need to format it in Windows (the FORMAT command). But I worry that doing so might break Windows booting.

If you have Windows install media, you might try booting that and seeing if you can repair that partition or see if you can repair booting.

If it is corrupt I can’t think of a way to fix it since that is the hart of EFI booting. All the boot chains pass through that partition to boot the associated OS’s. It must not be too bad if Windows can boot. Maybe they used a different format for Win10 (vfat???) We just don’t know enough about Win10 yet.:stuck_out_tongue:

I think that I have to ask in windows forum. Windows creates problems. If I resolve I write here the solution.Thank a lot for your support. Bye

I have asked in windows 10 forum but I haven’t resolve. Now I think to reinstall windows and uefi boot manager. Can anyone help me to rebuild opensuse entry on new uefi boot?