Can't boot my suse 11.3

I can’t boot my Suse. Last night I had a power failure during an upgrade. When I boot today I see the following error :

call to lnusertemp failed (temporary directories full?). check your installation

Then I tried to wipe out all the data in /tmp but still the same. I completed zypper up but no luck.

Is it possible that your user has lost ownership of those tmp files? Did you try deleting them as root?

How did you delete the files in /tmp
Randomly deleting files there is Not recommended

So what is happening now exactly?!

Well, I tried deleting every files on the /tmp directory but lo luck. Then I deleted the /tmp itself and next time I boot the screen went blank without error. Then if I press Esc I see problem regarding runlevel 5. I went to IRC and someone named tacit told me to use some complex chmod command on /tmp dir.

I did that, the old message (which I’ve posted) came back.

I removed with " rm -r /tmp/*"

Removed the /tmp with “rm -rf /tmp”

You deleted /tmp
So did you make a new one to do your chmod trick?

You should never delete the whole dir
You might want to consider re-installing and next time, post install, do this:
Clear Temp Files at Boot
That will prevent your calamity happening again

Yes I made a new one with the chmod trick.

So, I don’t have any other option but to re-install? :frowning:

How can you chmod something that isn’t there?
It’s like saying: I’m going to wash my panties… Oh but hang on… I just flushed them down the toilet.

Or did this complex command also include mkdir ?

I forgot to mention that after I saw the black screen I myself recreated the /tmp.

The complex chmod command bring back the previous problem. I think it did some ownership transfer or something.

I’m not sure what your best solution is - there may be some black magic that can be performed, but I don’t do Magic.
Sorry I can’t help any more than this.

Maybe someone else has ideas.

caf4926 wrote:
> Maybe someone else has ideas.

it is impossible to know what was damaged during the power
failure…any number of files could have been open and in a state of
flux…there could have been a rather long queue of items waiting to
be written to disk, etc etc etc. when the power failed…

if the OP has instituted the means given by caf to correctly clean the
/tmp, and still /tmp is full on next boot i have to ask:

how big is the space you gave openSUSE when you installed it?
it is possible that there is zero space available on the partition
which contains /tmp?

or, maybe the power failure damaged the hard drive itself…(i don’t
know if that is possible?)

CAVEAT: [posted via NNTP w/openSUSE 10.3]
When it comes to chocolate, resistance is futile.