Can't boot into opensuuse11.1 after aborted update

before 2 days i was trying to update my opensuse 11.1 with 1 kernel update. Due to slow connection it was automatically aorted. i tried twice for updation but it failed each time in between.
When i restarted computer i have been getting following message on booting:-

Could not find /dev/disk/…– part9
Want me to fall back to /dev/disk/…- part9 ? (Y/n)

Y and n resulst in:

Waiting for device /dev/disk/…– part9 to appear…
Not found-exiting to /bin/sh
$

i also find some solution on this forum
opensuse11.1 not boot
but i could not get any understandable solution.
Thanks in advice.
Hope for simple solution.

result of command in rescue dvd:
cat /boot/grub/menu.lst
>>No such file or directory

so what to do ?

I have XP also on the same system.
please help so that it avoids reinstallantion of opensuse11.1
My swap partition is sda8
root partition is sda9
and home partition is sda10

Boot from the 11.1 install DVD. Get into the installer, until the point where you Choose "New install… etc. There should be an option “Boot installed system”. This will detect the installed system, and boot it, if possible. If you can get in the console, then perform, as root, a ‘zypper up’. That should install missing packages from update.

BTW Updating on a non-reliable internet connection can indeed lead to instable or even unbootable systems.

Thank you for your imediate reply.

I inserted opensuse 11.1 DVD and choosed Installation; in that i could not found “Boot Installed System” under Installation mode.
So reboot my computer and choosed Repair Installed System
in Expert tools there was a option “Boot Installed System” i clickedon it but it showed “No linux partition found”.

So i choosed “Repair File system” option in that i selected sda9 which is root partition for opensuse 11.1 it said that filesystem ext3 is corrupted , do you want to repair it;

Now i have doubt after repairing filesystem will my data remain intact or will it be lost?

Did the repair work?

Was sda10 ok?? If so your personal data should be fine. If you have data (tun a server of some kind?) on sda9 then that may or may not be ok.

If the simple repair worked then it is a good chance that all is recovered on 9. Check lost and found to see if any partial files were recovered. If so or the repair was not successful it is best to simply reinstall but DON’T format the home partition sda10 just mount it as home.

But then you can always restore from your backup right :open_mouth:

Thanks for your quick reply.

I did not try repair because the threat of loss of data. Also
my home partition i.e. sda10 also corrupted the message of repair file system tool said.

I inserted live cd of puppy linux ; it recognizes both xp and opensuse 11.1 partitions and mounted successfully.

So should i go for repair without taking backup or first take all backup then give a try?

One more thing to say is i have GAG installed.

Thanks.

If the file system is shot it won’t work without repair from anything. The best shot is to try to repair it. But don’t expect to get everything back. It all depends on the extent of the damage.I’ve seen all come back then I’ve seen major chunks of files and directories end up in lost and found.

Unless you had serious databases on root I would not bother just figure on reinstalling that part.

And think about doing regular backups in the future.

Thanksfor your guidance.

I tried to repair sda9 with expert tool but it said that device or resourse busy …
So reinstall opensuse 11.1 on sda9 without formatting the home partition sda10 and just mounted it as home.

But now i have to install some softwares again. Also my C: drive of XP can not be mounted in opensuse. some failed error was displayed while booting into opensuse.

Any way Thanks once again for your help and hence
I love Opensuse and Opensuse Community

Yes you need to reinstall all software, you erased all on the root partition by reformatting it.

Let’s see the menu.lst file to get Windows booting again

as root
cat /boot/grub/menu.lst

also as root
fdisk -l

well the results of given commands is

linux-9aag:~/Desktop # cat /boot/grub/menu.lst

Modified by YaST2. Last modification on Sun Mar 7 09:28:08 UTC 2010

default 0
timeout 8
##YaST - generic_mbr
gfxmenu (hd0,8)/boot/message
##YaST - activate

###Don’t change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.1 - 2.6.27.7-9
root (hd0,8)
kernel /boot/vmlinuz-2.6.27.7-9-pae root=/dev/disk/by-id/ata-ST380013AS_5MR6JJL2-part9 resume=/dev/disk/by-id/ata-ST380013AS_5MR6JJL2-part8 splash=silent showopts vga=0x317
initrd /boot/initrd-2.6.27.7-9-pae

###Don’t change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe – openSUSE 11.1 - 2.6.27.7-9
root (hd0,8)
kernel /boot/vmlinuz-2.6.27.7-9-pae root=/dev/disk/by-id/ata-ST380013AS_5MR6JJL2-part9 showopts ide=nodma apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x317
initrd /boot/initrd-2.6.27.7-9-pae

###Don’t change this comment - YaST2 identifier: Original name: windows###
title Windows
rootnoverify (hd0,0)
chainloader +1
linux-9aag:~/Desktop # fdisk -l

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x338d338c

Device Boot Start End Blocks Id System
/dev/sda1 1 2611 20972826 7 HPFS/NTFS
/dev/sda2 * 2612 9729 57175335 f W95 Ext’d (LBA)
/dev/sda5 2612 4113 12064783+ 7 HPFS/NTFS
/dev/sda6 4114 5615 12064783+ 7 HPFS/NTFS
/dev/sda7 5616 7117 12064783+ 7 HPFS/NTFS
/dev/sda8 7118 7207 722893+ 82 Linux swap / Solaris
/dev/sda9 7208 8233 8241313+ 83 Linux
/dev/sda10 8234 9729 12016588+ 83 Linux
linux-9aag:~/Desktop #

Thank you for quick help