Can't boot/install 11.1 with Jetway NC92 motherboard

I’ve seen some other threads elsewhere on this topic, but no resolution (or I haven’t found one). I’m trying to install the 11.1 x86-64 DVD with a Jetway NC92 motherboard (dual-core Atom 330).

When I select install, the kernel crashes within 5 seconds with the following:

cpuidle: using governor ladder
cpuidle: using governor menu
TCP cubic registered
registered taskstats version 1
Freeing unused kernel memory: 1472k freed
Write protecting the kernel read-only data: 5024k
BUG: unable to handle kernel NULL pointer dereference at 0000000000000000
IP: <ffffffff802104a0>] IRQ0x3c_interrupt+0x0/0x7
Oops: 0002 [1] SMP
last sysfs file:
Modules linked in:
Supported: Yes
Pid: 1, comm: swapper Not tainted #1
RIP: 0010:<ffffffff802104a0>] <ffffffff802104a0>] IRQ0x3c_interrupt+0x0/0x7
RSP: 0018:ffff88007d437d38 EFLAGS: 00010046
RAX: 0000000000000000 RBX: 00000000002eb163 RCX: 0000000000000000
RDX: 00000000002eb161 RSI: ffff88007dc09dc0 RDI: ffff88007d433758
RBP: 00000000002fb161 R08: ffff88007dc09dc0 R09: 0000000000000001
R10: 000200d0000612d0 R11: 0000000000000001 R12: 00000000000002fb
R13: ffff88006d437e80 R14: 00000000002fb163 R15: ffff88007dfc67d8
FS: 0000000000000000(0000) GS:ffffffff8084aa00(0000) knlGS:0000000000000000
CS: 0010 DS: 0018 ES: 0018 CR0: 000000008005003b
CR2: 00000000002fb161 CR3: 0000000000201000 CR4: 00000000000006e0
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Process swaper (pid: 1, threadinfo ffff88007d436000, task ffff88007d434040)
Stack: fffffff80229c13 0000000000000010 0000000000000286 ffff88007d437dd0
0000000000000018 0000000000000000 0000000000000002 0000000000000000
0000000000000163 ffff88006d437e80 ffff88007d437e80 0000000000000001
Call Trace:
Inexact backtrace:

<ffffffff80229c13>] ? __change_page_attr+0x30c/0x25d
<ffffffff80229d65>] ? cpa_process_alias+0xae/0x134
<ffffffff80229c81>] ? __change_page_attr_set_clr+0x1d/0x53
<ffffffff80209000>] ? _stext+0x0/0x11d
<ffffffff80229ea7>] ? change_page_attr_set_clr+0xbc/0x1e4
<ffffffff802fb000>] ? pagemap_read+0x91/0x2dc
<ffffffff80209000>] ? _stext+0x0/0x11d
<ffffffff8022752b>] ? mark_rodata_ro+0x65/0x78
<ffffffff808eb140>] ? early_idt_handler+0x0/0x72
<ffffffff80209130>] ? init_post+0x13/0x183
<ffffffff808eb930>] ? kernel_init+0xe6/0xea
<ffffffff8020d7b9>] ? child_rip+0xa/0x11
<ffffffff808eb140>] ? early_idt_handler+0x0/0x72
<ffffffff804a3eb1>] ? _spin_lock_irqsave+0x2e/0x35
<ffffffff808eb84a>] ? kernel_init+0x0/0xea
<ffffffff8020d7af>] ? child_rip+0x0/0x11

Code: ff 6a c9 e9 ee c5 ff ff 6a c8 e9 2c c5 ff ff 6a c7 e9 25 c5 ff ff 6a c6 e9 1e c5 ff ff 6a c5 e9 17 c5 ff ff 6a c4 e9 10 c5 ff ff <6a> c3 e9 09 c5 ff ff 6a c2 e9 02 c5 ff ff 6a c1 e9 fb c4 ff ff
RIP <ffffffff802104a0>] IRQ0x3c_interrupt+0x0/0x7
RSP <ffff88007d437da8>
CR2: 00000000002fb161
— end trace 4c0b0b551d923159 ]—
Kernel panic - not syncing: Attempted to kill init!

According to some other posts I read about an Intel Atom 330 motherboard, it sounds as if the problem is something with the 2.6.27 kernel. I tried the 11.2 Milestone 6 x86-64 install and it seemed to install and boot fine, but I don’t really want to run the bleeding edge.

So unless I’m mistaken, I need to find a way to install 11.1, but not use 2.6.27. I can’t figure out how I’m going to do that.

I have tried both a DVD-RW and DVD-R of the install media (both verified fine from my burner). I can’t opensuse’s on-menu verification because, well, the boots the kernel that crashes.

I have the latest firmware for this motherboard (A03).

I’ve installed several Opensuse flavors on other systems, but never had any install problems so I’m at a bit of a loss here.

Any assistance is greatly appreciated.