Can't boot from DVD

Hi, i am trying to install Suse on my Dell latitude D630 laptop as part of a dual boot. I have burnt the .iso file on a DVD which works (I tested it on my desktop and could install it okay). for some reason the dvd can’t boot on my laptop after the BIOS has been changed to boot from DVD. Dell seems to think that I’m going to have to reformat the laptop (really don’t want to do that!). I tried to just read the DVD in windows on the laptop and it seems unable to read it. I can’t figure it out, and would appreciate anyone’s take on this issue!

well i never installed on a laptop.but a general suggestion…are you abe to read other dvd from your laptop??

Multiple scenarios…I presume that you created the iso DVD on your desktop. Is it a re-writable disc?? Does your Laptop have a DVD-ROM or a DVD-RW?? Some DVD-ROM’s can not read DVD-RW discs. And as gsk_308 previously asked, can you still read other DVD’s on your Laptop and are they Purchased only or did you create some? I’m sure you checked all this but sometimes reminders are needed. I personally also had trouble with Maxell discs. They just would not work with my machine. Appeared to write but could not be read. And last, but not least, do a SLOW burn. Sometimes the fast writes are to faint to be reliable.
Take care and have fun,

Unfortunately, a DVD working in one optical drive is by far no guarantee it will work in a different drive. Aside from supported formats, some drives are more sensitive, and some drives only like certain media. That you cannot read the DVD from within Windows strongly suggests you have this compatibility problem (not booting indicates the boot sector cannot be read, Windows not reading it indicates the ISO9660 file system cannot be read). Try burning the iso to DVD using the laptop drive, and make sure you are using good quality media.

Manufacturers often recommend “reformat” and/or “reinstall OS” - it’s their quick-and-dirty solution to a problem not quickly solvable. I don’t see how that could possibly affect this problem.

Thanks for the handy suggestions! I tried a better quality dvd and it worked, it was just a simple case of my dvd being too posh!
Am successfully typing this from my new SUSE-KDE system!
Thanks again!

thats good to know.enjoy using linux

You’re welcome! :slight_smile: