Can't boot encrypted partition after updates

Hello

I use opensuse 42.2 on my laptop with an encrypted lvm disk, today I decided to make the update using yast but now I can’t boot anymore.
After I type my password the loading is stuck at dracut pre-mount hook and I can’t access any shell.

According to the bug report https://bugzilla.opensuse.org/show_bug.cgi?id=971023 I should try to downgrade sg3-utils package.

If I boot from an external device how can I do that ?

Does anymore had the same issue and fixed it without reinstalling the system ?

Thanks

You need to go to a rescue mode:
Linux rescues

However, if you are using “btrfs”, then you also need to mount all of the “btrfs” subvolumes.

Then, after chroot into the mounted system, use zypper at the command line for that install. Or you can probably use command-line yast (ncurses version of yast).

Thanks for the link it was very helpful.

But I have still some problems :
/boot is almost empty and there is nothing that seems to be kernel-related into it.
I desperatly tried to lunch the “upgrade” option in the boot menu but it messed up even more my system (no more GRUB…), i think my usb was corrupted

So as I can’t spend too much days without a working computer I guess I will simply reinstall the whole system.

Yes, that might be your best option.