Can't boot after update - please help

Hi,and thanks to all in advance.
Running 11.1 (Dual boot with windows Xp which works as fine as windows works) with internal graphics (Mobile Intel(R) 915GM/GMS,910GML Express Chipset Family)

Updated yesterday and had troubles with the opensuse factory repository (something about there not being a checksum). But apart from that it ran ok and then asked me to reboot, which i did.

At which point when it reloaded it got to grub fine, selected opensuse as normal, get progress bar moving most of the way up until the point where the login screen appears… and then it goes blank screen with a static cursor in top left corner.

Tried failsafe mode, gets to command line. Tried ‘startx’ and that just goes to blank screen.
Have tried ‘sax2 -r -m 0=vesa’ both straight from falisafe and normal mode (with vga=…etc replaced with ‘3’) as recommended in other threads. But when I do that I get a blank screen with a cross-like cursor in the middle i can’t move and it freezes. I manually reboot and back to square one.
Also tried ‘sax2 -r -m 0=fglrx’ in hope that might help (it was suggested to detect driver), but did nothing.

Have booted with livecd, mounted /home and copied files to external drive, so am backed up, but would rather not reinstall.
Any advice?

When you boot and get to the splash screen with the progress bar, hit Escape to remove the splash screen and watch for any messages that may point to the problem.

You could also look for errors in var/log/boot.msg

Hi, thanks for reply
Pressed ESC and nothing out of the ordinary comes up (not that I’d know really, but nothing red) and the screen goes blank 5-10 seconds before computer stops chugging so assumedly something is happening i can’t see.
Booted in failsafe, went cd /var/log/ then ‘less boot.msg’ to read.
746 lines long, don’t really know what I might be looking for. Except first lines=

Inspecting /boot/
cannot find map file.
No module symbols loaded - kernel modules not enabled.

Cannot build symbol table - disabling symbol lookups
klogd 1.4.1, log source = ksyslog started.
<6> Initializing ...... etc, etc

But the stuff logged most recent is at the bottom of the file so I don’t know if that’s pertinent.
Sorry if that isn’t much help.
What else might there be?

With the boot messages, your mainly looking for stuff that implies that it was unable to do something. It will probably be towards the end where it fails to continue.

With the boot.msg file have a look at the entries after
“Boot logging started on …”

With mine it starts on line 1144.

You can also look in var/log/boot.omsg for the same sort of info.

Other than that, I don’t really know where else to look.

ok, started in failsafe mode and then looked at /var/log/boot.msg. This stands out

doneStarting service kdm
The failsafe X.Org configuration /etc/X11/xorg.conf.install no longer exists.
Either move it back (if still available) or copy /etc/X11/xorg.conf to
/etc/X11/xorg.conf.install to use the native graphics driver instead of the
failsafe graphics driver. Of course the latter option no longer can be called

and at the very bottom it says

Master Resource Control: runlevel 5 has been reached
Skipped services in runlevel 5: smbfs earlyxdm nfs xdm
<notice>killproc: kill(1818,3)

then in /var/log/boot.omsg which i assume is the last boot which wasn’t failsafe, it has

Starting service kdmdone
Not starting NFS client services - no NFS found in /etc/fstab:unused

and at the end of the start-up sequence (before it starts shutting down when i pressed th epower button after it froze) it has

Master Resource Control: runlevel 5 has been reached
Skipped services in runlevel 5: smbfs nfs
<notice>killproc: kill(1820,3)

oh, and further up in the file it has

System Boot Control: The system has been set up
Skipped features: boot.cycle

and it says the same in boot.msg too.
thanks again

OK, I’m fairly new at this too, but if /etc/X11/xorg.conf.install doesn’t exist i’d try copying /etc/X11/xorg.conf to /etc/X11/xorg.conf.install as it says and see what happens. :slight_smile:

Log in as root

cp /etc/X11/xorg.conf /etc/X11/xorg.conf.install

ok, tried that but it just meant that failsafe mode went straight through to the blank screen with giving me the CLI.

Sorry, being fairly new to Linux I don’t know what other diagnostic tools are available to search for info on the possible problem. :frowning:

Hopefully someone with more experience will step in and help.

Thanks alot anyway david71, it’s been good to explore anyway.

Can you remember what you updated yesterday, as that may point to what may be broken?

it was a massive update because I hadn’t updated for a while. I just manually ran the update with Yast because of something to do with zypper needing refreshing and not doing very well with it.
So, yeah, it was a long list of stuff, don’t know what.

The only other suggestion is to use the repair function on the installation DVD.

I only have livecd, dvd may be a bit of problem

Why do you have factory with 11.1?

I suspect a fair bit is going on, so I’m clear can you boot with failsafe do you see a desktop?(Mmm Ok reading it seems even this isn’t working)So…

Due to newbie status I’m inclined to suggest a reinstall. Otherwise how did you install, i.e can you use the repair option from the install media? Then if this doesn’t do some magic it may get a little tricky involving mounting and chrooting to be able to run several commands. Though you maybe able to bring up some bits from the login and do some fixes like updating but you may have to fiddle with bits to get a network. You could look at logs to see what you have updated but the easiest maybe to use cli yast or zypper dup, but after you have disabled all superflous repos to end up with OSS, Non-Oss, Packman and update, this would in essence roll you back to when it was first installed(But may leave some packages if alternative versions can’t be found).

I actually suspect you have a mix of factory and 11.1 which will cause problems unless managed.

The reinstall is looking more attractive. No repair function on livecd.
I’m not sure why I have factory, I must have wanted to install something from it, don’t remember.
How would I disable unwanted reps?
Just to confirm, can’t get to desktop at all.

As for disabling the easiest would be to run yast. But prior to this


if your lucky the network will be intact and the rest should be easy’ish. If you don’t have network then it can be just as simple as rcnetwork start other times not so(And I’m really not the person to talk someone through this if that doesn’t work. I tend to be a bit of blind man stabbing till I get the correct combination)

When in yast you’ll have sorta of gui just need to use tab, alt (yellow letter) or arrow keys to navigate and space and return for other bits. Quite intuitive really.

You can do it straight via the command line by using zypper commands also Zypper/Usage/11.1 - openSUSE

Ok, i didn’t know you could get into yast from the CLI (sounds kinda obvious now) so that’s cool.
I deleted the non-essential repositories. So what am I doing now?
BTW i tried going to hardware settings and selected graphics card/settings whatever and the screen went blank with cursor like it has before. So definately something up with the graphical display settings.

Using cli yast you can select installed. iirc when you navigate to software, using the drop down(Filter think) choose repos, the first one should be @System. Select this one then navigate to the other button should have something like all in this list update unconditionally.

Or you can use

zypper dup

which will update all from that list and choose repos over packages. About zypper dup on the zypper page from earlier.(I’ve used it in several instances and have had no problems). The other one you can try perhaps even before is

zypper verify

But this is making the presumption your network is up and fine.

yeah network is fine, I’m plugged in direct
Ok, i verified and now im zypper dup-ing
it’s beavering away…

I’m getting a fair few warnings popping up

warning: /var/cache/zypp/packages/repo_6/i586/… with different things saying NOKEY, key ID…

Is that normal?

And it’s finished…
And startx works…
It reboots…
And all is back as normal!
Reboot again to make sure…
It works!!

Thank you very much, I am very releived.