Can't boot after installing proprietary Nvidia drivers

I tried to install proprietary Nvidia drivers and can’t boot. I had to install manually because there’s no up to date repo.
I downloaded the latest driver for my graphics card from Nvidia website. I’m following openSUSE’s guide:

I started the installer and completed the process. There was one conflicting Nvidia driver which I choose to remove. I answered “yes” for every question. After that I ran the two following commands in the guide. This is where booting gets stuck:!l4zyep5zWyJHF2GNMdXu2QXqR6DUNZfJkPXxRHY4

More info:

             4.016] Current Operating System: Linux linux-a1ym 3.16.7-24-desktop #1 SMP PREEMPT <current date> (ec183cc) x86_64   25791.813] (EE) Server terminated successfully (0). Closing log file


It’s not stuck, it completed but X11 server failed to start. If you press Alt-F1 you will get text mode login prompt. To answer why X does not start content of /var/log/Xorg.0.log would be needed.

Do you mean by running:

 less /var/log/Xorg.0.log

That list is extremely long. I’d have to photograph every page. Certain section that I should look for?
I remenber that Nvidia installer wanted to replace my Xorg.conf (I allowed), can this be related to my issue?

Is it possible to upload the content of Xorg.0.log from terminal? Internet should work.

I tried to install “Pastebinit”, but there is no stable package for openSUSE. Can I install unstable software easily from terminal or do you have another tool to recommend?

The repo is up do date with all released versions. There may be a beta version hanging out but when a driver is release it goes into the repo.

That said what hardware? Is this by chance a notebook with Optimus tech?? If so DO NOT install the regular driver you must use bumblebee

You should be able to boot into recovery mode since it does not load the driver. In Grub advanced second line

Copy/paste it to or similar sites and post a link.

In boot menu go to Advanced Options (I think it is called this way), second entry should give you GUI using generic X11 driver. Or edit main menu entry and add x11failsafe to kernel command line options (press ‘e’ to edit, go to line that starts with “linux” or “linuxefi”, append to end of this line, press F10 to boot).

This is a self-built desktop computer:
Intel Core i7-4770K @ 3.50GHz
16,00Gt Dual-Channel DDR3
Nvidia GeForce GTX 780 Ti

I wasn’t aware that I can boot into recovery mode. I thought that I’m locked into terminal.
I’ll try it tomorrow.

I’m not sure anymore what I installed in the first place. The community repo says that I shouldn’t use this method if I have a legacy card - GTX 780 Ti is. What repo should I use then?

A 780 should not be a legacy card It should handle a GO4 driver but also a GO3 driver should work. Any card prior to 610 may be considered legacy. Also NVIDA’s numbering is funky most old cards use 4 numbers all the newer ones use 3. Go figure

Don’t get too caught up on latest and greatest use the driver that works

It’s according to Nvidia:

Does the community repo use GO4 driver?

Also, the issues started when I logged out. I didn’t get a graphical sign-in screen but terminal.

I can’t boot into recovery mode, Gnome instantly crashes. I’ve had this issue also before.
Is it possible to switch to Nouveau driver? I’d also like to install the latest version of Gnome DE.

You could try to uninstall nVidia drivers; theoretically it should give you back nouveau. It is hard to say, as installation of nVidia drivers using their installer replaces system libraries that are required by X11. This may make it impossible to run any other video driver. Another problem is that GNOME is said to required video acceleration and won’t work without.

In similar situation I actually had to run full rpm verification and reinstall all packages that had changed files.

How demanding is that process if it needs to be done? I really, really have to start taking disk image backups.

Yes GO4 is in the repos

If you installed the hard way run the installer .run file again but add --uninstall.

Boot to command line. At boot menu type an e then find line starting with linux/linuxefi go to the end of that line (note it wraps) add a space and a 3 press F10 to continue.

Log into command line as root and cd to the directory where the installer file is then run it with the uninstall option

Optionally you could log into another GUI. Gnome is very picky and other GUI’s would not choke. Of course you have to not have autologin set

I’m assuming you installed the legacy driver which won’t work with you NEW card

I didn’t install the legacy driver, I downloaded a 64-bit Linux driver from Nvidia for my card.
I was using Xfce previously, but DE defaults now to Gnome.

Yes, I installed “hard way”. I have to upload the error log here.

Hmmm… is it possible to restore from a snapshot in this situation? I looked and I have several available from prior the driver installation.
If this doesn’t work I don’t know if Snapper is useful at all.