Can't boot after an update

I had 2 security updates last night that told me to reboot for them to take effect. So installed them and as it was time to go to bed switched off.

The following day when I booted up I had an invalid signature message so couldn’t get past grub. The default fall back boot wouldn’t work either. Using advanced options I selected one that does work so now at kde’s desktop.

Update now shows 44 updates but produces the following message

 There is no update candidate for kernel-default-4.19.72-lp151.1.3.x86_64 


The current Leap 15.1 kernel is 4.12.14-lp151.28.16.1

What repositories have you enabled?

sudo zypper lr -d

#  | Alias                               | Name                                   | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                          | Service
 1 | | home:bmwiedemann:cnc                   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |        |        
 2 | | home:mrbadguy                          | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                 |        
 3 | | openSUSE:Leap:15.1:ARM                 | Yes     | ( p) Yes  | Yes     |   99     | NONE   |                   |        
 4 | | home:rawtherapee                       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |              |        
 5 | | home:qantas94heavy                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |            |        
 6 | | graphics                               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                       |        
 7 | | KDE:Qt5                                | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                       |        
 8 | | science                                | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                        |        
 9 | | openSUSE:Tools added via Rawtherapee   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                     |        
10 | | openSUSE:Leap:15.1:Update              | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                                           |        
11 | | GNOME:Apps                             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                    |        
12 | | multimedia:photo Fotoxx                | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |              |        
13 | | multimedia:color_management DisplayCal | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |   |        
14 |    | libdvdcss repository                   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                                           |        
15 |      | Packman Repository                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                                             |        
16 | openSUSE-Leap-15.1-1                | openSUSE-Leap-15.1-1                   | No      | ----      | ----    |   99     | rpm-md | hd:/?device=/dev/disk/by-id/usb-Kingston_DataTraveler_3.0_60A44C413CA0F140C9760044-0:0-part2 |        
17 | repo-debug                          | Debug Repository                       | No      | ----      | ----    |   99     | NONE   |                          |        
18 | repo-debug-non-oss                  | Debug Repository (Non-OSS)             | No      | ----      | ----    |   99     | NONE   |                      |        
19 | repo-debug-update                   | Update Repository (Debug)              | No      | ----      | ----    |   99     | NONE   |                                     |        
20 | repo-debug-update-non-oss           | Update Repository (Debug, Non-OSS)     | No      | ----      | ----    |   99     | NONE   |                                 |        
21 | repo-non-oss                        | Non-OSS Repository                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                            |        
22 | repo-oss                            | Main Repository                        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                                |        
23 | repo-source                         | Source Repository                      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                         |        
24 | repo-source-non-oss                 | Source Repository (Non-OSS)            | No      | ----      | ----    |   99     | NONE   |                     |        
25 | repo-update                         | Main Update Repository                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                                            |        
26 | repo-update-non-oss                 | Update Repository (Non-Oss)            | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                                       |        

I have installed some photo applications that aren’t part of the distro. They are ones I have used for a very long time under various opensuse releases.


You have at least one home Tumbleweed repo active this may be where the problem is. Never mix distors

I don’t know where the arm repo came from. It’s a dead link now
Others are down to
Play with Linux - wine but more set up done on install and generally uses the latest version of wine.

Gnome will be there for pulse controls and I think ViewNoir

Up to the 2 updates last night I have been getting them more or less daily without any problems. One needed a reboot a couple of weeks ago.

One other thing springs to mind. On the previous needs a reboot update more updates appeared instantly and I added those. The same happened with the 2 last night but I didn’t install them - as mentioned it was rather late at night.


As @gogalthorp said, you certainly want to remove the TW repository (#1), also the ARM (#3)

also, let’s see where your “kernel-default-4.19.72-lp151.1.3.x86_64” kernel actually came from…

sudo zypper se -i -v kernel-default
S  | Name           | Type    | Version               | Arch   | Repository               
i+ | kernel-default | package | 4.19.72-lp151.1.3     | x86_64 | home:mrbadguy            
    name: kernel-default
i+ | kernel-default | package | 4.12.14-lp151.28.13.1 | x86_64 | openSUSE:Leap:15.1:Update
    name: kernel-default
i+ | kernel-default | package | 4.12.14-lp151.28.13.1 | x86_64 | Main Update Repository   
    name: kernel-default

Strange. I would need to reboot to be sure but I think that it was objecting to booting to the first one in the list but only this morning. I am not aware of a zypper command to see what else came from there but it looks like wine tricks did and some pulse commands did. Both of those have been on my machine for several weeks. Pulse since the initial install. pavuctrl and the equalizer and no problems with official updates or with the photo apps I run.


The tumbleweed repo only has cad related content. I run wine so that I can use a certain windows package as there is no linux equivalent. I do look at the Linux ones periodically. Play with Linux made a much better job of running the windows one probably via installing windows dll’s via winetricks I think.

Is there a zypper command to show what was installed from a particular repo? mrbadguy seems to be the culprit. All I can find is pulseaudio-utils and winetricks. Rest of both are from main repo’s. The arm repo may have been bought in by pulse utils as I would guess many arm users would want that.

To me it looks like the only way of recovering would be to correct the kernel even the initial run in memory aspect which may involve changing grub. That is beyond my capabilities so would need instructions.


I’ve used YAST to force a kernel update. Can anyone suggest checks that could be made before rebooting to be more sure I will get back to the desktop?


I rebooted, got back but the initial load that is run in memory failed out so had to select another as before to get back here.

Since forcing yast to update the kernel there are no more available updates.


While YAST goes through the motions it doesn’t actually install it. So downloads etc and if I then go back to update it still shows the older version and the newer one being available.


It is ok to get a single package from a home repo even TW if you really need it but it should not be left active. These repos are personal and may have very experimental code which may break your system.

Well anything seen is available

zypper se -r {number}

For example, your “mrbadguy” is repository #2, so

zypper se -r 2

The arm repo may have been bought in by pulse utils …

A repository won’t be added unless you add it, either directly, or more likely perhaps, as a result of using a “one click install”. Either way, you don’t want that one :wink:

Of what? The kernel?

The more repositories you have enabled the greater likelihood of something going wrong, especially if those repos contain newer versions than the standard repos… dependency problems etc etc…

If you must install something from a TW repository, you may be better off setting up a local repository and downloading the package to that, although you may well find there are several dependant packages also needed.

Other than the photo applications I usually disable repo’s as soon as I have what I want from them. I have also had the source of play with linux active before but it was maintained for opensuse as was the latest release of wine.

:’(Looks like I missed the arm one but am surprised that the pulse stuff isn’t maintained reliably some where on opensuse’s server.

The cnc / cad stuff is for rather occasional use of a 3D printer. I’ve not fully looked at Linux options but usually find the learning curve doesn’t suite me or they are too simple.

The kernel-default is what doesn’t actually update when I forced via YAST. Doing this seems to have satisfied the desktop update notifications. That’s a little odd. I did manage to get YAST to go through the usual dependency checks but resolving them proved impossible. Not sure what I did. What it needed to do was to change several things to suite. That option wasn’t available so maybe I picked up some items from a particular repo and have to wonder if they are actually used.

The best option seems to be to reinstall. KDE used to be pretty happy if user names and passwords aren’t changed so my home directory wont be formatted but several apps will have to be installed again. One now does have a 15.1 version rather than tumble. Pulse though may be a problem and also play with linux. The only thing I really need now from pulse is the equaliser. Codecs appeared to be more sorted out by installing mplayer.


I can’t post what came from mrbad as they character count is way too high. I have to wonder why many of them are installed.


At the end of the day, you yourself must know what you want to do.

Would you like to keep the newer kernel? Or do you prefer another way?
Yes, the newer kernel may cause problems. But you can try whatever you want.

As far as I got it, you, using YaST, looked for ways to get rid of the newer kernel, that isn’t the one used in 15.1. Am I wrong? I’m referring to

If you use a kernel different from that usually used for your distribution (15.1) then it may become difficult to help you.

It is your decision.

  1. You can boot to the older kernel
  2. To resolve your updating problems, you have to realize that libzypp will naturally update to anything that’s named the same but a later (higher number) version. So, if your kernel from the :home repo is preventing your kernel from updating because you have one installed with a higher version, you have to either uninstall the higher version or always install the new kernel with the “oldversion” option which can become onerous after awhile.


The problem I have is that some how an older version has installed and can’t be updated so YAST show 4.19.-lp151.1.3(4.19.-lp151. in red

If I tell YAST to just update it does nothing and the software management page just shuts immediately. If I tell YAST to do an unconditional update it goes through the motions but doesn’t actually install anything but does download.

Maybe I have the numbering aspect wrong and the 1.3. is newer than

All would be ok if the initial memory image load was ok but I have to select another version boot via the advanced option. It’s odd that anything installed without correcting that.

I am for the first time in rather a lot of years dual booting with windows so that I can update camera and etc firmware without needing another machine around. Maybe that has caused a problem. My windows laptop has all sorts of problems as the windows is very old. Suites me. I can install OpenSuse on it now.

The other odd aspect is that once I forced yast to install 10 auto updates are no longer needed even though in real terms nothing has changed.


The current leap 15.1 kernel is 4.12.14-lp151.28.16.1 from the (Leap 15.1) “Main Update Repository”, it is that version you probably should install.

YaST2 -> Software Management -> Search (for kernel-default)

Select “kernel-default” from the search results

Use the “Versions Tab” to select 4.12.14-lp151.28.16.1

Then right click on “kernel-default” in the search result pane and choose update unconditionally.

That has worked other than clicking mrbad’s kernel to change the icon to a minus sign and not needing to update unconditionally. MrBad’s repo was disabled.

One other aspect that may not matter. From memory I usually have kernel-base installed. The one from the main update repo with the same release wont install as it conflicts with the kernel-default. Must admit I am not sure what kernel-base actually is or why it may be needed.