Can't automount USB drive in Suse 11.0

Here’s what happens: I put a drive in the USB port, choose “Open in Konqueror” from the list of options, and Konqueror starts trying to open the drive at system:/media/sdc1, but then stops with an error message:

“ no ← (action, result)”

What does this mean, and how do I overcome this error? I can mount drives fine by hand:

mount -t vfat /dev/sdc1 /media/usbdrive

works. But I’d like my drives to automount, as they used to in Suse 10.0, and as they still do in my laptop running Suse 9.3.


Have you tried selecting dolphin or is it kde3 you are using??

kde3 should work like a dream

kde4 maybe not so good. And if you are kde4 I would suggest upgrading to Factory 4.1.3

tell us more please

I’m using KDE 3.5. Actually, part of the problem might be that I did an upgrade from Suse 10.0, rather than a clean new install. So I have bits of 10.0 still hanging about. I think what I might do when I have some time is completely reformat the hard disk and install from scratch. That may well solve a lot of other issues I’m having. Still annoying, though.


A complete format is not required.

You could probably quite successfully keep your /home partition as it is. Though it could be beneficial to backup and do a Fresh install right through,

Aussie Guy–

At least you can DO a manual mount! I can’t even figure out HOW to do this. I installed 11.0 just a week or so ago on a new box, and between hal and udev I’m in no man’s land! This is maddening!

So this was an install from scratch…should I attempt to do a repair. I have another box that I upgraded from 10.0 to 10.2 at one point and everything works fine.

The working one has the following particulars–

hal: 0.5.8-git20061106-31.3
kde: 3.5.5-102.11

new one, different bus setup etc

hal: 0.5.11-8.1
kde: 3.5.9

I’m almost ready to chuck all this and go back to manual setup…I am VERY frustrated at this point. Been trying to figure this out for 2 weeks now…is there NO solution???


kayschenk what happens when you try to do the mount?

as a “normal” user, i.e. in my own account, I can’t mount anything AND when I use say a flash stick in root, it seems to want to use the mount point…/dev/sdb… but these devices do not currently exist in /dev so they are apparently created on the fly.

As a “normal” user, I get a pop up that asks me if I want to

  • open in a new window (this is typical on my other system which happily opens up the stick in /media)
  • Do nothing, which of course does NOTHING

This is the point…I can NOT automount USB flash drives from KDE…

OK, more on this … moving on audio CDS. Again, no nice windows, or automouting or playing directly with KDE. I CAN tell my system to “do nothing” with these however and paly them with Kaffeine.

So…right now KDE and hal are NOT playing well together at all.

here’s my fstab info FYI…hmmmm…does this mean I should be using acls (which I know NOTHING about to set this up??)

/dev/disk/by-id/scsi-SATA_WDC_WD1600HLFS-_WD-WXL808117816-part5 swap swap defaults 0 0
/dev/disk/by-id/scsi-SATA_WDC_WD1600HLFS-_WD-WXL808117816-part7 / ext3 acl,user_xattr 1 1
/dev/disk/by-id/scsi-SATA_WDC_WD1600HLFS-_WD-WXL808117816-part6 /boot ext3 acl,user_xattr 1 2
/dev/disk/by-id/scsi-SATA_WDC_WD1600HLFS-_WD-WXL808117816-part12 /home ext3 acl,user_xattr 1 2
/dev/disk/by-id/scsi-SATA_WDC_WD1600HLFS-_WD-WXL808117816-part11 /opt ext3 acl,user_xattr 1 2
/dev/disk/by-id/scsi-SATA_WDC_WD1600HLFS-_WD-WXL808117816-part8 /tmp ext3 acl,user_xattr 1 2
/dev/disk/by-id/scsi-SATA_WDC_WD1600HLFS-_WD-WXL808117816-part10 /usr ext3 acl,user_xattr 1 2
/dev/disk/by-id/scsi-SATA_WDC_WD1600HLFS-_WD-WXL808117816-part9 /var ext3 acl,user_xattr 1 2
/dev/disk/by-id/scsi-SATA_WDC_WD1600HLFS-_WD-WXL808117816-part1 /windows/C vfat users,gid=users,umask=0002,utf8=true 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0

Your resposes to the above may help us.

When it asks if you want to open in a new window does it do that if you click that option? If it does then it has automounted. Same deal with the CD’s

OK–answers to your questions…

  • the only reason why I was using root is so I could see IF anything was working for that account/user, which it is

This is the point…I can NOT automount USB flash drives from KDE…But it’s just given you the choice to open in a new window - so does it do this or not??

no, it does not… that’s when I get the same message as AussieGuy

“ no ← (action, result)”

Does the Audio CD appear on the Desktop? Does it play with kaffeine? You can always choose a different player like Amarok.

The audio CD DOES NOT appear on the desktop, and unlike the root account in KDE, I DO NOT get offered a choice of players. I copied some addtional .kde/share/service files over to my normal users and same experience. SO, with audio CDs, again I am offered to open in a new window, which is not what I want to do…but I can somehow use Kaffeine to play it using the device hal has set up.

Still this is NOT AT ALL what I want to have ahppen or what normally happens.

Should I do a “system repair”. Have I royally messed something up somewhere along the way??? Really this is the first “from scratch” SuSE install I’ve done in a while, the others were upgrades mostly.

…and I apoligize, I don’t know how to use this forum interface very well.

OK, bye until tomorrow…PST

and thanks for any help you can give me. I’ve looked at the hal and udev stuff 'til I’m blue in the face and then some.

Are you using the kde3 build service repo: Index of /repositories/KDE:/KDE3/openSUSE_11.0

It shouldn’t make any difference to your problem though, but it’s more up to date.

You could try a system wide update all from Yast software management

check to see you only have originals of


Hello caf4926—

hmmmmm…interesting little files! I will definitely check this out and do as you suggest re KDE. Ai yi yi…I didn’t know about these guys! Re “update all”…well sounds scarey but if it solves my problems, I’ll be happy. I’ll get back to you later today.

OK, folks…I started reading the Hal docs for my hal implementation 0.5.11.

It discussed something about linux acls, which I certainly have VERY limited knowledge of, but also talked about a PolicyKit setup in /etc.

So, I took at look…yes, there was indeed /etc/PolicyKit in my setup containing only ONE file, PolicyKit.conf, along with some examples that I modified.

My two normal users now have access to “mount-removable” and no more errors. A first step anyway. I haven’t tested this on my floppy…yes, I’m one of those paranoids who still believe in them! So…at least a solution for the moment. Maybe someone can take this up with the packagers at some point. I surely DO NOT remember anything in my initial installation that asked about this. And, I gotta tell you, I’ve been grappling with this for 2 weeks! Really I don’t know if this was the right thing to do vis a vis security either. I need to investigate more what it considers my primary hard drive.

something about policy kit file - i will edit it and see if it works for me - i have 11.1 on an ibook g4 [How-To] Enable Auto-Mounting of External Drives In openSUSE 11](

@kayschenk, hi , can you post what you did to make this work? Apparently editing the policy in /usr/share as suggested in the link above has absolutely no effect.

This is absolutely pathetic on the part of Suse to let this sort of thing go out.

Without editing files etc, you might try running (replace the <user_name> with yours):

# sudo polkit-auth --grant --user **<user_name>**

# sudo polkit-auth --grant --user **<user_name>**

More details in here