Can't attach USB device to VirtualBox

Since I upgraded to openSUSE 13.1 I can’t attach USB device to VirtualBox. Somehow, VirtualBox recognize USB, but I can’t click on it:

I am member of vboxusers group and this is my /etc/udev/rules.d/60-vboxadd.rules:

KERNEL=="vboxguest", NAME="vboxguest", OWNER="vboxadd", MODE="0660"
KERNEL=="vboxuser", NAME="vboxuser", OWNER="vboxadd", MODE="0666"

I am using:
openSUSE 13.1
VirtualBox 4.2.18_OSE r88780

If I install the newest version of VB, I can’t even start VB… Probably because VB 4.2.18 is official version of OS 13.1 -

Any help would be appreciated,

Copy the file /usr/lib/udev/rules.d/60-vboxdrv.rules to /etc/udev/rules.d/, open it with a text editor, and remove the leading '#'s from the last 4 lines below the comment in line #2. This is needed to give you the needed permissions, but is disabled by default in the openSUSE package because of security concerns.
It should work then after a reboot.

Have you installed the extension pack? Extension Pack for 4.2.18:
Then enable USB 2.0 Controller in VM Settings.
If still not working, try to do it as root.

Attaching a device should work without the Extension Pack (in USB1.x mode only of course).

If still not working, try to do it as root.

Well, better do not. :wink:

Thanks - this fixed the problem on my openSUSE 13.1 desktop.

BTW - The 12.3 rules had been moved to an .rpmsave files (I normally search for and review all the .rpmsave and .rpmnew files, but I hadn’t got around to it yet).

Problem solved! :slight_smile:

Thanks everyone for helping…


installed version 4.3.6 today and it don’t create the group vboxusers


KERNEL=="vboxdrv", NAME="vboxdrv", OWNER="root", GROUP="root", MODE="0600"KERNEL=="vboxdrvu", NAME="vboxdrvu", OWNER="root", GROUP="root", MODE="0666"
KERNEL=="vboxnetctl", NAME="vboxnetctl", OWNER="root", GROUP="root", MODE="0600"
SUBSYSTEM=="usb_device", ACTION=="add", RUN+="/usr/share/virtualbox/ $major $minor $attr{bDeviceClass}"
SUBSYSTEM=="usb", ACTION=="add", ENV{DEVTYPE}=="usb_device", RUN+="/usr/share/virtualbox/ $major $minor $attr{bDeviceClass}"
SUBSYSTEM=="usb_device", ACTION=="remove", RUN+="/usr/share/virtualbox/ --remove $major $minor"
SUBSYSTEM=="usb", ACTION=="remove", ENV{DEVTYPE}=="usb_device", RUN+="/usr/share/virtualbox/ --remove $major $minor"

when i add a usb key, it’s not detected… seem like the rpm is not ok

Hey Folks :slight_smile:

this solution works fine for me


kwrite /etc/udev/rules.d/20-virtualboxusb.rules

KERNEL=="vboxdrv", NAME="vboxdrv", OWNER="root", GROUP="vboxusers", MODE="0600"
#these two lines give access permission to vboxusers to properly work with usb nodes, this could be security risk (bnc#664520) !!
SUBSYSTEM=="usb_device", ATTR{devnum}=="?*", ATTR{busnum}=="?*",SYMLINK+="vboxusb/$attr{busnum}/$attr{devnum}", GROUP="vboxusers"
SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ATTR{devnum}=="?*", ATTR{busnum}=="?*",SYMLINK+="vboxusb/$attr{busnum}/$attr{devnum}", GROUP="vboxusers"


Original-First-Line: just for info

KERNEL=="vboxdrv", NAME="vboxdrv", OWNER="root", GROUP="root", MODE="0600"

I would NOT recommend that. This advise is three years old and the virtualbox packages have changed a lot since then.

Better copy the included file /usr/lib/udev/rules.d/60-vboxdrv.rules to /etc/udev/rules.d/ and edit that (remove the comment characters ‘#’ in the last 4 lines).

sudo cp /usr/lib/udev/rules.d/60-vboxdrv.rules /etc/udev/rules.d/
kdesu kwrite /etc/udev/rules.d/60-vboxdrv.rules

It should look like this then:

KERNEL=="vboxdrv", NAME="vboxdrv", OWNER="root", GROUP="root", MODE="0600"
#these lines below give access permission to vboxusers to properly work with usb nodes, but enabling them could be security risk (bnc#664520) !!
SUBSYSTEM=="usb_device", ACTION=="add", RUN+=" $major $minor $attr{bDeviceClass} vboxusers"
SUBSYSTEM=="usb", ACTION=="add", ENV{DEVTYPE}=="usb_device", RUN+=" $major $minor $attr{bDeviceClass} vboxusers"
SUBSYSTEM=="usb_device", ACTION=="remove", RUN+=" --remove $major $minor"
SUBSYSTEM=="usb", ACTION=="remove", ENV{DEVTYPE}=="usb_device", RUN+=" --remove $major $minor"

Do you see the difference? :wink:

Thank you so much everyone! This was making me bang my head about. This fixed my issue. :slight_smile: