Can't add repositories

Hi everybody.

I’ve just started learning Linux with opensuse, and I have this problem.

It is probably something easy to solve, but it’s driving me crazy becasuse I cannot find any information about this.

I’m trying to add a repository, for example the packman or those included. However, yast returns me an error, it cannot connect to the host.

I have tried to access the path on firefox and it accesses perfectly, so I can’t find why yast or terminal can’t.

The packman repository, for example.

This is the address I’m trying to add, with this command:
zypper addrepo --repo

I found this on internet.
Can somebody help me? Thanks.

It’s all fine, except: add the directory which contains the file with .repo extension, and you need root permission to add repositories. You should type sudo before the whole command, like this:

sudo zypper ar Packman

(ar is same as addrepo)
and after the address Index of /pub/packman/suse/11.1 you need to type an identifier for this repository, Packman for example.
For more information type:

zypper help ar

Have a nice day.

Thanks, ram, it helped me a lot!

Just in case it helps at some time in the future, or helps someone else, there is a sneaky way around this issue. If you use the the web-based one click install, it automagically (if you don’t stop it) adds any repos that it needs to do its business.

So, go to, search for the software that you want, add it and let the process add the repos.

It is not an issue! It’s absolutely normal.
YaST informs you that some repos are being added.

Adding repos willy nilly will lead to headaches quickly.

Using build service is not the best idea for new users many are development repos. Many are home repos with special packages, wait till the day you use a repo that decides its going to update your kernel etc… Then you have people using stable still not realising stable doesn’t mean bug free. I wonder how many of these few complaints are related to using unsupported/non-official repos.

If you wish for the easy way then recommend the wiki page…
Package Repositories - openSUSE

Even the bottom few have… use at your own risk.
You can then find Packman here,
Additional YaST Package Repositories - openSUSE
Again Use at your own risk. Please make sure you actually need/want a specific repository instead of blindly adding it.

When you have to untangle the mess people get in after clicking this and that. Then perhaps people will be less inclined in suggesting, these warnings aren’t there for the fun of it.

The one clicks work but they still add repos and aren’t choosy and searching build service isn’t recommended for new users(If they’re struggling to add a repo they will certainly struggle with which are the safe repos and the ones not, that the build service search will bring). This should be a last resort, not a first stop that is software management or zypper with carefully chosen repos…