can't activate desktop cube animation

Hi all,

This is my issuee:

I Enter suse menu -> configure desktop -> Desktop Effects (under Workspace Appearance and behavior section) -> In general tab -> Effect for Desktop swiching -> I choose Desktop cube animation and when I apply for changes a message is displayed: “5 desktop effects could not be loaded” I click there on “Details” and a new window appears: " For technical reasons it is not possible to determine all possible error causes.

Blur effect requires OpenGL
Cover Switch requires OpenGL
Desktop Cube Animation effect requires OpenGL
Flip switch effect requires OpenGL.
Startup feedback requires OpenGL

Is important to know that those effects don’t work only in my user. In other users all animation effects works fine.

Any clue on how can I make them run ?

Thanks in advance for any answer
regards

agunet74

It is not clear what graphic chip you have. Intel??

Anyway go to Configure Desktop-Desktop effects Advanced and be sure that you have OpenGL selected as compositing type

I have checked the “OpenGL” ono advanced. The only thiing is disabled (I cannot ckeck or un-check it)

I’ve had this before.
And my only solution was to start a new .kde4
Not something I care to do…

I really don’t understand ! In others users works all fine! only in mineOpenGL doesn’t work !

I guess we need to figure out what graphics card is there and if the proper drives are installed. Easiest way to get the info look at the Kinfocenter which should be in your desktop folder.

How can I Start a new KDE ? Or reset the actual I have ?

we need to know the video card and the driver. It looks like for some reason you don’t have a driver that supports openGL in use. Only you can say what you have

First let me say, all my machines run multiple installations. So I would normally just boot the other system > access my openSUSE KDE /home > view hidden files > and rename .kde4 to .kde4-old
You can also do this with some live CD’s

If you can’t do that, then logout and do a console login (that means no X)
Once logged in as you, do this

mv .kde4 .kde4-old

Then do

su -

enter your password, then type

reboot

Now login normally and you should be good

If you need any settings from the old account (I usually just pick up my ‘konversation’ settings), they are in .kde4-old

the video card has nothing to do with this!

I enter as root ina console and run:
/etc/init.d/xdm stop

Then as ‘agunet’ (my user) and type:
rm -rf.kde4

Then as root again and:
/etc/init.d/xdm start

And all begins to work. The only thing i some confguratiosn were lost

Any way… I solve the masteer: now I can enable cube animation

thanks all for your time

cheers,

agunet

Might try a different use if that works then
You can try resetting the kde configs I guess just rename the ~.kde4 folder but you can’t do that with running as you. Best way log into a console as root (press ctrl-alt-F1) type init 3 to shut down the GUI type

mv /home/yourusernamehere/.kde4 /home/yourusernamehere/.kde4.old

type reboot

that will bring thing back to day zero on the GUI configs.

If different user does not work we need to know what card/driver you are running.