cant access webmail at work, behind firewall appliance.

hello all.
recently i started using my laptop at work.
im using opensuse 11.4 on a lenovo laptop,the network driver is tg3.

the problem : i cant access any webmail service, gmail redirects for a long time after logging in and eventually comes up as a blank screen, the same with yahoo mail.
dropbox syncing also doesnt work, seems to sync forever but never finishes.
i have no problem accessing the web,using rdp,teamviewer etc.
the network dhcp agent is a fortinet 30b appliance, i have a static ip, i have setup rules to allow traffic in and out for my ip for all services but nothing helps.
windows machines in that network, including one ive set with my ip have non of these problems.
any ideas?

Just wondering if perhaps devices on your work network are put into a quarantined subnet if they are lack some specific network config (EAP, etc.). This can also happen if some system management agent does not report compliance - i.e., if no AV software is installed or Windows updates are not up to date you are actually placed in a more restricted subnet, etc. (See Cisco NAC Appliance) Depending on where you work this could certainly be the case.

Of course - it might not be anything that fancy.

Some things to check: You are certain you are on the same subnet as the Windows devices which work? Can you telnet to telnet 443 (one of the IPs dropbox uses to sync with.)

You can also completely disable the firewall to test with, just to be certain.

If you still can’t get it to work, you might need to contact the network folks - if you can telnet to things like 443 but can from a windows system, then something is blocking your traffic.


hey lewstherintelemon.
thanx for the swift reply.
theres nothing of what u described above at my work.
the firewall is configured in the simplest way there is. no subnets or any kind of intranet limitations,no web filtering, just simple dhcp with static ip’s.
i manage this network, thats my job as an it person :wink: im just a linux newbie and thought there might be more then what i know about windows networks.
i know theres no difference in the protocols used and it looked wierd to me that only the linux machine have these problems.
i will try to remove the firewall tomorrow and report back on the result.
i suspect its faulty in some way because i couldnt update its firmware as well.
ill reply tomorrow with the outcome.

Sometimes for these slow connections it helps to disable IPv6 in Yast → network devices → network settings → global options → IPv6

Might be worth a try.

hey there,
sorry for taking long to respond.
tried this out today and it turns out the firewalls firmware was faulty in some way,some features worked when some dont.
i updated the firmware today and it didnt help,i replaced it with a borrowed one from a customer and everything works fine even without special permissions.
thanx for the advice.
as for ip v.6 disabling it actually made things better in the internal network.
thanx again.
all the best.