Can't access USB devices after updates 11.2

openSUSE 11.2 - 2.6.31.12-0.1

Possibly related to kernel update, but can’t be certain.

My USB memory devices show up everywhere as expected, except in any file manager, as root or otherwise.
How do I restore access through file manager?

p35s3g: # fdisk -l

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000da049

Device Boot Start End Blocks Id System
/dev/sda1 1 8924 71681998+ 7 HPFS/NTFS
/dev/sda2 * 8925 8929 40162+ 83 Linux
/dev/sda3 8930 8993 514080 82 Linux swap / Solaris
/dev/sda4 8994 38913 240332400 f W95 Ext’d (LBA)
/dev/sda5 8994 11604 20972826 83 Linux
/dev/sda6 11605 38913 219359511 83 Linux

Disk /dev/sdc: 1024 MB, 1024966656 bytes
32 heads, 63 sectors/track, 993 cylinders
Units = cylinders of 2016 * 512 = 1032192 bytes
Disk identifier: 0xc458ada3

Device Boot Start End Blocks Id System
/dev/sdc1 1 992 999813+ 6 FAT16

Disk /dev/sdb: 4045 MB, 4045406208 bytes
104 heads, 39 sectors/track, 1948 cylinders
Units = cylinders of 4056 * 512 = 2076672 bytes
Disk identifier: 0xf767f767

Device Boot Start End Blocks Id System
/dev/sdb1 3 1949 3946496 b W95 FAT32

p35s3g: # ls -l /dev/disk/by-uuid/
total 0
lrwxrwxrwx 1 root root 10 2010-02-14 13:46 11da0810-cb03-47b6-afd3-61de61d09a96 → …/…/sda5
lrwxrwxrwx 1 root root 10 2010-02-14 13:46 1bd1fe36-2c42-4e94-981a-2f723bceef7a → …/…/sda3
lrwxrwxrwx 1 root root 10 2010-02-14 18:46 3819-DCC6 → …/…/sdb1
lrwxrwxrwx 1 root root 10 2010-02-14 18:46 3B69-1AFD → …/…/sdc1
lrwxrwxrwx 1 root root 10 2010-02-14 13:46 73143d49-3b56-4811-a55d-c7b275f87e50 → …/…/sda6
lrwxrwxrwx 1 root root 10 2010-02-14 13:46 c03ba92e-6535-4098-bf54-c68dcfc4210a → …/…/sda2
lrwxrwxrwx 1 root root 10 2010-02-14 13:46 D208C64108C623F7 → …/…/sda1

Which GUI KDE, Gnome, other??

It’s KDE 4.

Is it mounted? does it show up in Device Notifier?

Can you manually mount it?

type mount to see where it is mounted.

Does it show up in Places?

You may just need to reboot

SO far, it seems that you have to use the “device manager” (sorry I am not in my KDE4 desktop right now) button. I have not managed to use my USB drives, unless I press device manager button and select an option from the list.

I’m away from my Suse pc now, but when I tried to mount by cmd line /dev/sdb1 or sdc1 - it said not listed in fstab, mtab…

Not sure what you mean by the term ‘device notifier’.

They show up in Yast Partition tool (and everywhere else you would expect) and I could add them to fstab, but I don’t want to mount at boot.

I did select ‘Mount’ in the partition tool as a test, but they still didn’t appear in any file mgr.

USB devices apparently do auto mount (hotplug) and were accessible in all file mgrs until recently - until after some updates.

caf4926: I did reboot - even with the devices plugged in.

If you want me to run some specific commands from shell, please list them and I’ll do that when I get home this afternoon - thanks!

removable devices are not mounted in fstab anyway

You should format that device sdc to FAT32 for it to work properly

As I wrote “I could add them to fstab, but I don’t want to mount at boot.” and “I did select ‘Mount’ in the partition tool as a test, but they still didn’t appear in any file mgr.”

They both (sdb and sdc) worked properly on this 11.2 system prior to updates, and continue to work properly in my other opensuse box running 11.1/XP and on every windows machine I have access to.

/sdb is a 4gb SDHC card in a USB adapter, /sdc is a Sandisk 1gb stick with factory partitioning.

Any suggestions?
thanks

You did not mention you desktop KDE or Gnome?

device notifier is a widget in KDE 4 that notifies you when a device is plugged in. it looks like a terminal with a CD on top. If you run Gnome forget about it :X

Putting the USB device in fstab is not the way to go. USB devices are handled by HAL and u-dev.

mount will tell you what is mounted, even if its USB.

Check your logs

Try rebooting

The device notifier is the application in KDE 4. If you right click on it, it should give you Device Notifier Settings.

Yesterday 02:07 It’s KDE 4.

I recall now that I turned the notification off

As I wrote “I could add them to fstab, but I don’t want to mount at boot.”

user10@p35s3g:~> mount
/dev/sda5 on / type ext4 (rw,acl,user_xattr)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
debugfs on /sys/kernel/debug type debugfs (rw)
udev on /dev type tmpfs (rw)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
/dev/sda2 on /boot type ext4 (rw,acl,user_xattr)
/dev/sda6 on /home type ext4 (rw,acl,user_xattr)
/dev/sda1 on /windows type fuseblk (rw,noexec,nosuid,nodev,allow_other,default_permissions,blksize=4096)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
securityfs on /sys/kernel/security type securityfs (rw)
gvfs-fuse-daemon on /home/user10/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=user10)

Here’s what I see in /dev/disk/by-id

file:///dev/disk/by-id/usb-SanDisk_Cruzer_Mini_SNDK4FFC950841108106-0:0
file:///dev/disk/by-id/usb-SanDisk_Cruzer_Mini_SNDK4FFC950841108106-0:0-part1
file:///dev/disk/by-id/usb-SD_MMC_Card_Reader_058F011111B1-0:0
file:///dev/disk/by-id/usb-SD_MMC_Card_Reader_058F011111B1-0:0-part1

So they aren’t mounting, but they are recognized?

Try pulling up File Manager Super User Mode, and accessing it that way.

I have noticed the same thing. I also have a cruzer thumb drive, and when the device notifier indicates its there and I pull it up in Dolphin or Konqueror, or any other file manager as user, it doesn’t show in /media. But, when I pull up Dolphin or Konqueror as root user, I can see it and navigate there. /media/Cruzer/

I haven’t played around with it to “fix” the permissions, as its not that big of a deal to me.

Root mode in file manager didn’t work.

I reinstalled the Device Notifier and it recognized both USB memory sticks as they were plugged in.

Using the Actions for each notification, I selected Open With File Manager. That apparently mounted the device and caused each to become accessible with Dolphin and Krusader.

So now I have a work-around.

What is the process by which USB devices are hot-plugged and mounted?
(so that I can try to troubleshoot)

Thanks!