Can't access external drives. Pendrives, External HD, etc...

I can’t access my drives! It gives me this error: An error

occurred while accessing ‘Volume (vfat)’, the system responded:
org.freedesktop.Hal.Device.PermissionDeniedByPolicy: no <–(action,result)

I get this error in Dolphin and in Konqueror, The drive wont mount at all. It doesn’t show up in /media. I’ve had this error for ~1 & a half.

Can somebody help me?

Hi. I know, it’s a stupid question but - have you tried mounting it as su? And/or creating a mount folder and mounting it manually thereto? Does it show up in YAST/Hardware/Hardware Info?

I updated my whole system and now the drives seem to work except 1 of them. Its a 8G Flash drive and even when on root, I can’t edit the permissions. It says that I’m the owner(root) but when I press OK to save, it goes back to what it was. Even if root is “supposed” to be allowed to read & write(from what the permissions tab says), I cant make folders. What is the problem?

EDIT: Also, I can’t unmount any drive even in root.

Check if you have an entry in /etc/fstab for any of your removable drives. If you have, erase or comment them out.

Note that none of your removables should be listed in fstab. They are configured and mounted as needed by HAL/udev/whatever, and shown in /etc/mtab, which is a kind of “at the moment” fstab. There you can see what permissions are set for all devices. If, for example one is set for ro (read only), even root won’t be allowed to write on it.

It’s a far shot, I know, but - does it have some sort of a hardware protection tab?

I looked at fstab and they are all hard drives. Everything in mstab says rw so that means that I should be able to read and write. Here is a copy of fstab and mstab.


/dev/disk/by-id/scsi-SATA_WDC_WD2500KS-00_WD-WCANKC436708-part3 swap                 swap       defaults              0 0
/dev/disk/by-id/scsi-SATA_WDC_WD2500KS-00_WD-WCANKC436708-part1 /                    ext3       acl,user_xattr        1 1
/dev/disk/by-id/scsi-SATA_WDC_WD2500KS-00_WD-WCANKC436708-part2 /windows/c           vfat       users,gid=users,umask=0002,utf8=true 0 0
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0

My windows is just an empty partition which I cant figure out how to add to my Linux partition.


/dev/sda1 / ext3 rw,acl,user_xattr 0 0
proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
debugfs /sys/kernel/debug debugfs rw 0 0
udev /dev tmpfs rw 0 0
devpts /dev/pts devpts rw,mode=0620,gid=5 0 0
/dev/sda2 /windows/c vfat rw,noexec,nosuid,nodev,gid=100,umask=0002,utf8=true 0 0
fusectl /sys/fs/fuse/connections fusectl rw 0 0
securityfs /sys/kernel/security securityfs rw 0 0
none /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
none /proc/fs/vmblock/mountPoint vmblock rw 0 0

Guys! I found the problem, but I don’t know how to solve it! It’s my OS the problem because I have another computer running the same OS as me(openSUSE 11) and it has no problems with the drives! On my computer, I inserted a disk, it got recognized so I went to the partitioner and went to the yast partition and clicked my flash drive and went to the settings(Edit) and I can’t change the fstab options! On the other computer, everything works fine. I can’t access any of the fstab options on any flash drive(hard drive works fine) on my computer! How can I solve this?

You can do the following to help diagnose the problem. Type the following command (as root):

lshal -m

Now plug in the device. Note/paste what gets reported.

Type ‘fdisk -l’ to see if the device is listed.

‘udevadm monitor’ is another useful command in this situation.

Got the same problem, checked lshal -m , That s what it says:
22:45:01.010: storage_model_DVD_RW_ND_2510A property storage.removable.media_available = true
22:45:01.020: storage_model_DVD_RW_ND_2510A property storage.cdrom.write_speeds = {‘706’}
22:45:01.022: storage_model_DVD_RW_ND_2510A property storage.cdrom.write_speed = 706 (0x2c2)
22:45:01.028: storage_model_DVD_RW_ND_2510A property storage.cdrom.read_speed = 5645 (0x160d)
22:45:03.215: volume_label_WIN_ME_BOOT added

It s not possible to mount the device. Same when i try to mount USB Sticks etc… Any solutions available?


When i plug a 2GB PD the line below appears in mtab:

/dev/sdc1 /media/KINGSTON vfat rw,nosuid,nodev,noatime,flush,uid=1000,utf8,shortname=lower 0 0

The mtab you posted shows no reference to your pendrive. Again, any removable drive will NOT show in your fstab (unless you specifically edit it by hand, of course). You have to plug your pendrive and then see what happens in mtab. If nothing, it probably means that your pendrive is not being detected by udev.

Might it be something related to your PD large size? I’m running a system very much like yours (Asus M2N-MX SE Plus, Athlon X2 5000, onboard nvidia graphics), but kernel is A kernel update may help.

Good luck!

See KDE4: USB stick access fails with Hal.Device.PermissionDeniedByPolicy there’s no need to be root to mount a USB pen drive etc.