Canot access nodejs network URL on other network machine

Already having this working with OSX host but now after using OS LEAP I can’t?


Welcome to the openSUSE forums.

The description of your problem is really the minimum of the minimum. Not much to work from, or even understanding what you are doing. So please explain what you are doing, what you expect that should happen as a result and what happened instead. The best with copy/paste of your commands (between CODE tags, it is the # button in the toolbar above the post editor).

Welcome Henk van Velden,

I’m running a Quasar vuejs application on OpenSuse which works fine.

The problem on other machine connected to wifi which is Lubuntu but this one cannot connect to

Unable to connect.


I don’t have a big experience in OpenSuse, any changes required to Firewall ?


I think that is simple, I prefer an answer from who had experience with the same use case Node project and access via network. (WIFI)

Disable the Firewall temporarily and see…

It’s always nice to see how new (unexperienced) users, claim to now it better and push away experienced helpers which spend their free time to help other users. You failed to provide any useful information as requested by hcvv, so that anybody could help you.

Good luck with such an attitude…

Thank you, Sauerland.

But how to configure that without losing security and what is the knowledge behind that aspect ?

After disabling the Firewall you can reach the Server?

I don’t think it is bad to ask for knowledge from who has experience in such skills (i.e Node, Front-end) to benefit from that.

You failed to provide any useful information as requested by hcvv, so that anybody could help you.

I see that I provided details based on his request for who has experience on that skill.

Yes I was able to access it.

enalbe the Firewall.
Add your Network Card (Wlan or Ethernet) to a Zone, I use public.

Goto that Zone, klick to Ports and add your Port (8081) to TCP_Ports…

Thank you all for the shared info.

I prefer using terminal where I used the following cmds:

sudo firewall-cmd --zone=public --add-port=8081/tcp --permanent

 sudo firewall-cmd --zone=public --add-service=http --permanent
sudo firewall-cmd --zone=public --add-service=https --permanent