Canon printer drivers

I am running openSuse 11 and am trying to get a Canon PIXMA iP1600 printer to work. I am told that driver for ip2200 works, so I downloaded that from Canon (Canon Europe - PIXMA & i-Sensys Linux Page). I get RPM files. When I try to load these using YAST (or the command line) I get errors telling me that I do not have “libxml” and “” loaded. These libraries do not seem to be on installation media. Can anyone help (or tell me where IO can find PPD driver files).
I have looked at some of other posts, but does not help me with this. belongs to package libpng. Packages libpng and libxml are both in the normal OSS repository.

When you talk about ‘install media’, it is quite possible that they are not on the CD/DVD that you used for the installation. But after the installation you should have the OSS and NON-OSS repos in your repos list.
Goto YaST > Software > Software Repositories and see if they are there. Also disable the cd/dvd one there because you do not need it any more.

hi kmeloy;

I assume the Canon package that you need to download has 2 rpm files: what they call a common cups driver, and a specific for the printer; I think canon recommend you install the common driver first;

hopefully if you get your repositories set up, when you ask YaST to install something, it should be able in the future to go off and retrieve what it needs, on its own

oldcpu recommends only four repositories

I recommend only OSS, Non-OSS, Update and Packman. No others. None. You can add others ONLY after you learn more about the risks, implications, and how to resolve problems.

post 4#
multimedia and opensuse - make vlc and plugins work - openSUSE Forums

Unfortunately the system which I want to connect to the printer is standalone - ie not connected to the internet or any other network.
All the software downloads seem to assume you want to install directly on the machine you are using. Is there anywhere I can download the libxml and libpng3, so I can copy them to the standalone computer?

if you installed opensuse 11.0 from a DVD, the libs are likely on that DVD;

failing that, they seem to be in what is called the main repository:

Package Repositories - openSUSE

listed on the above page;

so from any computer with internet access, you should be able to download those, and copy on to USB stick or somesuch and then copy onto your computer that runs 11.0

similarly to download the two canon rpm packages;

install the lib packages first; then the cups common driver, and the specific canon driver

the packages should come as rpm packages; if you copy those into a folder somewhere on your own user home system; (eg directory called downloads) and right-click on each package, and select install with package installer, YaST should open up; you enter your substitute user (root) password, and each should be installed;

post back how it goes

Success! I downloaded libxml and libpng as suggested. Tried to compile the Canon drivers. They still did not appear in YAST, however as a by-product a PPD file was created in /user/share/cups/model. I used this to load the driver and (so far) it works perfectly. Thanks to all for help.


  1. you can now help others: can you go to this page on openprinting:

OpenPrinting database - Printer: Canon ip1600

and report that you got the printer working on OpenSuse and how it went;

  1. when you say

Tried to compile the Canon drivers. They still did not appear in YAST,

I am really curious to understand that: can you tell us exactly what you did; the reason I ask is the drivers for suse are easiest if they are rpm files; and I wondered if you used those