Canon Pixma ip4000 and gutenprint driver doesn't work

I hzave openSuse 11.1 64bit gnome installed. My printer is Canon Pixma ip4000 and i installed gutenprint because this site OpenPrinting database - Printer: Canon iP4000 says the printer works well with this driver. But when i go yast > printer and add a printer, it doesnt list a driver when i select the pixma ip4000 device. Isnt that the way to instlall the driver?

Canon are not very well supported

HCL/Printers - openSUSE

I would probably look at the cups localhost method
CUPS - Explained - openSUSE Forums

This is a shame as other Linux distributions I have tried when the printer is turned on it is just auto configured. It is recognized and then it just works. To bad OpenSUSE is not the same way.

Though I am using 32 bit system. Opensuse 11.1 works well with my canon ip400 printer. The driver is there right after the installation it is called canon pixma ip4000. It is detected by yast and ready to be installed. Please have a look again in yast it should be there.

Cool, it was pretty easy with CUPS. I just put http://localhost:631 in my web browser and installed my printer in few and easy steps.I printed a test page, it works, thanks :slight_smile:

And no, there wasnt any driver in yast, here is how it looked like ImageShack - Image Hosting :: bildschirmfotoxd7.png

Great. Linux is so good! Well done.

Good you’ve made it work.

I had a similar problem with my iP5000, appeared to be no driver whatever I did.
finally I highlighted the printer name in the box next to the ‘add driver’ button. I then hit delete. ‘any printer’ appeared in the box. I could then scroll down to the gutenprint driver, highlighted it then clicked Ok.
I was then able to use the printer.
I would say that the ‘improvement’ of the printer setup in yast has in fact made it harder,:expressionless: or less intuitive than it was in previous versions of Opensuse.
The drivers are in /usr/share/cups/model/Canon.
Hope that this might help others with a similar problem!

Thanks for the tip. It worked for me. OpenSuse 11.1 and canon pixima ip4200. Finally can print now :slight_smile:

I agree, harder and more complicated.