Canon mp250series driver failure

When I try to instal the rpm I downloaded from canons support website after authentication the install process fails with the following error report:

[PK_TMP_DIR|dir:///var/tmp/TmpDir.kLgXId] Repository already exists.

I believe the packages I download (cnijfilter-common-3.40-1.i386.rpm and cnijfilter-mp250series-3.40-1.i386.rpm) are fine–not corrupted.

What went wrong?

When I try to instal the rpm

perhaps you tell us what you did; in some detail

after i extracted the packages, I use the right click menu in Nautillus to install the rpm (cnijfilter-common-3.40-1.i386.rpm). I’ve used the ‘open with install/remove software’ and ‘open with package installer’. And that’s what I’ve got.

Should I use the terminal instead? Thanks in advance

If I google on the phrase

[PK_TMP_DIR|dir:///var/tmp/TmpDir.kLgXId] Repository already exists.

I get two responses, both from OpenSuse forums

Repository Already Exists

I see in the above post that caf recommended

su - terminal, one at a time in this order
zypper rr 2
zypper rr 1
zypper clean --all
zypper ref

so one enters

su - zypper rr 2
and enters the Substitute User password, and then copy and paste each of the commands in one by one to the terminal and hit enter

then you should be able to install the Canon driver …

let us know how it goes

Thanks for the reply. I really appreciated it.

I did a bit reading in the terminal. then, after typing rpm, and I typed

rpm -i -p ‘name of package.rpm’

the terminal returned nothing (I was expecting something more dramatic to indicate whether the command worked or not). But, then I found out that Yast > hardware > printer has identified my canon mp258. It printed the test page well. SO, I assume my problem is solved. But, do I still have to do what you suggested above for some reasons?

so canon make two rpm packages: the common and mp250series;

if you installed both, and your test page prints; you should be good to go: enjoy!

Thank you very much. I’ve tested the scanner. It works Xsanely well.

thank Canon for making these packages available to support linux users