Canon iP1880 driver problem

I just intalled opensuse for about a month now. Have upgraded to KDE 4.3.5 . Now I’m trying to use my canon ip1880. I have downloaded cnijfilter-ip1800series-2.70-1.i386.rpm and cnijfilter-common-2.70-2.src.rpm. I have installed the 2nd tarball first and all seems well. After i tried to install the 1st tarball, this error appears :

libgdk-1.2.so.0 is needed by cnijfilter-ip1800series-2.70-1.i386.rpm
libglib1.2.so.0 is needed by cnijfilter-ip1800series-2.70-1.i386.rpm
libgmodule-1.2.so.0 is needed by cnijfilter-ip1800series-2.70-1.i386.rpm
libgtk-1.2.so.0 is needed by cnijfilter-ip1800series-2.70-1.i386.rpm
libpng.so.3 is needed by cnijfilter-ip1800series-2.70-1.i386.rpm
libpopt.so.0 is needed by cnijfilter-ip1800series-2.70-1.i386.rpm
libxml.so.1 is needed by cnijfilter-ip1800series-2.70-1.i386.rpm

Where do i search all this dependencies? Am i doing things right?

Box: openSUSE 11.2 | (KDE4.3.5) | Acer RS740DVF | AMD64 X2 5600+ | Radeon HD4670 | 3GB RAM