Canon CAPT goes OSS?

hi all
i am just download drivers for canon lbp2900 from


it is sources no rpm or bin files… for now… i’m confused
never heared about that canon open their drivers…

ordinary companies use this step as a PR action…


* These programs except for cnsktmodule are licensed under the terms of
the GNU General Public License. (See the file COPYING.)
* cnsktmodule is subject to MIT License.
(See the file cnsktmodule/LICENSE.txt).

is somebody know about that?

i can’t belive in that… i think it just somebodies mistake?

i’ve miss some
archive cndrvcups-common-1.70 have some binaries in lib folder

so it still proprietary…

i just want to told you about some trick how printer canon LBP2900 is perfectly work for me… it works on opensuse 11 with both 1.6 and 1.7 drivers

first of all it should be installed exectly like is writen in the docs that goes with drivers…

the main problem for me was that i could not understand some things…
when printer is switch of the driver (or what ccpd is) ccpd stop working.
i installing printer when printer was off and turn it on after installation of software. of course it does not working.
when you turn printer on it could appear window with something about new printer found… you must ignore this every time (even if i configured it with yast, gnome and cups it stil appears after restarting of printer)

then it needed stopping of ccpd

sudo /etc/init.d/ccpd stop# maybe it is not really important but just for shure :slight_smile:

after that you should restart cups
sudo /etc/init.d/cups restart

then start ccpd

sudo /etc/init.d/ccpd start

that’s all

you could be know is everithing ok with your printer for shure
you could start gui monitor
sudo captstatusui -P <your printer name>&

i did

sudo captstatusui -P LBP2900&

it is important that captstatusui was run by super user…

i hope it will be helpfull for someone

well done to get this running; a previous contributor to the forum worked very hard to try to get a LBP3300 working, but to no avail; he started with a 64bit Suse 11.0 system, and I think also tried a 32 bit install, but it kept on giving error messages; well done to get this install working