Canon camera unnoticed

I have plugged a Canon IXUS 8015 camera, and nothing appears in the ‘Devices recently plugged in’ applet (KDE 4.1.3, SuSE 11.1)
I know I should browse the web, use google, etc, but I am really tired of googling for every possible thing each time I upgrade my op.system (this camera worked plug-n-play under Ubuntu 7.10; my logitech webcam worked plug-n-play under Ubuntu 7.10, and now it does not; etc etc etc)
This is /var/log/messages:

Jan 15 17:43:49 nbad11 kernel: usb 1-2: new high speed USB device using ehci_hcd and address 3
Jan 15 17:43:49 nbad11 kernel: usb 1-2: configuration #1 chosen from 1 choice
Jan 15 17:43:49 nbad11 kernel: usb 1-2: New USB device found, idVendor=04a9, idProduct=3184
Jan 15 17:43:49 nbad11 kernel: usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Jan 15 17:43:49 nbad11 kernel: usb 1-2: Product: Canon Digital Camera
Jan 15 17:43:49 nbad11 kernel: usb 1-2: Manufacturer: Canon Inc.
Jan 15 17:43:49 nbad11 kernel: usb 1-2: SerialNumber: 7A1B255BD1D940FFB0E0A14A0AF2CFEE

8015 or 80 IS? There is a 80 IS in Digikam’s tables.

What happens if you go into digikam and add the camera anyway?

Thanks, that was a good hint. It does work in digikam.
However, in Ubuntu it appeared as a storage device (although it is not a usb mass storage device). Clicking on the camera icon, which appeared on the desktop when I plugged in the camera, one could use it in dolphin in the same way as other (usb mass storage) cameras. I liked this approach more, since it handled all cameras and other picture storage devices in the same way. I don’t like to have 1000 different applications for slightly different tasks. I just want to copy pictures.
Does anybody know how to reach this? Was this an ubuntu-specific feature, or just a setup question?

Ubuntu or Kubuntu? If Ubuntu, then you were using GNOME and you should use GNOME under OpenSUSE to compare oranges with oranges.

sorry, it was kubuntu.

I think there are some issues with plugin devices under 11.1 at the moment. It ought to briefly appear in the device notifier asking what you want to do.

Notifications are not of primary importance of me, as long as I know what to do myself.
I recalled now that under Kubuntu 7.10 the camera was opened in dolphin via the camera:/ interface in dolphin. So I tried it now, typing camera:/ into the location bar: my camera was listed, but clicking on gave no result, just nothing happened.