cannot wake up

Im on tumbleweed with the minimal desktop environment. I have installed xmonad as my wm.
I am on a desktop pc, with an nvidia graphics card.

So if my system idles, it will suspend or hibernate, not sure which it is. But when it does, I cannot wake it up.
So the interesting thing is sometimes I am able to get to tty1. Also If i suspend and wake up immediately after it seems to be ok.

All i want is to be able to leave my pc, have the screen turn off or something, so that it doesn burn, and then be able to resume the pc. I dont care if it is hibernate, suspended, or even just the monifor is turned off. I dont want to be forced in to suspend/hibernate after idle and each time this happens i basically have to reboot.

I have tried to disable hibernate and suspend via my sleep.conf:


So i cannot issue systemctl suspend, or hibernate, so it works as expected.
I thought maybe dpms maybe doing someting, so I issued

xset s off

and also tried

xset dpms 0 0 0

I also tried to hibernate on a fresh install without any nvidia graphics drivers, and still the same issue, so i dont think it has anything to do with nvidia.

As a last ditch effort I installed xfce4-power-manager, and tried to fix it there, but this did nothing.

I hopped from debian because the stuff was too outdated. But on debian if i idled too long, my screen would just turn off, and come back on no problem.
Windows has no issue with this, either, so i dont think its hardware related.

I have tried looking at different logs, but nothing seems to point out any glaring issues related to waking up, so I am at a loss.