Cannot use simple scan software with Cannon Pixma MP 280 scanner printer with Opensuse 13.1


Recently installed Opensuse 13.1 Gnome version and not used Opensuse before. Model of 3 in1 Cannon printer (including scanner) is Pixma MP280. Checked Sane Project’s Website to see if this Scanner is supported and it is listed as good. Have used this scanner with Fedora 19 and 20 using Simple Scan software and it worked fine.

When I try using this Cannon Scanner with Simple Scan software with Opensuse 13.1, it churns and sounds as thought it might work, but it comes up with a message “Failed to scan- error communicating with scanner”. When I click the Change the scanner icon in the dialogue box that comes up it shows the model of my Cannon 3in 1 printer correctly under preferences.

Please can you help me resolve this problem.



Did you install the Cannon drivers?

I’m not sure if this problem is related to a regression with the pixma back-end or the scanning utility, but you could try using xsane (front-end) to see whether it behaves differently. A bug report may be required. Other than that, I’d go with gogalthorp’s suggestion to use the proprietary scanner driver and ‘scangearmp’ scanning app instead.

Hello again

Thanks for your suggestions.

I have tried using xsane from the Opensuse repository to see if it will activate my scanner but does not improve the situation.The error message is the same as before. What I forgot to mention before that the scanner just scans part of a document- a small part of the first line. I am sorry about this but I have short-term memory loss and poor concentration at times.

When I installed Opensuse, I did run all the updates.

I have downloaded Cannon’s scangearmp app and tried installing this but have come stuck with this. I have looked for additional tar type software in addition to what was already installed, but I do not know what I else I need to install this type of software (tar.gz).

The printer part of my Canon 3 in 1 printer works fine with the software from Opensuse software repository.

Perhaps I should report my scanner situation as a bug as you suggest.

Have you got any further suggestions that might help?



[size=5] [/size]

Please don’t change the fonts/sizes when posting. (It can appear as shouting, and harder to read anyway.)

The .tar file (tarball) needs to be unpacked (extracted) first. You should be able to right-click on the file via your file manager and do this. It will create a folder of the same name with the RPM files contained within. Click on those should be enough to have the package manager install them (and any dependencies) for you.