Cannot use recovery partition for Win7 after installing OpenSuse 12.1

Hello,

I am a complete newbie to linux, so please forgive me if I’m not exact enough. Here is what happened:

I have a laptop from the VAIO SE series that has a recovery partition (no recovery disks, and also my CD-ROM does not work now anyway). Using the Win Disk Management I partitioned the disk so I could have it all - basically it looked something like that:

recovery partition
C: Windows 7 system
D: data partition (made under Win)
L: for Suse
free space here
M: for Linux Mint
O: swap partition

I first installed Linux Mint, as a sort of backup in case I couldn’t get Suse to work (I have to work on Linux, therefore I wanted to have one secured). The installation (performed from an USB, where it was put by Universal USB Installer) was successful and then I proceeded to install Suse on disk L (in the same way, from an USB). I managed to properly assign disks during the installation (95% sure) and it completed well. However, Suse was running unbelievably slowly and also during the booting I only had an option to choose SUSE or Win (Mint disappeared from the boot options - I can see in the file system that the disks are still there, btw).
So putting little thought to it (this is probably where the problem started :mad:) I just did format on the partition L (with SUSE) under Windows… Problem was that I think SUSE changed something in the booting settings of the system, because then, once I tried to restart my computer, nothing happened.

So then I installed SUSE again in order to get anything working. Indeed, something works. When booting starts (and the booting has ensembles of SUSE already) I get the following options:

SUSE
Windows 1
Windows 2
SUSE (fail-recovery) [or some similar name, you get the point]

Windows 1 leads to my C: Windows system. However, both Suse and Windows work poorly, they are terribly slow now and also they freeze a lot, the monitor turns on or off at random times - a complete disaster! I couldn’t work on systems that are so unstable (I use my computer to control experiments and so the performance should be continuous).

Now in principle my VAIO laptop as an ASSIST button that when pressed while computer is off should take me to the recovery mode. However, now it takes me to the SUSE boot options… the same that when I just turn the computer on. And if I choose Windows 2 option, I get the following message:

rootnoverify (hd0,2)
chainloader +1

BOOTMGR is missing
Press Alt+Ctrl+Del to restart

Could you please tell me if there any options that I could

  1. check whether my recovery partition is OK
  2. use the said recovery partition?

I have all my stuff backed-up, so I don’t mind erasing all the data if necessary. As I am pretty familiar with Windows, I would just love to make the Win7 recovery partition to get everything formatted and installed anew.

I will be incredibly grateful for any help!

So you may have a recovery partition, but Windows 7 would by default create two more partitions, one for boot and one for Windows, most often called the C: drive. You do not use the Windows partition program to create SUSE partitions as it does not use NTFS for its native install. A full accounting of your hard disk, number of partitions and partition types and sizes would be in order for use to read. It is best to have free unpartitioned space for which openSUSE can install its three normal partitions of root / (EXT4), /home (EXT4) and SWAP. I suggest a minimum 40 to 80 GB total for all three partitions. SWAP partitions can be shared between Linux version, but if you use it to hibernate, you must go back into the same Linux OS version from which it came. I have a blog on Partitions you could read about here:

Creating Partitions During Install for MBR and GPT Hard Disks - Blogs - openSUSE Forums

Thank You,

On 2013-07-23 00:26, Agness wrote:

Oh, my… :frowning:

> Could you please tell me if there any options that I could
> 1) check whether my recovery partition is OK
> 2) use the said recovery partition?

It is probably there, but not the same partition number, probably, so
the automatics fail to call it.

You probably need to install grub right, and then call that restore
partition from it. Perhaps use one of those grub rescue live CD to just
boot it.

An alternative is to just restore the HD from a backup, assuming you did
an image and not a data backup. Or, hopping you created a DVD rescue,
use it.


Cheers / Saludos,

Carlos E. R.
(from 11.4, with Evergreen, x86_64 “Celadon” (Minas Tirith))

jdmcdaniel3:

Thank for redirecting to the manual for creating partitions!

I do think that I proceeded all right in this regard though,. During the Suse installation I chose advanced options and selected my L (sda6 or so, of 80 GB) disk to mount (), after formatting to ext4. I do not remember whether I allowed Suse to create a different partition for \home (there is a special place to accept this or not), it may be that I did, but I am not sure what would be the result?
Anyways, after choosing these options the message window clearly stated that the system will be installed on sda6 after formatting to ext4, and that the swap will be sda8 (the one I already formatted while installing Mint, so that Suse just detected it as the correct one).
*
“A full accounting of your hard disk, number of partitions and partition types and sizes would be in order for use to read”* - do you mean by that that I should provide some system output about the hard drive? (Sorry, my English is not that great)

robin_listas:

I’d like to play with GRUB a little for sure, but sadly I cannot really use your advice: as I wrote, my CD-ROM is broken, so I cannot use any CDs/DVDs. And no, by backup I meant only data backup and not an image…

Do you think that the GRUB is installed wrong though? Couldn’t I just try to call (after finding it) the recovery partition from it as it is? (Of course, I have no idea how would I do that, but I’m willing to try!)

Thanks for the answers!

So it seems that I have the following disks:

command sudo /sbin/fdisk -l :

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xb70da62f

Device Boot Start End Blocks Id System
/dev/sda1 * 2048 42993663 21495808 27 Hidden NTFS WinRE
/dev/sda2 42993664 43198463 102400 7 HPFS/NTFS/exFAT
/dev/sda3 43198464 252911615 104856576 7 HPFS/NTFS/exFAT
/dev/sda4 * 252915710 976771071 361927681 f W95 Ext’d (LBA)
/dev/sda5 252915712 756252671 251668480 7 HPFS/NTFS/exFAT
/dev/sda6 756254720 924047359 83896320 83 Linux
/dev/sda7 932448256 968370130 17960937+ 83 Linux
/dev/sda8 968372224 976771071 4199424 82 Linux swap / Solaris

command df -Th:

Filesystem Type Size Used Avail Use% Mounted on
rootfs rootfs 79G 3.0G 75G 4% /
devtmpfs devtmpfs 1.9G 8.0K 1.9G 1% /dev
tmpfs tmpfs 1.9G 96K 1.9G 1% /dev/shm
tmpfs tmpfs 1.9G 772K 1.9G 1% /run
/dev/sda6 ext4 79G 3.0G 75G 4% /
tmpfs tmpfs 1.9G 0 1.9G 0% /sys/fs/cgroup
tmpfs tmpfs 1.9G 772K 1.9G 1% /var/lock
tmpfs tmpfs 1.9G 0 1.9G 0% /media
tmpfs tmpfs 1.9G 772K 1.9G 1% /var/run

I am sure the recovery partition is sda1, but how to get to it? And still, how can I be sure that once I reach it it will work?

Hello Agness,

You are new here (welcome) and thus we have to tell you something about the forums here that is not obvious to know. Please, when you post computer text like the fdisk -l output above, do so between CODE tags.

You get the CODE tags by clicking on the # button in the tool bar of the post editor. Then please copy/paste complete, that is the prompt, the command, the output and the next prompt, directly from your terminal in between the CODE tags.

This has many advantages. E.g. when you include the command in your copy/paste, there is no need to tell stories about the command you used.

Thanks for pointing this out!

I think now it looks OK:


agnes@linux-r8k5:~> sudo /sbin/fdisk -l
root's password:

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xb70da62f

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048    42993663    21495808   27  Hidden NTFS WinRE
/dev/sda2        42993664    43198463      102400    7  HPFS/NTFS/exFAT
/dev/sda3        43198464   252911615   104856576    7  HPFS/NTFS/exFAT
/dev/sda4   *   252915710   976771071   361927681    f  W95 Ext'd (LBA)
/dev/sda5       252915712   756252671   251668480    7  HPFS/NTFS/exFAT
/dev/sda6       756254720   924047359    83896320   83  Linux
/dev/sda7       932448256   968370130    17960937+  83  Linux
/dev/sda8       968372224   976771071     4199424   82  Linux swap / Solaris
agnes@linux-r8k5:~> df -Th
Filesystem     Type      Size  Used Avail Use% Mounted on
rootfs         rootfs     79G  3.1G   75G   4% /
devtmpfs       devtmpfs  1.9G  8.0K  1.9G   1% /dev
tmpfs          tmpfs     1.9G   96K  1.9G   1% /dev/shm
tmpfs          tmpfs     1.9G  764K  1.9G   1% /run
/dev/sda6      ext4       79G  3.1G   75G   4% /
tmpfs          tmpfs     1.9G     0  1.9G   0% /sys/fs/cgroup
tmpfs          tmpfs     1.9G     0  1.9G   0% /media
tmpfs          tmpfs     1.9G  764K  1.9G   1% /var/run
tmpfs          tmpfs     1.9G  764K  1.9G   1% /var/lock
agnes@linux-r8k5:~> 


Looks very fine. I hope people can help you to your satisfaction.

On 2013-07-23 08:16, Agness wrote:
>
> So it seems that I have the following disks:

Please use code tags. The ‘#’ button - for command outputs and listings
View this
thread for instructions

Besides, instead of saying “I enter command such and I get…” we prefer:


computer ~# suchcommmand
listing...
listing...
computer ~#

Then we can see for ourselves how you enter the command.

I’ll try to convert.


> command    sudo /sbin/fdisk -l :
>
> Disk /dev/sda: 500.1 GB, 500107862016 bytes
....
>
> Device Boot         Start         End      Blocks   Id  System
> /dev/sda1   *        2048    42993663    21495808   27  Hidden NTFS WinRE
> /dev/sda2        42993664    43198463      102400    7  HPFS/NTFS/exFAT
> /dev/sda3        43198464   252911615   104856576    7  HPFS/NTFS/exFAT
> /dev/sda4   *   252915710   976771071   361927681    f  W95 Ext'd (LBA)
> /dev/sda5       252915712   756252671   251668480    7  HPFS/NTFS/exFAT
> /dev/sda6       756254720   924047359    83896320   83  Linux
> /dev/sda7       932448256   968370130    17960937+  83  Linux
> /dev/sda8       968372224   976771071     4199424   82  Linux swap / Solaris
>
>
>
> command   df -Th:
>
> Filesystem     Type      Size  Used Avail Use% Mounted on
> rootfs         rootfs     79G  3.0G   75G   4% /
> devtmpfs       devtmpfs  1.9G  8.0K  1.9G   1% /dev
> tmpfs          tmpfs     1.9G   96K  1.9G   1% /dev/shm
> tmpfs          tmpfs     1.9G  772K  1.9G   1% /run
> /dev/sda6      ext4       79G  3.0G   75G   4% /
> tmpfs          tmpfs     1.9G     0  1.9G   0% /sys/fs/cgroup
> tmpfs          tmpfs     1.9G  772K  1.9G   1% /var/lock
> tmpfs          tmpfs     1.9G     0  1.9G   0% /media
> tmpfs          tmpfs     1.9G  772K  1.9G   1% /var/run


>

> I am sure the recovery partition is sda1, but how to get to it? And
> still, how can I be sure that once I reach it it will work?

Possibly. But being #1, it is strange it does not boot. My theory
explains it when it is the last, but not the first.

We will need grub configuration somehow. :-?


Cheers / Saludos,

Carlos E. R.
(from 11.4, with Evergreen, x86_64 “Celadon” (Minas Tirith))

On 2013-07-23 07:56, Agness wrote:

> I do not
> remember whether I allowed Suse to create a different partition for
> \home (there is a special place to accept this or not), it may be that I
> did, but I am not sure what would be the result?

It is a tick box on partitioning defaults - but it may go away in expert
mode.

The idea of a separate /home is that you can reinstall the system
without touching your data files. However, if the space is limited, it
makes sense to use the root filesystem instead, and either do system
upgrades, or backup-reinstall-restore.

> robin_listas:
>
> I’d like to play with GRUB a little for sure, but sadly I cannot really
> use your advice: as I wrote, my CD-ROM is broken, so I cannot use any
> CDs/DVDs. And no, by backup I meant only data backup and not an image…

Pity. A USB stick, perhaps, if you can put the restore image there.

> Do you think that the GRUB is installed wrong though? Couldn’t I just
> try to call (after finding it) the recovery partition from it as it is?

Possibly - but I’m not very familiar with grub 2 either. Grub 1 yes.
Others may know.


Cheers / Saludos,

Carlos E. R.
(from 11.4, with Evergreen, x86_64 “Celadon” (Minas Tirith))

Again, there is NO restore image.

I have searched the web a bit and changed the GRUB menu.lst file so that now it looks like that (I’ll put this into code mode, though I may be again wrong in doing that…):


# Modified by YaST2. Last modification on Mon Jul 22 20:48:19 CEST 2013
# THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
# For the new kernel it try to figure out old parameters. In case we are not able to recognize it (e.g. change of flavor or strange install order ) it it use as fallback installation parameters from /etc/sysconfig/bootloader

default 0
timeout 30
##YaST - generic_mbr
gfxmenu (hd0,5)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 12.1
    root (hd0,5)
    kernel /boot/vmlinuz-3.1.0-1.2-desktop root=/dev/disk/by-id/ata-TOSHIBA_MK5059GSXP_91S2F8Y7S-part6 resume=/dev/disk/by-id/ata-TOSHIBA_MK5059GSXP_91S2F8Y7S-part8 splash=silent quiet showopts vga=0x317
    initrd /boot/initrd-3.1.0-1.2-desktop

###Don't change this comment - YaST2 identifier: Original name: windows 1###
title windows 1
    rootnoverify (hd0,1)
    chainloader +1

###Don't change this comment - YaST2 identifier: Original name: windows 2###
title windows 2
    rootnoverify (hd0,2)
    chainloader +1

###This is my attempt at editing grub
title windows 3
    rootnoverify (hd0,0)
    chainloader +1

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 12.1
    root (hd0,5)
    kernel /boot/vmlinuz-3.1.0-1.2-desktop root=/dev/disk/by-id/ata-TOSHIBA_MK5059GSXP_91S2F8Y7S-part6 showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x317
    initrd /boot/initrd-3.1.0-1.2-desktop
~      

One can see where I tried to add another option (windows 3).

So now the result is this:
my sda1 with 20GB [windows 3 in GRUB] - which looks like the actual recovery partition - loads normally to Win7 system
my sda2 with ~100MB [windows 1 in GRUB] or so loads normally to Win7 too
my sda3 with 100GB [windows 2 in GRUB] - which is actual Win7 C: partition - does not load at all, but shows the BOOTMGR missing message described earlier

Why wouldn’t it go into the recovery mode? Maybe chainloading is used in a wrong way somewhere?

It’s probably an insane idea, but would somehow uninstalling GRUB be of any help? Remember that I have this ASSIST button on my VAIO which directed perfectly to the recovery mode until GRUB was there.

Thanks for any remarks!

After installing Linux Mint (Legacy Grub or Grub 2??) did it boot Windows correctly, and did it it have Windows 1 and Windows 2?

Hmm, why install 12.1 when you could install 12.2 or the latest 12.3? Did you install Legacy Grub (IIRC it also had optional Grub2 - buggy then)? I would have expected “Windows 2” entry to also arrive at C: Windows system, but it doesn’t as you explain here:

Now in principle my VAIO laptop as an ASSIST button that when pressed while computer is off should take me to the recovery mode. However, now it takes me to the SUSE boot options… the same that when I just turn the computer on. And if I choose Windows 2 option, I get the following message:

rootnoverify (hd0,2)
chainloader +1

BOOTMGR is missing
Press Alt+Ctrl+Del to restart

That looks like two legacy grub statements from the “Windows 2” entry in the grub config file, addressing partition sda3 (legacy grub addressing starts from zero so hd0,0 is sda1) which could be your Data partition. It wouldn’t find Window’s bootmgr there! So that isn’t right. Either the openSUSE installer screwed up there, or it was changed manually either using YaST bootloader configuration tool or a text editor on menu config file at /boot/grub/menu.lst (BTW, that’s different for Grub2 and its addressing starts from number one).

It’s also possible that one of the linux installers overwrote the original Master Boot Record (MBR) that enabled recovery booting from sda1 via Sony’s ASSIST button. I’m sure your recovery partition is at sda1 which is normal for Win 7, as its system partition contaiining the Windows Recovery Environment, boot manager, and some necessary system files.

It is likely that the openSUSE installer set the boot flag on the Extended Partition at sda4. It does that if you are booting openSUSE from a logical partition.

Did you ever make a Windows Recovery CD (recommended) as one way to reach sda1?

PS. Please note, I hadn’t seen your last post when I wrote this.

Hi consused, thanks for your remarks!

So my last note contains a bit of updates, I’ll try however to answer your question without repeating myself too much.

It had actually five options on a black screen, but I don’t remember them very well. They definitely were described in a different way (more details than windows 1 or 2). I think there was Linux Mint option, Linux Mint recovery, and then 3 for Windows? I may be wrong though, I only managed to see them once or twice before I tried suse…

I’d actually love to know how to check my GRUB version. I installed 12.1 because it was the latest version compatible with Universal USB Installer (my CD-ROM does not work).

When it comes to MBR files I am sure I made everything worse by erasing the first SUSE by hand and installing the new one right afterwards. That way probably the version of the MBR files (SUSE automatically saves them before installation) that it is now possible to return to through the SUSE yast manager is the one with the first SUSE in it… (if I get the concept right, that is).

I am almost sure this is true, see my previous post.

No, and again CD drive is not working, only USB.

So yeah, I am still where I was last night. I am almost sure the problem is in the GRUB overwriting the MBR file, but where should I proceed from there - no idea. I am almost pondering the idea of getting another Linux Installer on another USB (I’ll keep this one with a working installation just in case) and trying to erase all disk altogether with it.

I am also wondering why is it that this SUSE works so unbelievably slow (as in, opening new tabs in Firefox for 20 secs or longer, changing between application for 30 secs and so on). This whole problem would not be such a pain if not for my practical inability to work now.

Anyways, again thanks!

Well sda3 fails because it is probably not a Windows bootable partition e.g. not marked as “Active”. I assume therefore that Win 7 bootmgr can’t boot it. AFAICT, the Wiin 7 Disk Management partitioner will only let you mark one partition as “Active”. I suspect sda2 is marked as “Active” (Win 7 terminology). AFAICT, also linux partitioners will only let you set the boot flag against one partion.

It’s a waste of effort chainloading an unbootable partition. It makes no sense!

I agree that it is a waste of effort. I understand it that it is some bootable options in sda1 and sda2 that actually start Windows. I rather posted this results to make it clear which partition behaves in which way.
Still, one of them (sda1 and sda2) should not do that but start recovery instead, and I cannot myself see a way to make this happen yet.

Btw, in the very same way I changed the menu.lst file to boot the Linux Mint that one can see among the partitions. However, it just produces an error that says there is no basis to boot (or similar, I can check if needed).

You are using legacy grub. Grub2 doesn’t have “menu.lst” configuration file. Personally, I would stick with legacy grub for a while - it’s easier to edit.

BTW your sda2/C: looks far too small at around 102MB or 102400 blocks (can that be right from fdisk report?). There can’t be much room for a page file, leading to poor performance. My sda2/C: for Win 7 is about 50GB used, and I don’t use it much! :smiley:

My C: is sda3, the one that is 100 GB ;). According to Win disk manager the description is the following:

sda1: 20.50 GB Healthy (Active, Recovery Partition)
sda2: 100 MB System reserved (System, Primary Partition)
sda3: 100 GB Healthy (Boot, Page File, Crash Dump, Primary Partition)

I am not sure what this means system reserved means though.

Happy to know which GRUB I have!

That should not be the C: drive ( I hate MS nomenclature) It may be a boot partition the c: drive would then be sda3 100 meg is way to small for a c: drive.

On 2013-07-23 19:16, Agness wrote:

> consused;2573934 Wrote:
>>
>> Hmm, why install 12.1 when you could install 12.2 or the latest 12.3?
>> Did you install Legacy Grub (IIRC it also had optional Grub2 - buggy
>> then)?
>
> I’d actually love to know how to check my GRUB version. I installed
> 12.1 because it was the latest version compatible with Universal USB
> Installer (my CD-ROM does not work).

Why do you need that “Universal USB Installer”? If you do a raw write of
the opensuse image to USB, and your BIOS can boot from USB, you can
install any recent openSUSE version from USB. There are instructions on
the wiki.

> I am also wondering why is it that this SUSE works so unbelievably slow
> (as in, opening new tabs in Firefox for 20 secs or longer, changing
> between application for 30 secs and so on). This whole problem would not
> be such a pain if not for my practical inability to work now.

Few people had that problem, and some of them with no reason we could
find, but often is that the system has the automatic content search
engine running at large. Or two engines (the kde one and the gnome one).


Cheers / Saludos,

Carlos E. R.
(from 11.4, with Evergreen, x86_64 “Celadon” (Minas Tirith))

On 2013-07-23 18:16, Agness wrote:
>
> robin_listas;2573904 Wrote:
>>
>>
>> Pity. A USB stick, perhaps, if you can put the restore image there.
>>
>>
>
> Again, there is NO restore image.

Always do a restore image when you get a new computer with Windows…
ASAP, before you connect the machine to any network the first time.

Consider yourself spanked >:-)

> I have searched the web a bit and changed the GRUB menu.lst file so
> that now it looks like that (I’ll put this into code mode, though I may
> be again wrong in doing that…):

No, no, it is perfect.



>   ###This is my attempt at editing grub
>   title windows 3
>   rootnoverify (hd0,0)
>   chainloader +1


Good! Did you try it? What happened?

> Why wouldn’t it go into the recovery mode? Maybe chainloading is used
> in a wrong way somewhere?

Looks good to me.

> It’s probably an insane idea, but would somehow uninstalling GRUB be of
> any help?

No.

> Remember that I have this ASSIST button on my VAIO which
> directed perfectly to the recovery mode until GRUB was there.

It only works, I guess, with the MBR untouched.

The other possibility is to set the first partition with the boot mark.
May work, may not.


Cheers / Saludos,

Carlos E. R.
(from 11.4, with Evergreen, x86_64 “Celadon” (Minas Tirith))