Cannot use HTTP on OpenSUSE 12.2/ KDE4.9 / 3.4.11 x86

Hello,
I can not browse web pages using either a wireless network at home or a wired connection at work, using the same laptop.
All other hosts on the network can use all other network services, including browsing web pages.
The laptop in question can use all other network services (AFAIK), such as SMB shares and Bit Torrent.

The only thing that doesn’t work is browsing web pages, using either Firefox or Chromium. I’ve tried connecting wired and wirelessly, using diferent IP addresses, and deleting and re-creating connections in network manager. I have windows installed dual-boot, and this problem does not occur in windows, all network services are ok.

I’m completely stumped. How can this be? I have had problems with openSUSE spontaneously changing configurations (deleting mount targets in /media/*, getting confused about the time zone and changing the system time, for example), so it quite literally could be anything. Can someone help me narrow it down?

Some sort of problem, virus, maybe, attacking linux http services? I’m grasping at straws here. I can not browse using my Android phone either, but my wife’s Iphone is ok on the same network.

Apparently there’s some sort of problem with DNS. I can ping websites and browse by IP, but not by name on the problem laptop. DNS should be provided by my ISP, and it is, to my wife’s windows laptop, my Ubuntu desktop, the dual-boot windows 7 system on my laptop, and my wife’s Iphone, but not to my openSUSE sysyem for some reason.
Again, how can this be? WHy is openSUSE having problem locating a DNS server when it’s automatically provided by the ISP?
When I connect the laptop to my office network, the IP is static, and dns is hard-coded into network manager settings, but it still doesn’t use it.

Stop lamenting and show facts.


cat /etc/resolv.com

And please next time when you report a problem, do not only tell your conclusions (“I can not browse web pages” or, even worse “Cannot use HTTP”), but tell why you come to that conclusion. Does not FF and Chromium show error messages? Then tell/show what you asked from them, what they showed you. Vague reports like “it does not work” have no use in informing us what you do, see and experience.

Oops, looks like a typo… probably should be:


cat /etc/resolv.conf

:wink:

You are correct, I appologize for the confusion. :shame: