Cannot update packages with zypper


I ran zypper lr -d && sudo zypper up and it produces the following result:

I also tried running sudo zypper ref && sudo zypper -vvv up --allow-vendor-change

Can anyone help figure out why zypper won’t update?

Update Tumbleweed with zypper dup not zypper up

zypper up is for Leap.

The short reason is that you aren’t so much as updating packages as upgrading the whole distro at once.

Ah OK thanks(I installed Leap last week). Now I installed Tumbleweed on a different laptop.

So I never run zypper up on Tumbleweed? I always run zypper dup.

Will it always display the warning in the screenshot?

Yes and yes. Always dup, and it will always tell you you’re about to do a distro upgrade.

That message is important on Leap because there is a difference between upgrade (up) which installs patches to installed packages and distro-upgrade (dup) that would move from major/minor to the next major/minor (ie 15.5 to 15.6) which is a very different process in Leap.

Tumbleweed is released basically daily as snapshots. Each snapshot is akin to a major release in a traditional distro, so you have to use distro-upgrade to do the update properly. That is also why up doesn’t do anything, a snapshot isn’t updated after it has been created so there are no packages to upgrade in that release.

1 Like