Cannot type passphrase on boot if xen kernel is selected

Heyho!

64bit Opensuse, luks/dm-crypt, lvm

I have installed xen kernel, and if try to boot it then when it ask for password i can not write anything.
I can still boot the original kernel.
The another difference is that in xen bootin i am in character mode, but with the original kernel boot, I am in graphical mode when I have to type the passphrase.

I tried to replace grub2 with grub-legacy, but no success, still the same problem.

Do you have any idea?

So are you actually trying to use zen? If you want Virtualization, have you considered using VirtualBox instead?

Thank You,

Yes I would like to use xen. Virtualbox is not enough for me because i would like to hardvarevirtualize windows to play games.

I am going to move this to the VM forum. In the mean time, have a look at this: https://forums.opensuse.org/english/get-technical-help-here/virtualization/469824-welcome-new-opensuse-virtualization-forum.html

Please hold off on any further comments until this get to the right place.

Thank You,

This message thread is now open for business. Thank your for your patience in this matter.

Thank You,

Ok, thankyou!

On 2013-01-05 23:16, tibology wrote:

> 64bit Opensuse, luks/dm-crypt, lvm
>
> I have installed xen kernel, and if try to boot it then when it ask for
> password i can not write anything.

For clarification, you are talking of the encryption password, not the
login password.

> I can still boot the original kernel.
> The another difference is that in xen bootin i am in character mode,
> but with the original kernel boot, I am in graphical mode when I have to
> type the passphrase.

I think this maybe related to the graphical thing that 12.2 uses while
booting (I don’t use 12.2, so I don’t remember the name). Try disabling
it completely.


Cheers / Saludos,

Carlos E. R.
(from 11.4, with Evergreen, x86_64 “Celadon” (Minas Tirith))

Its OK and very happy to help. The link I provided does include a couple of Xen entries and you may want to follow them through to see if any helpful info might be there. Further, most Xen setups are designed to put all power to the VM session and not to its own desktop, though I do not use Xen myself. If you want a standard desktop and a VM, VirtualBox would be a better choice. Also VMWare might be an even better choice, but not free except for perhaps the player stuff.

Thank You,

Yes maybe You are right. Fisrt I wanted to make a minimal OS with Xen and boot Opensuse & Windows from it. But than and thought first I will give a try for Suse with Xen. Example because the very good/easy lulk+lvm install with it.

Think I will stick with xen because I am interested in it. Want to learn it how to use it. And I know this virtualization software is a best for gameing. Am I wrong?

Yes, yes. I am talking about the encryption passphrase not the login passwd.

Ommm… I think it is related to the character mod boot process after the grub.
(This is why I posted this problem on the boot forum.) Anyway I think the opposite.
I think if I could turn ON this graphical thing, than I could type my passphrase.
Because with the normal kernel I get the graphical interface, and it is working,
but with xen kernel booting I get the character mode interface.

(Think the Opensuse xen tester(s) just wasn’t test it with luks encryption.)

But I dont know where to search for turning the graphical thingy on.

On 2013-01-06 10:06, tibology wrote:

> But I dont know where to search for turning the graphical thingy on.

It is a setting in the kernel line, in grub.

Two possibilities: the setting is there, but it does not work. Then try
remove it. Or the opposite, it is not there.


Cheers / Saludos,

Carlos E. R.
(from 11.4, with Evergreen, x86_64 “Celadon” (Minas Tirith))

It was there. Kernel settings was the same with the orig kernel.

Im sorry, but I dropped Opensuse not just for Xen dom0, but for everyday use too. I have to admit its buggy. I was experienced at least 4-5 bug in the first 24h.
Like menu cannot open, packege manager closing without any error message, automated install for kvm in the virtualmanager not working, etc…
I am very disappointed. I used Suse maybe 10 years ago, and now decided to try it again, but this instability is not acceptabe for me.
At debian the betas are more stable like here the stable ones.

Please correct me if I wrong! And tell me how can you use it!

Thanks!


In the meantime i was dissappointed in the CentOS distro… AAGGHhh… :slight_smile:
Camon linux distros, whats wrong with you.
How can it be that there is no xen in an ENTerprise linux??
And no gnash? Adobe flash player is NOT secure…
And just random the keyboard is not working???

Don’t understand… Really… Pls somebody explain me how can it happen…

On 2013-01-06 19:06, tibology wrote:

> It was there. Kernel settings was the same with the orig kernel.
>
> I`m sorry, but I dropped Opensuse not just for Xen dom0, but for

everyday use too. I have to admit it`s buggy. I was experienced at least
> 4-5 bug in the first 24h.

Well, openSUSE is a community effort, you are supposed to test those
things and report to the devs during development phase so that they get
corrected. Without your personal effort and help, they will never be.

> Please correct me if I wrong! And tell me how can you use it!

Well, I use it daily and I don’t hit that many bugs.


Cheers / Saludos,

Carlos E. R.
(from 11.4, with Evergreen, x86_64 “Celadon” (Minas Tirith))

Wrong.

I have come to openSUSE from three years of Debian because I had severe data loss and installation failures in the released installer.

Maybe just I was just no lucky. Or maybe this is just not the right distro for me.
Good luck!

On 2013-01-07 18:26, tibology wrote:

> Maybe just I was just no lucky. Or maybe this is just not the right
> distro for me.
> Good luck!

Well, you have to use whatever works for you :slight_smile:


Cheers / Saludos,

Carlos E. R.
(from 11.4, with Evergreen, x86_64 “Celadon” (Minas Tirith))

I’m having the same problems with not being able to input my luks password at boot if I select the xen option from the grub2 menu.
What I have found is that there is a difference between the menu option for standard kernel and the xen option.
Standard kernel has load_video and set gfxpayload=keep as well as insmod gzio while the xen option does not have these.
I was able to find the differences in the **/**boot/grub2/grub.cf file but as grub has changed over the years I’m not sure if this is the best place to make changes since it draws from /etc/grub.d/ and /etc/defaults/grub.
Would the three entries mentioned above cause the inability of the user to enter the luks password during boot as has been mentioned.

Also fwiw I am running 12.3 while still in testing and am not having any issues (other then this luks) that can’t be fixed simply and quickly. Most were resolved by updating the system through the patches given.