Cannot start wifi

Opensuse 15.3.18-150300.59.68 not starting my Intel 4965AG. Thinkpad laptop has a wifi switch that I usually leave off because I mostly use it on eth0. It’s been nearly a year since I travelled w/ this laptop and it’s been through many kernel & system updates since then. Perhaps with the wifi radio switched off the needed config did not get made? Whatever, I have tried a lot of stuff and get nowhere. Rfkill list shows software off, hw on. I can force it on but cannot make it connect to AP.

hardware probe sees the wifi radio. I booted into an old XP partition and the wifi works ok.

I had system set to wicked. I tried to change it to network manager but when I do the radio turns off again.

lsmod shows iwl4965 so I know that is not the proble.

I’m looking for info on what commands to run to fix this issue. Sorry to be so vague, this problem is so frustrating.

Adding: KDE desktop. NetworkManager-connection-* is installed.

Enable soft-blocked wifi device with

sudo rfkill unblock wifi

If using NetworkManager, you can check wifi device status with

nmcli radio wifi

If necessary enable it with

nmcli radio wifi on

then proceed with connecting.

Deano: I spent hours on this.

# ping   PING ( 56(84) bytes of data.   64 bytes from icmp_seq=1 ttl=57 time=204 ms    
 I cannot thank you enough!!!

Glad to have been of help! :slight_smile: