Cannot start KDE - stuck at tty

Hello community,

I had some problems with the default ATI fglrx driver, so I removed it and installed the free radeon driver following this page:

After executing the modprobe radeon and reboot commands, my KDE fails to load. No login screen is displayed, so I had to use the tty login.
Entering startx at tty:
Shows the default 13.1 login screen and then snaps back to tty with the following message:

xinit:connection to X server lost

It also shows some library ksmserver could not be loaded (usr/lib64/ & the****

Entering startkde shows:

$DISPLAY is not set or cannot connect to the X server

Entering init 5 freezes the screen on the default login background.
Executing** export DISPLAY=localhost:0.0** did nothing.

I also added the **exec startkde **​line to the /etx/X11/xorg.conf file.
I’m using an ATI 5470 mobility radeon and opensuse 13.1 64bit KDE.
Please help me out guys.


… for now, at the Grub menu, choose Advanced options, then choose Recovery mode.

That should at least get you back into KDE desktop until you get a solution to your problem.

Thanks for the suggestion, but unfortunately that isn’t working either.

mmm Recovery should run with low level drives and normally work ( but not well ie lower res slower but should work) with any card. Are you sure you selected the right option in advanced?

Try press 3 at the first boot prompt find and go to the line starting **linux **press end key add a space then nomodeset press f10 to continue boot

Yes, I am sure. I tried that multiple times.
I did as you asked, openSUSE boot with the GUI login screen background and then goes into the tty screen.
When I logged in as root as entered startx, these are some of the messages I got:

Fatal Server Error:
(EE) No screens found
VGA Arbitration: Cannot restore default device

xinit: unable to connect to X server
xinit failed: /usr/bin/Xorg is not setuid, maybe that's the reason?
If so, either use display manager or adjust /etc/permissions.local

Would it be my best option to reinstall the OS?
Is there any other way I can fix this issue?

A slightly better option that re-installs without wiping is to run a repair from an openSUSE DVD (boot the DVD, select the repair option).

Been awhile since I’ve encountered what you describe. As Fraser suggests, normally “recovery mode” during bootup should work since Grub loads a generic display driver and the “better” driver (ATI in your case) isn’t loaded. Are you sure you’re booting to recovery mode? When you see the Grub Menu with 13.1 graphic on the left, you should click on Advanced, then the second (not top) top choice.

If you can boot into Recovery Mode, I’ve fixed similar Desktop issues by simply doing a force re-install of all Desktop (in your case KDE) components. That usually returns the system to original/older components with default configurations. If successful, then you can then try updating to lat/eest packages afterwards.

Another thing to note is that nowadays, typically there is <no> xorg file, the defaults are typically better than what you might want to specify manually.

One last thing, take a quick peek in


Although rare, I ran into an issue where some install script set one of the settings to a specific display driver so it invalidated any attempts to run a different display driver.


Thanks TSU for your detailed comment. I saw some KDE files missing, which might have been caused by me removing the proprietary ATI driver from the run level 5. So, I decided to
reinstall the kde4_basis package again, which was done successfully. When that didn’t solve the issue, I decided to reinstall the OS again.
All of this, for just wanting to switch back to the open source radeon drivers, which works so much better.

I’m assuming that your reinstall resolved the issue. In any regard, you needn’t have jumped through so many hoops such as you did. Unfortunately,

  • some of the info you followed is likely incomplete (i.e. the sdb article)
  • some of the steps you took don’t apply (by default) with openSUSE (i.e. startx as user)
  • some of the steps you took would fail (i.e. adding exec startkde to xorg.conf file)

Yes, reinstalling suse did solve the issue.
There isn’t any proper article/tutorial/guide for changing to the open radeon drivers (atleast I didn’t find any)[FONT=microsoft sans serif][/FONT], so I thought my best bet would be the SDB article.

I would advice non-gamers and people with ati radeon 5xxx cards to stay away from the buggy propreitary fglrx drivers, as the free radeon drivers works much better.