cannot start graphical login after installing amd driver

I have openSuse 13.2 Gnome installed , I used this to install amd driver.
it was installed successfully, but after rebooting I cannot use graphical interface to log, what should I do to fix it ?

What Graphics-Card is buildin:

/sbin/lspci -nnk | grep -iA2 vga

after removing all fglrx using ‘zypper remove fglrx*’ , it worked again.

I tried your command , here is the output

01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Pitcairn PRO [Radeon HD 7850] [1002:6819]
    Subsystem: PC Partner Limited / Sapphire Technology Radeon HD 7850 2GB GDDR5 DVI-I/DVI-D/HDMI/DP [174b:e221]
    Kernel driver in use: radeon

Your card should be supported by the fglrx driver.

Please install the driver again, and if it still doesn’t work please boot to “recovery mode” (“Advanced Options” in the boot menu) and post the file /var/log/Xorg.0.log.old (upload to http://susepaste.org or similar and post a link).

PS: See also this thread: https://forums.opensuse.org/showthread.php/504125-FGLRX-R9270X-Opensuse-13-2

Apparently gdm is crashing if the fglrx driver is installed.
Try switching to another display manager and everything should work.

xdm is installed by default but quite basic, you might also try to install lightdm e.g. which should be an acceptable alternative (at least until the problem is solved).

To switch, edit the file /etc/sysconfig/displaymanager in a text editor, and set DISPLAYMANAGER=“xdm” (or =“lightdm” e.g.).
You can also use YaST->System->"/etc/sysconfig Editor" for that, change Desktop->Display manager->DISPLAYMANAGER accordingly.