Cannot start GNOME with 4GB RAM

Hi,

I am a beginner of Linux. Last week, I upgrade my PC to 4GB RAM then install openSUSE 11 but it failed. The screen turn into blank just after the installation started. After I removed 2GB RAM, the installation completed finally. But, as I reinstalled the additional 2GB RAM(4GB RAM total), the GNOME cannot start, and I get a blank screen. The system seem to be running as the harddisk keep loading but I am not sure as the screen is blank.

I guess the problem is caused by memory share of the on broad display card.

Would you please help?

Thanks.

just a wild guess:

install all the ram, pop in the install CD and let it boot…

instead of selecting install, select Memory Test (or memtest, i forget
how it is worded) and let it run at least 12 hours…

if you have any errors, you know where the problem lies…


DenverD (Linux Counter 282315)
A Texan in Denmark

Hi,

Thanks for your reply. I tested the RAM 2 days before as your suggestion. Although not as 12 hrs test but as 3 hrs. There is no errors for the RAM.

Thanks!

ok…but, sorry i just don’t have the technical capability to trouble
shoot your problem past “it MUST be a memory problem”…hopefully a
REAL guru will come along and help.

in the mean time, you could take out 2 GB and enjoy the Gnome you
installed…

(i mean, i know that OS that begins with a V needs a PILE of ram, but my
10.3 runs GREAT in 1 GB!!)

in fact, if you installed 4 gig to help hobbled V, compare V in 4 to
Gnome in 2 and tell me who boots fastest and is more “snappy” !!


DenverD (Linux Counter 282315)
A Texan in Denmark

Is this a laptop?

Is it 2 @ 2 Gb DIMMs or something else? Will the system boot using each DIMM all by itself or does it fail with one specific DIMM? If the latter, you’ve isolated your bad DIMM.

Is your CPU 64-bit or 32-bit? If 64-bit, which OpenSUSE are you installing, 64 or 32-bit? This shouldn’t matter, but may be nice to know.

Does the system even boot to BIOS with the whole 4 Gb installed? Does the motherboard support 4 Gb?

Actually, the 4GB RAM is installed for running Virtual Server in Windows. Linux run much better than Windows and don’t need such large amount of RAM.

Now, I am doing as you said, remove the new purchased 2GB RAM…

Anyway, thanks for your help. :slight_smile:

Have you tried with only the new RAM? This will tell if it is bad RAM.

Is all the RAM the same speed, latency, etc? The new RAM may not be bad but may just not play well together with the old RAM.

Hi,

I am now using a PC but not a notebook and the specification as follow :

Mother Broad : PC CHip P55G LGA775 GF7050/610i M-ATX
CPU : Intel PDC E2180 2.0G 1M/FSB800 LGA 775 CPU
RAM : 2GB DDR2-800 D2/CL5 A-DATA (SINGLE)
2GB DDR2-800 D2/CL5 A-DATA (SINGLE) [New RAM]

Onbroad display for the mother broad (NVIDIA GeForce 7050 / NVIDIA nForce 610i)

The mother broad can support 4GB RAM with 2 slots.

For the RAM, both are in the same speed and same mode but just different packing. I use the new RAM only to start the system without problem. With both RAM (4GB) installed, Windows XP work without problem.

For the CPU, it is 64bit, right?

The OpenSUSE installed is 64bit.

Thanks again.:slight_smile:

> Have you tried with only the new RAM? This will tell if it is bad RAM.

another thing you can do is swap positions of the two ram
sticks…sometimes that makes a difference (do NOT know why)…


DenverD (Linux Counter 282315)
A Texan in Denmark

maybe have a look here
Physical Address Extension - Wikipedia, the free encyclopedia

Motherboard Maximum Memory - openSUSE Forums

64bit Or 32bit, Again… - openSUSE Forums

Are both DIMMs either single sided or double sided (are there RAM chips on only one or both sides of the DIMMs)?

I’m an AMD user - I like to install DIMMs in identical pairs for 128 bit memory access - I don’t know whether the Intel motherboard memory controller may have this feature or, if so, whether disabling this feature might help with the two different DIMMs. Can someone else help with this?

Have you tried minimizing and maximizing shared video memory in BIOS and verifying that Linux fails in both events? Can you scavenge a video card to test what happens turning off on-board video?

Good luck!

Hi All,

I used the new 2GB RAM only to start the GNOME without problem. Then I add it back to 4GB RAM with the slot swapped, it failed again. One more finding is when starting the GNOME, although the screen blank, it still get signal to the monitor as I the LED on the monitor is green but not orange.

Both DIMMs are in dobuble sides.

I also tried to change the video sharing to 64MB, 128MB and 256MB but still doesn’t help.

I also started the GNOME with 2GB RAM then update the display driver but still doesn’t help also. Hence, I am going install a PCI display card for testing.

Any other suggestion? Thanks again.

Make sure the two sticks of ram are identical.

I have the same problem with Debian Lenny. Gnome dont start with 4 gb memory. And I think thats problem with sharing video memory. I have made changes in my /etc/X11/xorg.conf but it didn’t work. Kernel 2.6.26-2-amd64.

Have your 4GB in the laptop and try booting with the option

mem=4096M

Please post back the result.