Cannot start apps from desktop icons

Hi! Nice to have you back! :smiley:

I updated a TW KDE plain vanilla (more or less) on Saturday, and after reboot plasmashell segfaults when ever I tried to move a desktop icon for launching any kind of app (VLC, firefox, whatever). I could not delete them, either, only way to det a functional desktop was to move these icons to a newly created folder.

I tried the Wayland (half and full), but same result. Removing utilities repo (lates Bleachbit) with vendor change for all packages did not help either. xf86…nouveau was not installed and installing it did not change anything. Any ideas? Other TWs are doing just fine…

I have now another plain vanilla TW (5.6.11-1-default KDE) with plasmashell segfaulting when I try to move a .wav from Desktop to a Dolphin folder via drag&drop. What’s wrong here? :frowning:

Try a different user. Might be a corrupt config or cache

Hi and many thanks for reply!

I don’t really like this option, reminds me of standard recommendation for Win (“do a fresh install…”). Is there no way to clear the cache or config for my current user and keep the lovely icons on my desktop (yeah, I know, that’S totally 90’s, but…)

The recommendation is strategics for trouble shooting. You want to find out whether it is a system wide issue or related to the config files of your user account. Finding that out helps a lot.

Nobody asked you to remove or never use again that existing user. What was asked was to create temporary a user just for analysing the problem.
As long as nobody knows what the cause is of this particular problem (remember that nobody else complained about it, you seem to be unique), the only advice one could give you for cleaning things is removing all .* files/directories, which would result in the same testing environment as a fresh user. And which would result in loosing your precious look and feel, which you then can restore from a backup.

Instead of removing all and restoring after a test, by far more easy and save is the creation of a test user, which you then can remove after the test.

And comparing this with the reinstalling of a Windows system is ridicoulous. I do not know much about Windows, but new installing will remove all that one has. Creating a new user in a Linux system that may already have tens of users does not remove or change anything for existing users. It is your own suggestion that comes near to removing the configurations a user has.

OK, but if the new user works, but my existing not, what’s next? Move to the new user?

Customizing a new user (no matter if Linux or Win) takes me 1-2 days, before 95% of settings are back to normal.

Did you check this already? As Karlmistelberger told you, it will decide the next step. When you do not cooperate which such a simple test, why should he?

I saw this posted on the kde neon website:

*Ever since the KDE Frameworks 5.70 update, I’ve had an issue where dragging most desktop icons to a new position crashes Plasma. It only happens with those that are the actual icon and not a thumbnail of the content as the icon. I saw that there is a bug filed on it, though I do not have the number handy.

If anyone else runs into this, I’ve found a workaround. Simply use the command line or package manager of your choice to revert plasma-frameworks to version 5.69. After that, a restart of plasma (or you could just reboot) should fix it. Be sure to lock the package so it’s not updated once again to the faulty version.

Sounds like the same issue.

The post is at:

Just perfect! Many thanks!

Since maybe a cache problem first clear out ~./.cache directory. (Best done when GUI not running)

The latest zypper dup brought things apparently back to normal! Many thanks to all for helpful advice! :smiley: