Cannot shutdown or log out via GUI on 11.4

I was trying to install support for some codecs or something a couple weeks ago. I use KDE and I think I accidentally tried to install some packages meant for GNOME. Whatever the case though, now I cannot shutdown or log out a user through the GUI. I have to go do it in terminal. Also, the startup and sleep sound disappeared. I can still put the PC to sleep or lock the screen via GUI, just no shutdown or log out.

If anyone knows how I can un-mess-up this situation, I appreciate it. :stuck_out_tongue:

Please post output of


zypper lr -d

Output as follows:


#  | Alias                 | Name                       | Enabled | Refresh | Priority | Type   | URI                                                               | Service
---+-----------------------+----------------------------+---------+---------+----------+--------+-------------------------------------------------------------------+--------
 1 | Packman Repository    | Packman Repository         | Yes     | Yes     |   99     | rpm-md | http://ftp.uni-erlangen.de/pub/mirrors/packman/suse/openSUSE_11.4 |        
 2 | libdvdcss repository  | libdvdcss repository       | Yes     | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/11.4/                              |        
 3 | openSUSE-11.4-Non-Oss | openSUSE-11.4-Non-Oss      | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/non-oss       |        
 4 | openSUSE-11.4-Oss     | openSUSE-11.4-Oss          | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/oss           |        
 5 | openSUSE-11.4-Update  | openSUSE-11.4-Update       | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.4/                         |        
 6 | repo-debug            | openSUSE-11.4-Debug        | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/11.4/repo/oss/    |        
 7 | repo-debug-update     | openSUSE-11.4-Update-Debug | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/11.4/                   |        
 8 | repo-non-oss          | openSUSE-11.4-Non-Oss      | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/non-oss/      |        
 9 | repo-oss              | openSUSE-11.4-Oss          | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/oss/          |        
10 | repo-source           | openSUSE-11.4-Source       | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/11.4/repo/oss/   |        
11 | repo-update           | openSUSE-11.4-Update       | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.4/  

If this was me I would run YaST / Softwarer / Software repositories and remove repositories numbered 2, 3, 4 & 5 as 3-5 are duplicates and 2 is only required to get libdvdcss and not after that. I would change the priority of # 1 - Packman from 99 to 10. I would change the update repo number # 11 to a priority of 49. After that I would go into Software Management, Options and check: Allow vendor change. Next, select Package, All Packages and select: Update if newer version available. Press Accept on the bottom right. If you get any conflicts, I suggest this:

To avoid package problems, the most important thing to do is to: NEVER
ignore a dependency, even if YaST/zypper/updater gives you such an option!
In general, never switch to an >inferior< architecture and the solution is
most often to just switch Vendor to the >Packman< repository. So changing
the vendor is OK, but >ignoring< dependencies is never a very good idea!

As for Gnome, I load it and use applications for Gnome in KDE without a problem. If you switch back and forth between desktops, that might cause some issues, but not just because you have loaded Gnome apps.

Thank You,

Well I did all of that and did not get any conflicts but it did not resolve the problem. Thanks for your time in any regard.

So not shutting down could be a desktop problem, a kernel problem or a video driver problem. Can you tell us more about your hardware setup? Running uname -r in terminal will tell us exactly what kernel version you are using. The My Computer icon on the KDE Desktop also tells you video driver and other such things. Make and model on PC as well as install memory and anything else you can throw in. With openSUSE 11.4, its possible to upgrade the kernel version to 3.3.5 if you wanted to do so, but not sure what has went wrong. Have you thought of switching to openSUSE 12.1 by chance?

Thank You,

I was about to say before reading your last statement that I’m more the type to just re-install rather than spend my whole life debugging. I rather like 11.4 and am always suspicious of new releases if I’m stable with what I’ve got. I was reluctant to get rid of 11.2 before because 11.3 was sort of like a crossword puzzle where your kid ate ten of the pieces to it and you’re sitting there trying to put it together.

Anyhow… I’ve only used Linux for a few years so I would say I’m pretty novice. I mean, I can make my way around it fine and I absolutely love it and will never go back, and I credit that mostly to the superb functionality and ease-of-use that SUSE brings, but when it gets deeply technical with Linux, I definitely really have no idea what I’m doing. I am 100% convinced that SUSE versions of Linux are the most functional and easiest to navigate of any distro so I will always support openSUSE 'til the day I die.

I see this problem perhaps though as I see life-- I messed up something which is going to be probably beyond my technical means so for me, it’s probably just easier to save the small amount of important data stored and just reload the OS. I’m impatient by nature too and highly ADHD. I think it says something that somebody like me was fed up with the MS world enough to change to Linux and have the guts to stick with it long enough so that I have JUST enough knowledge to get along and enjoy it.

Well sorry if this seems like I’m giving up a bit but like I said, I’m novice, and the Saturday night beverages are only increasing my already-inherent simplistic way of thinking.

I use KDE and I think I accidentally tried to install some packages meant for GNOME. Whatever the case though, now I cannot shutdown or log out a user through the GUI. I have to go do it in terminal.

I wonder if you have accidentally changed to using the gdm display manager - that can be the cause of issues like this with KDE. You can (re)set this to kdm via

YaST >> System >> /etc/sysconfig/ Editor, navigate to Desktop >> Display manager >> DISPLAYMANAGER and set to kdm

Alternatively, check /etc/sysconfig/displaymanager for the ‘DISPLAYMANAGER=…’ entry, and edit accordingly.

Edit: This will only take effect next time you restart the X-server (or reboot).

Let me say that it is not defeat to reload Linux and no matter what you think you know, an update can go wrong. In the beginning, I would reload for all sorts of problems I now understand and would just fix with no trouble at all. But, ever so often, something does go astray on an update and its still easier to just reload. And while I don’t wish to make comparisons to Windows, I had the same thing go on with it as well. So, if you do make an effort to save whats important, like mail, documents, music, media, downloaded files, even labels, then doing a reload is a good thing to try. I use two methods to make sure I don’t get burned. 1) I keep a separate /home partition and during a clean install, I only mount the /home partition and I do not reformat it. 2) All important stuff, I place on a second hard drive on a different partition. Living by these two rules has saved me more than once. All of the items I mentioned however, before rules 1 and 2, have been lost by me during a reinstall. While the system still works now, make sure you take stock of the data you have and just how one might save it. Also, there is no rush to reinstall and so listen to any other help you might get here and good luck.

Thank You,