Cannot setup Xonar DG, no sound cards in alsa

Hi,

I’ve been restoring my old OpenSUSE installation to new life, but I’m having few problems with configuring
sound.

Details: I have On-board audio (SBx00 Azalia (Intel HDA)), ATI HDMI Audio, and Asus Xonar DG which I’m trying to make work, but having no success.

As for now I have blacklisted snd-hda-intel driver in /etc/modprobe.d/50.blacklist.conf .
I thought it might be easier to configure when those two cards are not getting in the way.

I’ve been following This Audio Troubleshooting.

YaST shows 2 not configured cards, and if I try to configure them I get “Kernel module snd-virtuoso could not be loaded” error.

Also I’ve deleted (moved) 50.sound.conf file, because I’ve read somewhere that YaST cannot configure that card and alsa should configure itself after removing this file and cold reboot.

I’ve upgraded alsa to 1.0.24 from multimedia and drivers from multimedia-kmp.

It did not help.

Also I’ve compiled alsa-driver, tools, utils and libs from tarballs but nothing has changed.
My Xonar card is recognized by lspci -k, but no kernel module is assigned to it:

02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)
        Subsystem: ASUSTeK Computer Inc. M4A785TD Motherboard
        Kernel driver in use: r8169
03:07.0 Multimedia audio controller: C-Media Electronics Inc CMI8788 [Oxygen HD Audio]
        Subsystem: ASUSTeK Computer Inc. CMI8786 (Xonar DG)
03:08.0 FireWire (IEEE 1394): VIA Technologies, Inc. VT6306/7/8 [Fire II(M)] IEEE 1394 OHCI Controller (rev c0)
        Subsystem: ASUSTeK Computer Inc. M4A series motherboard
        Kernel driver in use: firewire_ohci

I’ve ran /usr/sbin/alsa-info.sh script and uploaded info here for you to see.

Also:



ugnius@linux-efue:~> uname -a
Linux linux-efue 2.6.37.6-0.7-desktop #1 SMP PREEMPT 2011-07-21 02:17:24 +0200 x86_64 x86_64 x86_64 GNU/Linux

ugnius@linux-efue:~> rpm -qa '*alsa*'
alsa-plugins-32bit-1.0.24-64.1.x86_64
alsa-plugins-1.0.24-64.1.x86_64
alsa-plugins-pulse-32bit-1.0.24-64.1.x86_64
alsa-1.0.24.1-119.1.x86_64
alsa-plugins-pulse-1.0.24-6.1.x86_64
alsa-oss-1.0.17-65.1.x86_64
alsa-utils-1.0.24.2-48.1.x86_64
alsa-oss-32bit-1.0.17-65.1.x86_64
alsa-driver-kmp-desktop-1.0.24.20111010_k2.6.37.1_1.2-2.1.x86_64

ugnius@linux-efue:~> rpm -qa '*pulse*'
pulseaudio-module-x11-0.9.22-6.11.1.x86_64
pulseaudio-module-gconf-0.9.22-77.1.x86_64
pulseaudio-module-bluetooth-0.9.22-6.11.1.x86_64
pulseaudio-0.9.22-6.11.1.x86_64
alsa-plugins-pulse-32bit-1.0.24-64.1.x86_64
libpulse-browse0-0.9.22-77.1.x86_64
pulseaudio-module-zeroconf-0.9.22-6.11.1.x86_64
libpulse-mainloop-glib0-0.9.22-77.1.x86_64
pulseaudio-esound-compat-0.9.22-77.1.x86_64
vlc-aout-pulse-1.1.12-1.1.x86_64
alsa-plugins-pulse-1.0.24-6.1.x86_64
pulseaudio-module-jack-0.9.22-6.11.1.x86_64
libpulse0-0.9.22-77.1.x86_64
libxine1-pulse-1.1.19-4.4.x86_64
pulseaudio-utils-0.9.22-6.11.1.x86_64
pulseaudio-module-lirc-0.9.22-6.11.1.x86_64
libpulse0-32bit-1.0-76.1.x86_64

ugnius@linux-efue:~> rpm -q libasound2
libasound2-1.0.24.1-119.1.x86_64

cat /etc/modprobe.d/sound
cat: /etc/modprobe.d/sound: No such file or directory

ugnius@linux-efue:~> cat /etc/modprobe.d/50-sound.conf
cat: /etc/modprobe.d/50-sound.conf: No such file or directory

cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.24.
Compiled on Oct 10 2011 for kernel 2.6.37.6-0.7-desktop (SMP).

ugnius@linux-efue:~> cat /proc/asound/cards
--- no soundcards ---


If some one could guide me on the right way, because I’m running out of ideas here.
Thank you very much for trying to help me.

Update, I’ve compiled ALSA snd-oxygen module and did modprobe snd-oxygen and my card came up, problem is I cannot figure out why there is no sound on any channel. I did try to fiddle in alsamixer with various options, but still no sound. At least it seems like it’s loading something, that’s a step forward.
But if I can remember well, my card used to work with snd-virtuoso driver. Something must have changed from then.

Hi again, it seems like I’m talking to myself here, but here you go.

I’ve dropped all that alsa compile thing and installed kernel 3.0.6-1 from Kernel:stable repos. Fingers crossed I will not regret this later. But Hey, I’ve got my Xonar Working.

Thank you all for reading my rant, I suppose this thread can be closed.

Hi again, it seems like I’m talking to myself here, but here you go.

I’ve dropped all that alsa compile thing and installed kernel 3.0.6-1 from Kernel:stable repos. Fingers crossed I will not regret this later. But Hey, I’ve got my Xonar Working.

Thank you all for reading my rant, I suppose this thread can be closed.

ugnius40, you just got to give us long enough to respond. A lot of us work during the week days and don’t see this till late evening. I have seen some interest on using the Xonar sound card with openSUSE, but it was not clear what you did that made it work? Did going to kernel 3.0 do it or did loading a newer version of Alsa do it? I am sure many others want to know this. Did you mention what desktop that you use? If you go to YaST / Hardware / Sound is the sound card listed there now but was not before? I have updated ALSA before, but found I had to update YaST as well to get some sound cards to show up there. So we need more details on the subject.

Thank You,

As soon as I saw this the ‘red alert’ alarms went off. I’m pretty sure you do not understand the versioning on the multimedia repository. Note your kernel is the 2.6.37.6 kernel. Hence if you are going to install a kmp packaged driver (any driver, whether it be an alsa driver, or a wireless, or a webcam) then you need to ensure that the kmp has the correct version in its version number.

Your PC has the kmp for the 2.6.37.1 kernel installed on a PC with the 2.6.37.6 kernel. Its no surprise the sound does not work.

You need to either change your kernel back to 2.6.37.1 or you need to install the proper alsa-driver-kmp-desktop-1.0.24.20111011_k2.6.37.6_0.7-1.1.x86_64.rpm (11-Oct version).

Note I was away on business all day yesterday (with my job that pays my salary, as opposed to this ‘volunteer’ GNU/Linux support contribution), returned very late last night, and I am off on business again for the remainder of the week. It may the upcoming weekend before I can look at this thread again.

Thank you oldcpu. I see now, this might have been the problem, but I’m not willing to experiment more, nothing seems to be broken with new kernel:

ugnius@linux-efue:~> uname -r
3.0.6-1-desktop

will live for a while with that.

I’m sorry for bumping my thread impatiently, I understand that you people have jobs, and physically cannot answer all posts right away.

Thanks

I am having a similar problem with a Asus DGX xonar card using CMI8788 [Oxygen HD Audio] No sound. Any help would be appreciated.

Yast -> hardware -> sound -> edit (of cmi8788) says

The kernel module snd-oxygen for sound support could not be loaded

A quick look confirms no kernel module associated with card.

lspci -k

…]

00:1f.6 Signal processing controller: Intel Corporation Lynx Point Thermal Management Controller (rev 05)
Subsystem: Intel Corporation Device 35b5
02:00.0 PCI bridge: ASMedia Technology Inc. ASM1083/1085 PCIe to PCI Bridge (rev 04)
Kernel modules: shpchp
03:04.0 Multimedia audio controller: C-Media Electronics Inc CMI8788 [Oxygen HD Audio]
Subsystem: ASUSTeK Computer Inc. Device 8521
04:00.0 Serial Attached SCSI controller: LSI Logic / Symbios Logic SAS2308 PCI-Express Fusion-MPT SAS-2 (rev 05)
Subsystem: Intel Corporation Device 3517
Kernel driver in use: mpt2sas
Kernel modules: mpt2sas
…]

A quick modprobe of snd-oxygen

modprobe -v snd-oxygen

insmod /lib/modules/3.0.76-0.11-default/kernel/sound/core/seq/snd-seq-device.ko
insmod /lib/modules/3.0.76-0.11-default/kernel/sound/core/snd-rawmidi.ko
insmod /lib/modules/3.0.76-0.11-default/kernel/sound/drivers/mpu401/snd-mpu401-uart.ko
insmod /lib/modules/3.0.76-0.11-default/kernel/sound/core/snd-page-alloc.ko
insmod /lib/modules/3.0.76-0.11-default/kernel/sound/core/snd-timer.ko
insmod /lib/modules/3.0.76-0.11-default/kernel/sound/core/snd-pcm.ko
insmod /lib/modules/3.0.76-0.11-default/kernel/sound/pci/oxygen/snd-oxygen-lib.ko
insmod /lib/modules/3.0.76-0.11-default/kernel/sound/pci/oxygen/snd-oxygen.ko

Alsa is loaded and I looked at SDB:Audio troubleshooting.

I am at a loss. I uploaded my config here http://www.alsa-project.org/db/?f=2d93d2451d238dcf9f3c7750ec5767fdf8861648

J

This is very old thread please start a new one

I note your PC is running SLES-11 SPE3. This is an openSUSE forum, and I suspect the SUSE Linux Enterprise experts hang out on a different SLE forum.

Your problem is mostly summed up by this:



!!Soundcards recognised by ALSA
!!-----------------------------

--- no soundcards ---

and




!!Loaded sound module options
!!---------------------------

and


!!Aplay/Arecord output
!!--------------------

APLAY

aplay: device_list:217: no soundcards found...

ARECORD

arecord: device_list:217: no soundcards found...

SLES-11 SP3 does not currently recognize your hardware sufficiently to load the driver.

I take it after the ‘modprobe -v snd-oxygen’ your PC’s sound did not work ?

Typically it is the alsa driver in the kernel that will provide the code necessary to recognize your hardware. I was going to try suggesting installing alsa-firmware in case that might help provide the missing driver, but your post suggests ‘snd-oxygen.ko’ is already present ?

My not knowing SLES-11 limits the help I can provide. You may be best asking for help on a SLE forum, and possibly maybe even write a bug report on SLES-11.

Thanks oldcpu… I need to upgrade anyway… I’ll troubleshoot more with either the sp4 kernel or sles12