Cannot set monitor refresh rate to 75Hz (ati hd4850)

i have a Compaq V1100 monitor, which is capable of 75Hz refresh rate (i`m sure, it works under windows) but it works only on 60Hz under linux.
my video card is a hd4850 and i use the proprietary fglrx drivers.

i tried opensuse 11.0, 11.1 (installed drivers manually, not from repository), and now i have a 11.2 (this time the drivers are from repository the fglrx-desktop version)

i have tried editing xorg.conf, using modes generated by gtf (maybe i copid them to the wrong section, but i tried putting them to the monitor and the modes section), tried disabling RandR1.2, also tried setting the monitor to vesa with 75hz refresh rate, i still cant set the refresh rate to 75hz (amdcccle lists only 60hz)

someone please help, the monitor has an annoying flicker in white zones


I recommend you write a bug report on this. There is guidance here Submitting Bug Reports - openSUSE for how to submit bug reports. You can use your openSUSE forum username and password when accessing bugzilla.

In openSUSE-11.2 there is also the option for putting the monitor details in a different area (ie inside “/etc/X11/xorg.conf.d” ). Take a look at this thread: 11.3 M6 Gnome: how to change screen resolution? - openSUSE Forums … I’ve never tried this myself so I can not offer any advice.

Before messing about manually with xorg.conf and with /etc/X11/xorg.conf.d you may wish to see if ATI provide a proprietary wizard/tool with their driver for doing this.