Cannot select Oxygen style

Since a minor upgrade in the KDE 4.9.x series I am not able anymore to select the oxygen style in the kcm_style (kcmshell4 style) – it just does not show up in the list of the available styles anymore. I am on opensuse 12.2.

I upgraded now to KDE 4.10 and the problem persists. I double checked and reinstalled the packages that seem to be connected to the oxygen style and nothing changed. Yast does not report any non-satisfied dependencies, and I cannot find were the problem is. I have two other installations of opensuse 12.2 on different PC’s (one i686 and on x64) and both have the same packages installed, and there is no problem with the oxygen style.

As a workaround for now, I use the gtk+style and choose as a gtk+ style the oxygen style, this kind a works, but it has some minor flaws (some tickboxes are not working 100% correctly) and I am really curious what the problem is, and I want to repair it…

So my question is, how can I find out what the problem is, what could be the reason that the style does not appear in the list?
Any help/hint is appreciated!

Thanks,
Thomas

I’ve seen this on machines with an NVIDIA card. Remove ~/.config/Trolltech.conf whilst not logged in, then login and you should be fine.

Hmm, this was not the solution, but I remember now that I played around a little bit with X and the bumblebee stuff, perhaps my problem is linked to that. I now have Optimus turned completely turned off (and run purely on the intel integrated graphics) as it saves an additional Watt or two on my laptop – I will try to reinstall the X-Server stuff…

To achieve what you want you need bumblebee and bbswitch. “played around” mostly doesn’t make things easier :P.

Is Oxygen visible in qtconfig?

Sorry, “played around” is not to accurate, but frankly I don’t know exactly which versions of bumblebee I tried, so that’s perhaps the most accurate I can tell – I just tested it, it worked, and then I recognized that even if the nvidia card is not used, it costs me a few watts, and that I don’t need the graphics power at all. So I disabled the Optimus stuff on my laptop again (in the BIOS). I didn’t delete the bumblebee and nvidia packages (I have now bumblebee, primus, and the official nvidia packages installed), but I remember to have reinstalled some X-Packages to get the current setup working. But now the drm stuff works perfectly with my integrated graphics card, also in kwin.

So perhaps there is a problem with some old nvidia driver files? Perhaps I should remove them … as I am not using them anymore anyways…
I don’t think that the primus and bumblebee files should have an influence, as they don’t interfere with the X files…

Ah, and thanks for your hint with qtconfig – Oxygen does not appear there as well.

Did you perhaps try to get things working by logging in with root permissions? If so, remove /root/.config/Trolltech.conf.

  • How did you update to KDE 4.10?
    most of the times I’ve seen issues like this one, it was caused by a mix of packages from different repos.

Another option: create a new user, login as that new user, and see if the problem exists for that new user.

Hmm now it’s getting interesting for me:

First, there is already a second user on the system, for this user the oxygen style is selectable.

I removed also /root/.config/Trolltech.conf to no change, and for a second time ~/.config/Trolltech.conf.

I compared the recreated Trolltech.conf to the one of the User where the oxygen is working. The recreated
one is missing (amongst other small differences) the oxygen style line. I wonder which tool recreates the Trolltech.conf
and why it is not finding the oxygen style.

I will try to insert manually the missing line, by copying it from the other Trolltech.conf file.

:slight_smile: Isn’t linux a wonderful thing ? Mind, you’d better do that whilst not being logged in on the desktop (from the seconds user’s f.e., then use

su YOUR-OWN-USERNAME-HERE