Cannot see Google Chrome on repo site. How do I get it?

I have chromium but apparently need Google Chrome for some of our accountancy work.

I assumed no problem but cannot see Google Chrome in repo site. Am I looking is wrong place or do I have to download from web?

Further to this I tried the website download which downloaded an .rpm.
Tried to install using Yast and this is what I get:-

Error: INVALID:google-chrome-stable-94.0.4606.61-1.x86_64 (file-85675795): Signature verification failed [4-Signatures public key is not available]
     Header V4 DSA/SHA1 Signature, key ID 7fac5991: NOKEY
     Header SHA256 digest: OK
     Header SHA1 digest: OK
     Payload SHA256 digest: OK
     V4 DSA/SHA1 Signature, key ID 7fac5991: NOKEY
     MD5 digest: OK

Does this mean I have to get public keys from Google?

It’s not there. Search Google Chrome. There’s an .rpm download.

When you’re installing it, a box will likely arise that says the package is broken or something like that. I click on the tab that says ignore. The browser works great.

Have you tried the Brave browser instead? Much better privacy creds than the privacy-invader-max Chrome. Just go to the Brave browser site and follow the guidelines for openSUSE installation.

Hit the ignore key. It installs fine.

What i found by searching the internet using “google chrome opensuse download”:



Google is evil. Try to use Vivaldi or Brave.

installing the .rpm should also add the google chrome repo to your list and update automatically (if that is what you allowed) in the future

… or maybe using the oss part of chrome, named chromium which is availabe here:

Why do you need CHROME when you already have CHROMIUM? Aren’t they almost 99% the same browser?

For just browsing yes, but google has crippled some features that were previously available in chromium.