Cannot scroll: Microsoft Wireless Intellimouse Exp

I did find the entry, “Can’t get Microsoft Wireless Intellimouse Exp. 2.0” No luck. The thread reported success, but …

So, I have this thing:

from /proc/bus/input/devices:
I: Bus=0003 Vendor=045e Product=008a Version=0111
N: Name=“Microsoft Microsoft Wireless Optical Desktop� 1.00”
P: Phys=usb-0000:00:1d.0-2/input1
S: Sysfs=/devices/pci0000:00/0000:00:1d.0/usb1/1-2/1-2:1.1/input/input2
U: Uniq=
H: Handlers=kbd mouse0 event2
B: EV=17
B: KEY=3000000000000 0 1f0000 f8400244000 601878d800d448 1e000000000000 0
B: REL=7c3
B: MSC=10

and my xorg.conf file:
Section “InputDevice”
Driver “mouse”
Identifier “Mouse[1]”
Option “Buttons” “15”
Option “Device” “/dev/input/mice”
Option “Name” “Microsoft Wireless Keyboard and Mouse”
Option “Protocol” “explorerps/2”
Option “Vendor” “Sysp”
Option “ZAxisMapping” “4 5”
EndSection

The device names don’t seem to agree, but the mouse works.
Other than scrolling. Well, the scroll wheel does have an
effect. It moves stuff in the x axis (side to side)…

$ ls -l /dev/input/m*
crw-r----- 1 root root 13, 63 Aug 11 04:44 /dev/input/mice
crw-r----- 1 root root 13, 32 Aug 11 04:44 /dev/input/mouse0

I don’t know what I’m doing. I just did a straight up install and it doesn’t work. Now, what?

Two days of struggle. No solution. Not even any replies. I’ve found many, many others with the problem. The only places where people said, “fixed” is where they are editing XFree86config. It is now called “xorg.conf” and is slightly different. They also refer to external modules that are now built into the driver. Or they refer to “imwheel”, which also seems to be obsolete, probably because the problems it solved are now integrated in the driver. I am sure everything is fixed. Except, perhaps, the documentation on how to actually make it work.

Hi
Have a look here;
http://linuxreviews.org/howtos/xfree/mouse/
Just replace the reference to Xfree config with xorg.conf file.

man xmodmap may help as well.

Also have you run sax2 to select the check box for the wheel?


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
up 6:07, 1 user, load average: 0.02, 0.03, 0.05
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12

:slight_smile: I found the problem. For years and years, as everyone knows, the scroll wheel is found by applications as buttons 4 and 5, and the mouse manufacturers actually put the wheel on buttons 6 and 7. The installation automatically adapts to this. Unfortunately, the driver was fixed so the configuration was wrong. The correct pointer mapping is now:

pointer = 1 8 3 4 5 6 7 2 9 10 11 12 13 14 15 16 17

(I am unable to paste with button 2 without scrolling the wheel. I use a side button. I have no clue what buttons 10 thru 17 might be. I have 5 buttons on the scroll wheel, plus four more.)

So, SaX2 understands the buttons, but they have to not be remapped, as per historical usage. Thank you for your reply.

Regards, Bruce

I surely do wish that this still worked. Ever since upgrading
to openSUSE 11.0, I’ve had to revert to scrolling and pasting
simultaneously. I paste correctly about 80% of the time. :frowning:
So, my xorg.conf file and my ~/.Xmodmaprc file:

Section “InputDevice”
Driver “mouse”
Identifier “Mouse[1]”
Option “Buttons” “15”
Option “Device” “/dev/input/mice”

Option “Dev Name” “usb-0000:00:ld.0-2/input1”

Option “Name” “Microsoft Wireless Keyboard and Mouse”
Option “Protocol” “explorerps/2”
Option “Vendor” “Sysp”

Option “ButtonMapping” “1 8 3 4 5 6 7 2 9”

Option “ZAxisMapping” “4 5 6 7”
EndSection

$ cat .Xmodmaprc
keysym Alt_L = Meta_L Alt_L
keysym Alt_R = Meta_R Alt_R
pointer = 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32

I surely do wish I could past reliably again. Thanks in advance!

A little additional info:

xev does not show any activity when pressing button 8
(the second side button) and unlike:
Mouse setup - Wheel and USB (Linux Reviews)
I have to have 4 & 5 in the correct place.

Finally, I did successfully map button 2 to button 9 just now.
I still don’t know what is eating button 8 activity. It could
be broken, but its disappearance was coincidental with the
installation of a new SuSE version. So, I don’t know. Anyway,
the final fix is to alter .Xmodmaprc thus, despite button 8
being more convenient:
pointer = 1 9 3 4 5 6 7 8 2 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32