Cannot resume from suspend or hybernate since recent update

I am used to suspending to ram my laptop when I have finished working with it. However I recently updated my Tumbleweed (I usually do this every day, but this time I waited two weeks because I was abroad), and now the laptop still does suspend and hybernate. But after waking up, it just shows a frozen black screen with only the mouse pointer visible on it. The mouse pointer does not respond to inputs and I cannot switch to a virtual console with CTRL-ALT-F#

I have not changed anything on the laptop configuration between the updates.

Does anyone else have the same problem.

Have a look at

journalctl | grep suspend

Most of the time issues like you describe are related to errors in unloading/reloading drivers, in this case I’d suspect a videodriver.

I just discovered it’s kernel related: Booting with the previous kernel (4.11.8-2) poses no problem. After booting with kernel 4.12.11-1, the laptop does not resume from suspend anymore.

It’s definitely related to kernel 4.12. Out of curiosity I installed upstream kernel 4.13 and the problem disappears. Unfortunately, with kernel 4.13 I get an error with Virtual Machine Manager when I try to start a virtual machine: “Error starting domain: internal error: child reported: Kernel does not provide mount namespace: Permission denied”

I guess I will just have to wait for the next Tumbleweed kernel release and hope that they have fixed it in that one.

Somehow the Tumbleweed version of Kernel 4.13.1-1 has included the bug from kernel 4.12 that prevents my laptop from suspending and hibernating. I don’t quite understand why because the kernel from at least fixed that problem. The Tumbleweed kernel 4.13.1-1 did however take over the bug that breaks kvm virtual machines from running. It seems that since the last three versions the Tumbleweed kernels have been breaking functionality that worked previously.

I don’t have these issues, but this is on an HP laptop. I’d say this deserves a bugreport

It turns out that since the last update it was actually apparmor blocking kvm since the latest kernel update. Issuing a “systemctl stop apparmor.service” allows me to start virtual machines again. Strage, because I never enabled apparmor in the first place.

So, that just leaves the sleep/hibernate to be fixed (I already filed a bugreport).

p.s. I am using a HP laptop as well (HP pavilion, kaby lake chipset).

Hi Hans2004,

I have the same problem with my Tumbleweed/KDE/Bumblebee installation right now. Can you please publish a link to the bug report?

Here is the link to the bugreport:

Unfortunately I was unable to include a journalctl log report because after the system goes to sleep or hibernate nothing gets logged anymore when restarted because then the system is frozen.

I’m having the same issue with Leap 42.3, no Tumbleweed.

fuscop@office:~> /usr/sbin/hwinfo --gfxcard
08: PCI 02.0: 0300 VGA compatible controller (VGA)
[Created at pci.378]
Unique ID: _Znp.fOXSkkk0ZeF
SysFS ID: /devices/pci0000:00/0000:00:02.0
SysFS BusID: 0000:00:02.0
Hardware Class: graphics card
Device Name: “Onboard IGD”
Model: “Intel 4th Generation Core Processor Family Integrated Graphics Controller”
Vendor: pci 0x8086 “Intel Corporation”
Device: pci 0x041e “4th Generation Core Processor Family Integrated Graphics Controller”
SubVendor: pci 0x1043 “ASUSTeK Computer Inc.”
SubDevice: pci 0x8534
Revision: 0x06
Driver: “i915”
Driver Modules: “i915”
Memory Range: 0xf7800000-0xf7bfffff (rw,non-prefetchable)
Memory Range: 0xe0000000-0xefffffff (ro,non-prefetchable)
I/O Ports: 0xf000-0xf03f (rw)
IRQ: 31 (4164 events)
I/O Ports: 0x3c0-0x3df (rw)
Module Alias: “pci:v00008086d0000041Esv00001043sd00008534bc03sc00i00”
Driver Info #0:
Driver Status: i915 is active
Driver Activation Cmd: “modprobe i915”
Config Status: cfg=no, avail=yes, need=no, active=unknown

Please don’t hijack threads since this is Tumbleweed related, please start a new thread with your issue and select the distribution release prefix.

Apologies, that hadn’t occurred to me but does make sense. I was thinking of them both being openSUSE but realize they are considerably different.

I have a similar problem. I just updated to Tumbleweed kernel 4.14.6-1-default and both Suspend (to RAM) and Hibernate (to Disk) no longer work. It is different from the description here in that the desktop appears and the programs are running. But /proc, /sys and /dev are not mounted, and trying to mount them fails with EINVAL. /run and /var/run seem to be missing, too. The command reboot can’t communicate with systemd, and SIGINT to systemd or Alt-Ctrl-Del also doesn’t work. I have to press the power button long enough to turn of the power. The dmesg command doesn’t show any errors.

One difference I noticed is that now the BIOS shows resume from Hibernation, but then the boot menu (GRUB2) appears. Before the update, the BIOS would also show resume from Hibernation, but then it would immediately load the kernel without presenting a boot menu. I don’t know whether this is related to the resume problem, because it also happens with Suspend to RAM, which doesn’t involve the boot manager.

So it seems my problem is unrelated, but in case somebody finds this thread before the bug is fixed, the description and solution can be found at
Just delete /etc/NetworkManager/dispatcher.d/nfs or insert “exit 0” at the top.

I have the exact same problem with the lost hybernate/ suspend after the recent tumbleweed update.
Can I simply put “exit 0” at the top of the above file? “/etc/NetworkManager/dispatcher.d/nfs” ?

Besides, NetworkManager does not allow encription password when a new WIFI is opened.
It must be a bug.


How did you update your TW install ? If through YaST or some desktop applet, open a terninal window and do

su -c 'zypper dup'