Cannot restart with booting directly to Windows

I really like the possibility to restart to Windows grub entry. But this seems to be broken in openSUSE 13.2 with btfrs. When I choose to restart to Windows there is no grub menu offered after the restart, only message “sparse file not allowed” shows for a very short moment and openSUSE is booted. To change the state back to normal I have to delete grubenv so the grub menu is shown by next restart.

Is there a way how to fix this annoyance?

Sounds like the problem with grub not able to write to BTRFS. so a file does not get updated… AFAIK you can’t boot direct to any other OS when using BTRFS and not having a separate non-BTRFS boot partition.

You should report it as bug in Bugzilla. Meantime unless you want to add a non/BTRFS boot you will have to do a restart to get to the grub menu and select Windows.

You can try the work-around that Wolfi gave me when it happened in my 13.1 if you want :

It worked but I thought it was now fixed (I haven’t re-encountered it in 13.2).

The root problem is the same but this is not about hibernation it is about using the quick boot to another OS option. I don’t know of a work around for it at this time.