cannot read from dvds


I am experiencing a problem reading from data DVDs recorded on my desktop pc. If I burn a DVD everything seems to go OK until I try to read it back and I am then told that no disc is detected and it shows the drive to be empty. I can then put the DVD into the drive on my laptop and it is read without any problem and the files can be copied from. I find that DVDs recorded on the laptop are read by the desktop and can be copied from.

So the problem is that the desktop will not read DVDs that have been recorded by it and it shows the drive as empty. But it will read blank DVDs and show them as blank.

Both the desktop and laptop are running version 10.3 of opensuse I have tried both DVD+RW & DVD-R discs with the same result.

I have tried burning with Brasero, Gnomebaker & k3b and they all give the same result.

This problem did not exist when I backed up the desktop 2 months ago (using Gnomebaker) and this backup can still be read by the desktop.

I have used a lens cleaner and that makes no difference!

I would grateful for any guidance on this.