Cannot play sseveral video files

hii,
First, thanks to the friendly experts here, all my issues with opensuse 13.2 have been resolved.
Special thanks to: **wolfi323, Gerry Makaro (Fraser-Bell), miuku, gogalthorp, oldcpu, and john_hudson, **you guys are so helpful and knowledgeable :good:

I just have one issue that’s still present, and am hoping someone will help me solve this final glitch, if this is done, my installation/ setup procedure will be complete and I can start using this notebook like I use my Windows system.

Here’s the problem, my opensuse (13.2) cannot play some of my videos. These videos play fine on Windows.
I did the “1-click multimedia” thing, and it started playing most of my videos, but some still don’t play.
I installed vlc and vlc-plugins from pacman, and vlc is the WORST of the offenders, it refuses to play MOST of the files, which my other players (kaffeine, Mplayer, SMplayer) can play fine!
If I can get VLC up and running, that’d be greeat- I have used it in Windows and I’ll feel at home.
If I cannot, I can switch to SMplayer, I never used it before, but it looks just as good as (if not better than) vlc.
It’s not like none of my videos play. Some play, but some don’t.

After I couldn’t fix it myself (I tried everything a new user coming from Windows will probably try, I did the 1-click multimedia install, ran an online update check using yast, uninstalled/reinstalled vlc, tried installing other players, restarted computer), I ran this command:

zypper install libxine2-codecs ffmpeg lame gstreamer-0_10-plugins-good gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-ugly gstreamer-0_10-plugins-bad-orig-addon gstreamer-0_10-plugins-good-extra gstreamer-0_10-plugins-ugly-orig-addon gstreamer-0_10-plugins-ffmpeg libdvdcss2 flash-player dvdauthor07 gstreamer-plugins-base gstreamer-plugins-bad gstreamer-plugins-bad-orig-addon gstreamer-plugins-good gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon gstreamer-plugins-good-extra gstreamer-0_10-plugins-fluendo_mpegdemux gstreamer-0_10-plugins-fluendo_mpegmux k3b-codecs gecko-mediaplayer vlc smplayer h264enc x264 gstreamer-plugins-libav vlc-codecs

Found it in a post by caf4962 in this page: https://forums.opensuse.org/entry.php/160-openSUSE-13-2-Multimedia-Guide

This didn’t help much either. VLC will open some files now, but frame rates are terrible (it’s as if I’m playing microsoft flight simulator on a pentium 4 with no GPU, but all I’m doing is watching a video, not even an HD video, just a normal video). Other players can open the same files fine (ie, no frame rate drop/lag).
But for some of my files, none of the players work, neither vlc, not anything else…

Tried opening a file with kaffiene, I got this error:
http://s12.postimg.org/irrpwvanh/snapshot7.jpg

Tried opening the same file in SMplayer, it says: “Mplayer has finished unexpectedly, Exit Code: 2”.

If I click on “Show log”, I get this:

*/usr/bin/mpv --no-config --no-quiet --terminal --no-msg-color --slave-broken --no-fs --hwdec=no --sub-auto=fuzzy --vo=xv --ao=pulse --stop-screensaver --no-input-default-bindings --input-x11-keyboard=no --no-input-cursor --cursor-autohide=no --no-keepaspect --wid=85983335 --monitorpixelaspect=1 --osd-scale=1 --sub-ass --embeddedfonts --ass-line-spacing=0 --sub-scale=1 --ass-styles=/home/jheel/.config/smplayer/styles.ass --sub-codepage=utf8:ISO-8859-1 --sub-pos=100 --volume=50 --cache=2048 --osd-level=0 --vf-add=eq --screenshot-template=cap_%F_%p_%02n --audio-channels=2 --af-add=scaletempo --af-add=equalizer=5.3:5.3:5.3:2.9:0.5:-2.3:-4.7:-5.9:-6.5:-6.5 --softvol=yes --softvol-max=110 --ytdl=no --term-playing-msg=MPV_VERSION=${=mpv-version:}
*
INFO_VIDEO_WIDTH=${=width}
INFO_VIDEO_HEIGHT=${=height}
INFO_VIDEO_ASPECT=${=video-aspect}
INFO_VIDEO_FPS=${=fps}
INFO_VIDEO_BITRATE=${=video-bitrate}
INFO_VIDEO_FORMAT=${=video-format}
INFO_VIDEO_CODEC=${=video-codec}
INFO_AUDIO_BITRATE=${=audio-bitrate}
INFO_AUDIO_FORMAT=${=audio-format}
INFO_AUDIO_CODEC=${=audio-codec}
INFO_AUDIO_RATE=${=audio-samplerate}
INFO_AUDIO_NCH=${=audio-channels}
INFO_LENGTH=${=length}
INFO_DEMUXER=${=demuxer}
INFO_TITLES=${=disc-titles}
INFO_CHAPTERS=${=chapters}
INFO_TRACKS_COUNT=${=track-list/count}
METADATA_TITLE=${metadata/by-key/title:}
METADATA_ARTIST=${metadata/by-key/artist:}
METADATA_ALBUM=${metadata/by-key/album:}
METADATA_GENRE=${metadata/by-key/genre:}
METADATA_DATE=${metadata/by-key/date:}
METADATA_TRACK=${metadata/by-key/track:}
METADATA_COPYRIGHT=${metadata/by-key/copyright:}
INFO_MEDIA_TITLE=${=media-title:}

  • –term-status-msg=STATUS: ${=time-pos} / ${=length:0} P: ${=pause} B: ${=paused-for-cache} I: ${=core-idle} /home/jheel/Win_D/Movies/The Big Bang Theory/Season 6/The.Big.Bang.Theory.S06E06.mp4*
    –slave-broken is deprecated (see manpage).
    [input_file] Client connected
    Playing: /home/jheel/Win_D/Movies/The Big Bang Theory/Season 6/The.Big.Bang.Theory.S06E06.mp4
    [ffmpeg/demuxer] mov,mp4,m4a,3gp,3g2,mj2: moov atom not found
    [lavf] avformat_open_input() failed
    [ffmpeg/demuxer] mov,mp4,m4a,3gp,3g2,mj2: moov atom not found
    [lavf] avformat_open_input() failed
    Failed to recognize file format.
    Exiting… (Errors when loading file)

If I open the same file using VLC, sometimes nothing happens (VLC opens and shows playback time as --:–), and sometimes the whole system locks up and I have to press and hold the power button to force a shutdown.

Another example:
If I open this other file in SMplayer, it playes back fine. Clicking on “Show info” in SMplayer gives the following output:

John Mayer - Your Body Is A Wonderland.mp4
General

File /home/jheel/Win_D/Music Videos/John Mayer - Your Body Is A Wonderland.mp4
Size 16501 KB (16 MB)
Length 00:04:16
Demuxer lavf

Clip info

Name John Mayer - Your Body Is A Wonderland.mp4

Video

Resolution 480 x 360
Aspect ratio 1.33333
Format h264
Bitrate 428 kbps
Frames per second 29.970030
Selected codec lavc:h264

Initial Audio Stream

Format aac
Bitrate 96 kbps
Rate 44100 Hz
Channels 2
Selected codec lavc:aac

Audio Streams

# Language Name ID
0 und <empty> 1

If I play the same file in VLC, it plays only the audio, the video part is just black.
While this file is playing in VLC, if I click on show info, I get this:
http://s27.postimg.org/rd5wnwwlf/snapshot9.jpg

http://s7.postimg.org/pvwwj1j97/snapshot10.jpg

No idea what I can try next. Please help.
I’m a windows user, so please use non-techy language in your reply…
Thanks…

Hi,

Please have a look at

http://opensuse-guide.org/codecs.php

or

https://forums.opensuse.org/entry.php/149-openSUSE-13-2-Multi-media-and-Restricted-Format-Installation-Guide

sorry, you have the oneclick thing already but VLC needs the codec too.

You may have to make sure VLC is fully “switched” over to the Packman version with a vendor change, also make sure vlc-codecs is installed properly.

Do a zypper sl -d then look at which repo is Packman and issue: **zypper in --from packmanreponumber vlc vlc-codecs

**So if your repo output looks like this:


2  | ftp.gwdg.de-suse         | Packman Repository                                                         | Yes     | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.2/       

It would be


zypper in --from 2 vlc vlc-codecs

If this fails, try opening a terminal and try launching vlc from the terminal, then try playing a file. Copy paste the output here and wrap it in CODE tags.

Usually installing vlc codecs will solve this.
The only thing i can see stopping you is these files use some sort of DRM, if so you could try to convert these with handbrake to get them working.
Its a pain but with the way some videos are encoded this can happen, especially if you got them from itunes.

personally I think you don’t have packman as the system repo and a lot of packages got pulled from the OSS repo and some libraries got mixed up
if you like the command line you can try

sudo zypper dup --from packman

or better yet see this page and do a full repository vendor change
https://en.opensuse.org/SDB:Vendor_change_update#Full_repository_Vendor_change

I prefer smplayer

What GPU do you have and driver if any?

I’ll reiterate the need already expressed by others to switch on packman with the package switcher

Perhaps also we should see your repos:

zypper lr -d

hello, thanks for replying,
I did the 1-click install from the first like once again, no changes…
Your second link, although it says 13.2 in the url, but lands to a page about 13.1. Nevertheless, I followed those instructions too, and I now have TWO repositories, one says “pacman”, and another says “pacman repository”…
tried the command

zypper install libxine2-codecs ffmpeg lame gstreamer-0_10-plugins-good gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-ugly gstreamer-0_10-plugins-bad-orig-addon gstreamer-0_10-plugins-good-extra gstreamer-0_10-plugins-ugly-orig-addon gstreamer-0_10-plugins-ffmpeg libdvdcss2 flash-player dvdauthor07 gstreamer-plugins-base gstreamer-plugins-bad gstreamer-plugins-bad-orig-addon gstreamer-plugins-good gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon gstreamer-plugins-good-extra gstreamer-0_10-plugins-fluendo_mpegdemux gstreamer-0_10-plugins-fluendo_mpegmux k3b-codecs gecko-mediaplayer vlc smplayer h264enc x264 gstreamer-plugins-libav vlc-codecs

4
it says:
2 Problems:
Problem: nothing provides libass.so.4()(64bit) needed by gstreamer-plugins-bad-1.4.5-80.34.x86_64
Problem: nothing provides libass.so.4()(64bit) needed by gstreamer-0_10-plugins-bad-0.10.23-165.32.x86_64

Problem: nothing provides libass.so.4()(64bit) needed by gstreamer-plugins-bad-1.4.5-80.34.x86_64
Solution 1: do not install gstreamer-plugins-bad-1.4.5-80.34.x86_64
Solution 2: break gstreamer-plugins-bad-1.4.5-80.34.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c):

I selected to break gstreamer (option 2), selected a bunch of vendor changes, it installed new packages, but still no go, cannot play those videos…

I selected the vendor change option in Yast software management, and there are again two pacmans, one is just pacman, another is pacman repository.
“pacman repository” looks like the one for 13.2, i got the “pacman” from your link (probably for 13.1?), selected the option for switching system to “pacman repository”, it again downloaded a bunch of new packages, but still cannot play videos… What do I try next? Thanks for your help, looking forward to hear from you again… :slight_smile:

Please post the output of **zypper sl -d **and wrap it in CODE tags


Like this!

Sounds like you have repositories that are meant for different versions of openSUSE and this will cause issues.

Hello, thanks for your reply, Followed your instructions, this is what happens: SUSE:/home/jheel # zypper sl -d # | Alias | Name | Enabled | Refresh | Priority | Type | URI —±--------------------------±-----------------------------------±--------±--------±---------±-------±--------------------------------------------------------------- 1 | Packman Repository | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /pub/linux/packman/suse/openSUSE_13.2/ 2 | libdvdcss | libdvdcss | Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/13.1/ 3 | libdvdcss repository | libdvdcss repository | Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/13.2/ 4 | openSUSE-13.2-0 | openSUSE-13.2-0 | Yes | Yes | 99 | yast2 | hd:///?device=/dev/disk/by-id/scsi-20001020000060804-part2 5 | packman | packman | Yes | Yes | 99 | rpm-md | http://packman.inode.at/suse/openSUSE_13.1/ 6 | repo-debug | openSUSE-13.2-Debug | Yes | Yes | 99 | yast2 | http://download.opensuse.org/debug/distribution/13.2/repo/oss/ 7 | repo-debug-update | openSUSE-13.2-Update-Debug | No | Yes | 99 | NONE | http://download.opensuse.org/debug/update/13.2/ 8 | repo-debug-update-non-oss | openSUSE-13.2-Update-Debug-Non-Oss | No | Yes | 99 | NONE | http://download.opensuse.org/debug/update/13.2-non-oss/ 9 | repo-non-oss | openSUSE-13.2-Non-Oss | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distribution/13.2/repo/non-oss/ 10 | repo-oss | openSUSE-13.2-Oss | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distribution/13.2/repo/oss/ 11 | repo-source | openSUSE-13.2-Source | Yes | Yes | 99 | yast2 | http://download.opensuse.org/source/distribution/13.2/repo/oss/ 12 | repo-update | openSUSE-13.2-Update | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.2/ 13 | repo-update-non-oss | openSUSE-13.2-Update-Non-Oss | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.2-non-oss/ SUSE:/home/jheel # zypper in --from 1 vlc vlc-codecs Loading repository data… Reading installed packages… ‘vlc’ is already installed. No update candidate for ‘vlc-2.2.0-266.1.x86_64’. The highest available version is already installed. ‘vlc-codecs’ is already installed. No update candidate for ‘vlc-codecs-2.2.0-266.1.x86_64’. The highest available version is already installed. Resolving package dependencies… Nothing to do.the I don’t know how to launch VLC from the shell, I don’t know unix commands, I have used Windows all my life, so if you don’t mind, could you please tell me how do I do that? I can post the shell error here for you guys to see… IMPORTANT: I installed a software called “xine-ui”, and it auto-installed some other files, and then strangely, all the players except VLC, were able to play all my videos. But unfortunately, I got greedy and thogh I should fix VLC too… Someone suggested to reinstall VLC, I uninstalled VLC and VLC-codecs, and then when I searched for vlc again, a “beta” version of VLC showed up in the list. I stupidly thought the beta is new and it might solve the problem with vlc, and downloaded vlc beta with vlc codecs beta. It changed some “shared libraries”, and then my old problem returned again- none of my players (including vlc) can not play those files that they were playing after i installed xine-ui. I reinstalled xine-ui, but this time yast did not auto install anything, it just installed the xine-ui, and of course, the problem didn’t solve. I uninstalled vlc beta + vlc codecs beta and moved back to vlc+vlc codecs, no go, still the same. I tried “vendor change” to “pacman repository”, it again downloaded some applications, but didn’t solve the issue. I’m now feeling like kicking myself- if only i had stopped when my other players were working, and just left vlc alone, I could watch all my movies in linux. Now I don’t know what to do. ****.

Hello,
thanks for your reply,
Followed your instructions, this is what happens:

SUSE:/home/jheel # zypper sl -d # | Alias | Name | Enabled | Refresh | Priority | Type | URI —±--------------------------±-----------------------------------±--------±--------±---------±-------±--------------------------------------------------------------- 1 | Packman Repository | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /pub/linux/packman/suse/openSUSE_13.2/ 2 | libdvdcss | libdvdcss | Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/13.1/ 3 | libdvdcss repository | libdvdcss repository | Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/13.2/ 4 | openSUSE-13.2-0 | openSUSE-13.2-0 | Yes | Yes | 99 | yast2 | hd:///?device=/dev/disk/by-id/scsi-20001020000060804-part2 5 | packman | packman | Yes | Yes | 99 | rpm-md | http://packman.inode.at/suse/openSUSE_13.1/ 6 | repo-debug | openSUSE-13.2-Debug | Yes | Yes | 99 | yast2 | http://download.opensuse.org/debug/distribution/13.2/repo/oss/ 7 | repo-debug-update | openSUSE-13.2-Update-Debug | No | Yes | 99 | NONE | http://download.opensuse.org/debug/update/13.2/ 8 | repo-debug-update-non-oss | openSUSE-13.2-Update-Debug-Non-Oss | No | Yes | 99 | NONE | http://download.opensuse.org/debug/update/13.2-non-oss/ 9 | repo-non-oss | openSUSE-13.2-Non-Oss | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distribution/13.2/repo/non-oss/ 10 | repo-oss | openSUSE-13.2-Oss | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distribution/13.2/repo/oss/ 11 | repo-source | openSUSE-13.2-Source | Yes | Yes | 99 | yast2 | http://download.opensuse.org/source/distribution/13.2/repo/oss/ 12 | repo-update | openSUSE-13.2-Update | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.2/ 13 | repo-update-non-oss | openSUSE-13.2-Update-Non-Oss | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.2-non-oss/ SUSE:/home/jheel # zypper in --from 1 vlc vlc-codecs Loading repository data… Reading installed packages… ‘vlc’ is already installed. No update candidate for ‘vlc-2.2.0-266.1.x86_64’. The highest available version is already installed. ‘vlc-codecs’ is already installed. No update candidate for ‘vlc-codecs-2.2.0-266.1.x86_64’. The highest available version is already installed. Resolving package dependencies… Nothing to do.the

I don’t know how to launch VLC from the shell, I don’t know unix commands, I have used Windows all my life, so if you don’t mind, could you please tell me how do I do that? I can post the shell error here for you guys to see…

IMPORTANT: I installed a software called “xine-ui”, and it auto-installed some other files, and then strangely, all the players except VLC, were able to play all my videos. But unfortunately, I got greedy and thoght I should fix VLC too… Someone suggested to reinstall VLC, I uninstalled VLC and VLC-codecs, and then when I searched for vlc again, a “beta” version of VLC showed up in the list. I stupidly thought the beta is new and it might solve the problem with vlc, and downloaded vlc beta with vlc codecs beta. It changed some “shared libraries”, and then my old problem returned again- none of my players (including vlc) can not play those files that they were playing after i installed xine-ui. I reinstalled xine-ui, but this time yast did not auto install anything, it just installed the xine-ui, and of course, the problem didn’t solve. I uninstalled vlc beta + vlc codecs beta and moved back to vlc+vlc codecs, no go, still the same. I tried “vendor change” to “pacman repository”, it again downloaded some applications, but didn’t solve the issue. I’m now feeling like kicking myself- if only i had stopped when my other players were working, and just left vlc alone, I could watch all my movies in linux. Now I don’t know what to do.

Hii, well, I did uninstall/re-install, but it didn’t help :frowning:
The files are not DRM protected, I downloaded them from utorrent and youtube.
They play fine on my phone as well (Lumia 925, Windows Phone 8.1)

Hii, when you say “pacman”, do you mean “Pacman repository”?
There are two repositories, one is named “pacman”, and the other is “pacman repository”.
I had the “pacman repository” added already, and got my vlc from there.
But following instructions on this thread, i ended up adding the one named only “pacman”. I’m not an expert at all, but if it looks like “pacman” is NOT for 13.2, it’s for 13.1.
Anyway, if I try the command you posted, it encounters like 50 problems, and solutions are to uninstall everything, even amarok.
What shall I do? Remove “Pacman repository” and use “pacman”?
Thanks.

Remove those two repos, they are for 13.1 and can absolutely cause problems. Then make a full vendor switch to Packman.

sudo zypper rr 2 5
sudo zypper dup --from "Packman Repository"

And if you still have vlc-beta installed, you probably should better switch to the stable version again:

sudo zypper in -f vlc

PS: the reason why “zypper dup --from packman” wants to uninstall a lot of packages is that “packman” is the 13.1 repo. So there most likely are conflicts.

hii, smplayer was working, but i broke it while attempting to fix vlc :frowning: :frowning: :frowning:

“pacman” or “pacman repository”?
there are two pacmans…

When i execute your command, it produces the following output:
1 | Packman Repository | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /pub/linux/packman/suse/openSUSE_13.2/ |
2 | libdvdcss | libdvdcss | Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/13.1/ |
3 | libdvdcss repository | libdvdcss repository | Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/13.2/ |
4 | openSUSE-13.2-0 | openSUSE-13.2-0 | Yes | Yes | 99 | yast2 | hd:///?device=/dev/disk/by-id/scsi-20001020000060804-part2 |
5 | packman | packman | Yes | Yes | 99 | rpm-md | http://packman.inode.at/suse/openSUSE_13.1/ |
6 | repo-debug | openSUSE-13.2-Debug | Yes | Yes | 99 | yast2 | http://download.opensuse.org/debug/distribution/13.2/repo/oss/ |
7 | repo-debug-update | openSUSE-13.2-Update-Debug | No | Yes | 99 | NONE | http://download.opensuse.org/debug/update/13.2/ |
8 | repo-debug-update-non-oss | openSUSE-13.2-Update-Debug-Non-Oss | No | Yes | 99 | NONE | http://download.opensuse.org/debug/update/13.2-non-oss/ |
9 | repo-non-oss | openSUSE-13.2-Non-Oss | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distribution/13.2/repo/non-oss/ |
10 | repo-oss | openSUSE-13.2-Oss | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distribution/13.2/repo/oss/ |
11 | repo-source | openSUSE-13.2-Source | Yes | Yes | 99 | yast2 | http://download.opensuse.org/source/distribution/13.2/repo/oss/ |
12 | repo-update | openSUSE-13.2-Update | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.2/ |
13 | repo-update-non-oss | openSUSE-13.2-Update-Non-Oss | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.2-non-oss/

I don’t have a discrete GPU. It’s a laptop, (HP probook 4530s), Intel core i3 2310M@2.1GHz, Windows says “GPU: HD Graphics 3000”, don’t know how to check from suse.
It’s got 8GB of RAM, if that’s important, and Windows can play everything I have. I just checkedd again, rebooted to Windows 8.1, I have two players there, VLC,and gomplayer, both can play the videos I’m having trouble with.
Didn’t install graphics drivers, suse installed them on it’s own, so I don’t know what drivers I have.
Desktop effects seem to be forking fine, I enabled almost all of the effects, and there was no lag or stability issue-it worked great.
Anyway, is this a hardware issue? is my computer incompatible with linux?

IMPORTANT: I installed a software called “xine-ui”, and it auto-installed some other files, and then strangely, all the players except VLC, were able to play all my videos. But unfortunately, I got greedy and thogh I should fix VLC too… Someone suggested to reinstall VLC, I uninstalled VLC and VLC-codecs, and then when I searched for vlc again, a “beta” version of VLC showed up in the list. I stupidly thought the beta is new and it might solve the problem with vlc, and downloaded vlc beta with vlc codecs beta. It changed some “shared libraries”, and then my old problem returned again- none of my players (including vlc) can not play those files that they were playing after i installed xine-ui.
I reinstalled xine-ui, but this time yast did not auto install anything, it just installed the xine-ui, and of course, the problem didn’t solve.
I uninstalled vlc beta + vlc codecs beta and moved back to vlc+vlc codecs, no go, still the same. I tried “vendor change” to “pacman repository”, it again downloaded some applications, but didn’t solve the issue. I’m now feeling like kicking myself- if only i had stopped when my other players were working, and just left vlc alone, I could watch all my movies in linux. Now I don’t know what to do. Danm.

Take a deep breath and look at the list of repositories you copy pasted here.

See, you have 13.1 and 13.2 mixed. You should NEVER mix repositories from different versions of openSUSE, that is why you’re having issues. Only use repositories meant for your distribution version, in this case 13.2, fix the repositories to point to 13.2 versions and you’ll be fine.

Or rather (as I wrote in my previous reply) just remove the 13.1 ones, you have the 13.2 versions anyway.

hello wolfi323, thanks for clearing that up. I moved back to the older vlc from software management so didn’t run the last command.

Here’s what I got (after removing the two repos you pointed out):

jheel@SUSE:~> su
Password:
SUSE:/home/jheel # zypper dup --from “Packman Repository”
Loading repository data…
Reading installed packages…
Computing distribution upgrade…

The following 20 packages are going to be downgraded:
gstreamer-0_10 gstreamer-0_10-32bit gstreamer-0_10-doc gstreamer-0_10-plugin-esd-32bit gstreamer-0_10-plugin-gnomevfs gstreamer-0_10-plugins-bad-orig-addon
gstreamer-0_10-plugins-bad-orig-addon-32bit gstreamer-0_10-plugins-base gstreamer-0_10-plugins-base-32bit gstreamer-0_10-plugins-buzztard gstreamer-0_10-plugins-buzztard-32bit
gstreamer-0_10-plugins-ffmpeg gstreamer-0_10-plugins-ffmpeg-32bit gstreamer-0_10-plugins-fluendo_mpegdemux gstreamer-0_10-plugins-good-32bit gstreamer-0_10-plugins-good-extra-32bit
gstreamer-0_10-utils gstreamer-0_10-utils-unversioned libgstreamer-0_10-0 libgstreamer-0_10-0-32bit

20 packages to downgrade.
Overall download size: 6.3 MiB. Already cached: 0 B After the operation, 91.1 KiB will be freed.
Continue? [y/n/? shows all options] (y): y
Retrieving package libgstreamer-0_10-0-0.10.36-20.3.x86_64 (1/20), 498.0 KiB ( 1.5 MiB unpacked)
Retrieving: libgstreamer-0_10-0-0.10.36-20.3.x86_64.rpm …[done (5.5 KiB/s)]
Retrieving package libgstreamer-0_10-0-32bit-0.10.36-20.3.x86_64 (2/20), 489.2 KiB ( 1.6 MiB unpacked)
Retrieving: libgstreamer-0_10-0-32bit-0.10.36-20.3.x86_64.rpm …[done (5.1 KiB/s)]
Retrieving package gstreamer-0_10-0.10.36-20.3.x86_64 (3/20), 571.1 KiB ( 2.9 MiB unpacked)
Retrieving: gstreamer-0_10-0.10.36-20.3.x86_64.rpm …[done (6.6 KiB/s)]
Retrieving package gstreamer-0_10-plugins-good-32bit-0.10.31-85.2.x86_64 (4/20), 1.2 MiB ( 4.5 MiB unpacked)
Retrieving: gstreamer-0_10-plugins-good-32bit-0.10.31-85.2.x86_64.rpm …[done (5.4 KiB/s)]
Retrieving package gstreamer-0_10-plugin-esd-32bit-0.10.31-85.2.x86_64 (5/20), 55.8 KiB ( 17.7 KiB unpacked)
Retrieving: gstreamer-0_10-plugin-esd-32bit-0.10.31-85.2.x86_64.rpm …[done (5.0 KiB/s)]
Retrieving package gstreamer-0_10-plugins-buzztard-32bit-0.6.0-12.7.x86_64 (6/20), 57.0 KiB (208.7 KiB unpacked)
Retrieving: gstreamer-0_10-plugins-buzztard-32bit-0.6.0-12.7.x86_64.rpm …[done (6.5 KiB/s)]
Retrieving package gstreamer-0_10-plugins-base-32bit-0.10.36-14.3.x86_64 (7/20), 637.0 KiB ( 2.3 MiB unpacked)
Retrieving: gstreamer-0_10-plugins-base-32bit-0.10.36-14.3.x86_64.rpm …[done (6.5 KiB/s)]
Retrieving package gstreamer-0_10-plugins-bad-orig-addon-32bit-0.10.23-165.10.x86_64 (8/20), 147.6 KiB (373.1 KiB unpacked)
Retrieving: gstreamer-0_10-plugins-bad-orig-addon-32bit-0.10.23-165.10.x86_64.rpm …[done (5.9 KiB/s)]
Retrieving package gstreamer-0_10-plugins-good-extra-32bit-0.10.31-85.2.x86_64 (9/20), 90.8 KiB (145.7 KiB unpacked)
Retrieving: gstreamer-0_10-plugins-good-extra-32bit-0.10.31-85.2.x86_64.rpm …[done (6.1 KiB/s)]
Retrieving package gstreamer-0_10-32bit-0.10.36-20.3.x86_64 (10/20), 132.7 KiB (332.2 KiB unpacked)
Retrieving: gstreamer-0_10-32bit-0.10.36-20.3.x86_64.rpm …[done (6.0 KiB/s)]
Retrieving package gstreamer-0_10-plugins-ffmpeg-32bit-0.10.13-2000.2.x86_64 (11/20), 126.4 KiB (279.6 KiB unpacked)
Retrieving: gstreamer-0_10-plugins-ffmpeg-32bit-0.10.13-2000.2.x86_64.rpm …[done (7.6 KiB/s)]
Retrieving package gstreamer-0_10-plugins-buzztard-0.6.0-12.7.x86_64 (12/20), 51.9 KiB (165.5 KiB unpacked)
Retrieving: gstreamer-0_10-plugins-buzztard-0.6.0-12.7.x86_64.rpm …[done (4.3 KiB/s)]
Retrieving package gstreamer-0_10-plugins-bad-orig-addon-0.10.23-165.10.x86_64 (13/20), 152.7 KiB (391.0 KiB unpacked)
Retrieving: gstreamer-0_10-plugins-bad-orig-addon-0.10.23-165.10.x86_64.rpm …[done (7.0 KiB/s)]
Retrieving package gstreamer-0_10-plugins-base-0.10.36-14.3.x86_64 (14/20), 727.7 KiB ( 2.6 MiB unpacked)
Retrieving: gstreamer-0_10-plugins-base-0.10.36-14.3.x86_64.rpm …[done (5.5 KiB/s)]
Retrieving package gstreamer-0_10-plugins-fluendo_mpegdemux-0.10.71-2.2.x86_64 (15/20), 87.6 KiB (287.2 KiB unpacked)
Retrieving: gstreamer-0_10-plugins-fluendo_mpegdemux-0.10.71-2.2.x86_64.rpm …[done (6.0 KiB/s)]
Retrieving package gstreamer-0_10-utils-0.10.36-20.3.x86_64 (16/20), 73.6 KiB (128.4 KiB unpacked)
Retrieving: gstreamer-0_10-utils-0.10.36-20.3.x86_64.rpm …[done (5.1 KiB/s)]
Retrieving package gstreamer-0_10-plugins-ffmpeg-0.10.13-2000.2.x86_64 (17/20), 140.9 KiB (290.7 KiB unpacked)
Retrieving: gstreamer-0_10-plugins-ffmpeg-0.10.13-2000.2.x86_64.rpm …[done (6.6 KiB/s)]
Retrieving package gstreamer-0_10-doc-0.10.36-24.7.x86_64 (18/20), 1.0 MiB ( 8.1 MiB unpacked)
Retrieving: gstreamer-0_10-doc-0.10.36-24.7.x86_64.rpm …[done (5.9 KiB/s)]
Retrieving package gstreamer-0_10-plugin-gnomevfs-0.10.36-14.3.x86_64 (19/20), 55.0 KiB ( 39.3 KiB unpacked)
Retrieving: gstreamer-0_10-plugin-gnomevfs-0.10.36-14.3.x86_64.rpm …[done (6.0 KiB/s)]
Retrieving package gstreamer-0_10-utils-unversioned-0.10.36-20.3.x86_64 (20/20), 35.6 KiB ( 14.7 KiB unpacked)
Retrieving: gstreamer-0_10-utils-unversioned-0.10.36-20.3.x86_64.rpm …[done (5.5 KiB/s)]
Checking for file conflicts: …[done]
( 1/20) Installing: libgstreamer-0_10-0-0.10.36-20.3 …[done]
( 2/20) Installing: libgstreamer-0_10-0-32bit-0.10.36-20.3 …[done]
( 3/20) Installing: gstreamer-0_10-0.10.36-20.3 …[done]
( 4/20) Installing: gstreamer-0_10-plugins-good-32bit-0.10.31-85.2 …[done]
( 5/20) Installing: gstreamer-0_10-plugin-esd-32bit-0.10.31-85.2 …[done]
( 6/20) Installing: gstreamer-0_10-plugins-buzztard-32bit-0.6.0-12.7 …[done]
( 7/20) Installing: gstreamer-0_10-plugins-base-32bit-0.10.36-14.3 …[done]
( 8/20) Installing: gstreamer-0_10-plugins-bad-orig-addon-32bit-0.10.23-165.10 …[done]
( 9/20) Installing: gstreamer-0_10-plugins-good-extra-32bit-0.10.31-85.2 …[done]
(10/20) Installing: gstreamer-0_10-32bit-0.10.36-20.3 …[done]
(11/20) Installing: gstreamer-0_10-plugins-ffmpeg-32bit-0.10.13-2000.2 …[done]
(12/20) Installing: gstreamer-0_10-plugins-buzztard-0.6.0-12.7 …[done]
(13/20) Installing: gstreamer-0_10-plugins-bad-orig-addon-0.10.23-165.10 …[done]
(14/20) Installing: gstreamer-0_10-plugins-base-0.10.36-14.3 …[done]
(15/20) Installing: gstreamer-0_10-plugins-fluendo_mpegdemux-0.10.71-2.2 …[done]
(16/20) Installing: gstreamer-0_10-utils-0.10.36-20.3 …[done]
(17/20) Installing: gstreamer-0_10-plugins-ffmpeg-0.10.13-2000.2 …[done]
(18/20) Installing: gstreamer-0_10-doc-0.10.36-24.7 …[done]
(19/20) Installing: gstreamer-0_10-plugin-gnomevfs-0.10.36-14.3 …[done]
(20/20) Installing: gstreamer-0_10-utils-unversioned-0.10.36-20.3 …[done]

Videos are still not playing. VLC beta broke ALL my other players which I somehow managed to fix accidentally (by downloading xine-ui).
What now??? :((

vlc-beta should not have any influence at all on any other player.

Can you please clarify of which other players you are talking of?
For totem e.g. you’d need the gstreamer-plugins (not gstreamer-0_10), in particular gstreamer-plugins-bad-orig-addon, gstreamer-plugins-ugly-orig-addon, and gstreamer-plugins-libav.

And try to set some other output device in those other players’ settings (and in VLC as well).

Maybe try to run one of the other players in a terminal window and post the output.

Try to uninstall vdpau-video and libvdpau_va_gl1 if they are installed.

MPlayer should just work though, as it brings in its own stuff. But it might fail as well if there’s a video output issue.

And you still haven’t mentioned here what graphics chip and driver you are using although being asked about that. You can’t expect people to search through your other posts to get that information.

Hi,
thanks for replying wolfi, libvdpau_va_gl1 was already installed, vdpau-video waasn’t-I installed it now.
I’m sure you’re right, but videos were working in mplayer, and they stopped working right after i installed vlc-beta, so i kinda linked those two events together… like i said earlier, m not an expert at all.

I did mention my graphics in this thread, in a reply to caf4926, post# 13, but I’ll write again:
Computer: HP ProBook 4530s
CPU: Intel Core i3-2310M @2.10GHz.
Graphics: Intel HD Graphics 3000 (no discrete GPU)
RAM: 8 GB.

Those Videos are still not working - I reboot to Windows, they work fine, I reboot to Suse, they fail…

My other players are:
SMplayer
Kaffeine
QtAV Player
QMPlay2
Gxine
Xine
MPlayer.

Sorry if i made myself sound “demanding”. I’m not. This isn’t Microsoft. I haven’t paid for the OS, or the support, and hence I am not entitled to anything, I am just hoping you guys will fix this for me, out of the goodness of your hearts. There’s no one else I can ask for help. HP Support won’t help because this computer came with Windows 8.1. I don’t know a single person personally who uses any flavour of Linux- my neighbourhood its Microsoft’s playground, “Windows Everywhere”, even the shop where i purchased the computer from won’t help- the tech in the shop simply admitted he wants to help but he doesn’t know anything about Linux :frowning:

If you don’t mind, is there something else I can try? I have checked for updates, there are not updates available.

I don’t think the GPU will be an issue then in your case since it is a standard fare Intel which should work no problem.

If you now have your repos in order and have switched to Packman. All should be good.

Just one little thing to consider. In Win 8, you must make sure it is really Shutting Down. Go to the power settings from the battery icon in the tray and disable Quick Start (you may have to toggle a check box to enable access to all options) and also where it has ‘Choose what to do when the Power button is pressed’ select Power Off.
Now, when you switch to Linux, Power Off by pressing the Power button.
This will ensure a trouble free experience in Linux.