cannot play music after upgrading to KDE 4.4.3

I upgraded to KDE 4.4.3 this morning, but after that Amarok (with Xine backend) does not play music any more - track is progressed, but only silence comes out of the speakers.

I tried Gnome music players too, but none of them plays anything.

I installed GStreamer with different kinds of plugins and switched Phono backend to gstreamer. When I start Amarok now, it says I have no MP3 support, so it has to be installed. It does it, restarts itself and it can play audio again. After restarting, having no MP3 support is reported again.

Any clues what has happened?

Aha, I deleted pulseaudio packages, killed pulseaudio and now I’m able to use Xine backend again.

Same happened to me.
Yesterday update introduced the problem.
I have it now at GStreamer but i will try your approach.

Do another update today in KDE: Desktop repository and xine is working again,

Same problem here but updating doesn’t solve anything.

Works OK with gstreamer backend but not xine.

Any idea ?

I got bit by this one as well . . . :open_mouth:

I’m Running OS 11.2 x32-bit, KDE 4.4.3 and after the update ran this morning: no sound.

System came up saying one of the sound devices was missing, but the remaining 2 not grayed out don’t work. This happens in both Xine & Gstreamer. Not only music is affected, but the system sounds are out also.

Yes, still problem exist with latest update.
I guess it was fixed in between

I have the same problem


I fixed with:

sudo setup-pulseaudio --disable


in Yast2 -> Hardware -> Sound: Delete and Edit again the sound card.


It’s a workaround. It doesn’t solve the problem with pulseaudio…

A friend has the same problem on debian so I think it’s phonon 4.4.1 related.

Today’s update fixed the issue.

I had the same problem: no sounds at all after upgrading to KDE 4.4.3. But after disabling pulseaudio, editing the sound card and rebooting all sounds have returned!

Thank you!

Confirm, the new update fixed phonon and pulseaudio. :slight_smile: